Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 409285 - net-wireless/wpa_supplicant fails to build with GCC 4.7 - error: ‘getopt’ was not declared in this scope
Summary: net-wireless/wpa_supplicant fails to build with GCC 4.7 - error: ‘getopt’ was...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Bjarke Istrup Pedersen (RETIRED)
URL:
Whiteboard:
Keywords: PATCH
: 416877 (view as bug list)
Depends on:
Blocks: gcc-4.7
  Show dependency tree
 
Reported: 2012-03-22 09:15 UTC by Branko Badrljica
Modified: 2012-05-22 07:17 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (eminfo.txt,7.70 KB, text/plain)
2012-03-22 09:16 UTC, Branko Badrljica
Details
failed emerge logfile (net-wireless:wpa_supplicant-0.7.3-r5:20120322-102428.log,16.86 KB, text/plain)
2012-03-22 09:17 UTC, Branko Badrljica
Details
patch file (wpa_supplicant-gcc470.patch,407 bytes, patch)
2012-03-22 09:17 UTC, Branko Badrljica
Details | Diff
new ebuild with epatch line (wpa_supplicant-0.7.3-r6.ebuild,8.77 KB, text/plain)
2012-03-22 09:18 UTC, Branko Badrljica
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Branko Badrljica 2012-03-22 09:15:53 UTC
I have made a patch and changed ebuild. It compiles fine- I did not test its functionality yet.



Reproducible: Always
Comment 1 Branko Badrljica 2012-03-22 09:16:13 UTC
Created attachment 306273 [details]
emerge --info
Comment 2 Branko Badrljica 2012-03-22 09:17:08 UTC
Created attachment 306275 [details]
failed emerge logfile
Comment 3 Branko Badrljica 2012-03-22 09:17:58 UTC
Created attachment 306277 [details, diff]
patch file
Comment 4 Branko Badrljica 2012-03-22 09:18:21 UTC
Created attachment 306279 [details]
new ebuild with epatch line
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2012-03-23 14:57:01 UTC
Comment on attachment 306279 [details]
new ebuild with epatch line

--- wpa_supplicant-0.7.3-r5.ebuild      2012-03-11 19:18:55.000000000 +0100
+++ -   2012-03-23 15:56:53.377828081 +0100
@@ -88,6 +88,7 @@
        epatch "${FILESDIR}/${P}-dbus-api-changes.patch"
        # bug (374089)
        epatch "${FILESDIR}/${P}-dbus-WPAIE-fix.patch"
+       epatch "${FILESDIR}/wpa_supplicant-gcc470.patch"
 }
 
 src_configure() {
Comment 6 Ryan Hill (RETIRED) gentoo-dev 2012-05-22 06:25:39 UTC
*** Bug 416877 has been marked as a duplicate of this bug. ***
Comment 7 Bjarke Istrup Pedersen (RETIRED) gentoo-dev 2012-05-22 07:17:43 UTC
Fixed in both 0.7.5 and 1.0 - please allow a few hours before syncing and testing.