Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 408153 - [gnustep overlay] gnustep-apps/sogo-2.1.1b version bump
Summary: [gnustep overlay] gnustep-apps/sogo-2.1.1b version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 1 vote (vote)
Assignee: Gnustep herd
URL: http://www.sogo.nu/english/downloads/...
Whiteboard:
Keywords:
: 364377 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-14 11:17 UTC by tanstaafl@libertytrek.org
Modified: 2014-02-04 10:52 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
sogo-1.3.14.ebuild (sogo-1.3.14.ebuild,4.70 KB, text/plain)
2012-04-13 16:10 UTC, Tobias Wallura
Details
sope-1.3.14.ebuild (sope-1.3.14.ebuild,6.32 KB, text/plain)
2012-04-13 16:11 UTC, Tobias Wallura
Details
sogod.confd (sogod.confd,2.96 KB, text/plain)
2012-04-13 16:12 UTC, Tobias Wallura
Details
sogod.initd (sogod.initd,1.70 KB, text/plain)
2012-04-13 16:12 UTC, Tobias Wallura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tanstaafl@libertytrek.org 2012-03-14 11:17:30 UTC
It would be really nice to see this ebuild updated for the latest version 1.3.12c, since this new version is the first one that works with the new 10.0ESR release of Thunderbird+Lightning, and more importantly no longer needs the 'Lightning Inverse Edition', and works with the standard Lightning for TB 10.0...

Also, if someone is interested, my company may be willing to sponsor support for maintaining the ebuild, with a goal of getting it added to the official portage tree.

Reproducible: Always
Comment 1 tanstaafl@libertytrek.org 2012-03-14 11:19:34 UTC
I am not a programmer, but maybe the older ebuild for 1.3.7a could be modified?

https://bugs.gentoo.org/attachment.cgi?id=272369
Comment 2 tanstaafl@libertytrek.org 2012-04-13 12:02:50 UTC
Hello...

Changing the Bug Title because the first rc of the new 2.0 is out, is as stable as the 1.3.x series, but also includes the new full/native Outlook/MAPI support, so Outlook no longer requires a plugin.

Would the current maintainer for the SOGo ebuild be interested in any assistance from Inverse? We will soon be rolling out a new SOGo install, and will be buying some official support from Inverse, and may be willing to pay them to assist or even take over maintenance of the SOGo ebuild/package on an ongoing basis.
Comment 3 tanstaafl@libertytrek.org 2012-04-13 12:08:50 UTC
Ok, changed the title to reflect two ebuilds - after thinking about it, if we do end up paying Inverse to maintain the ebuilds, we will ask them to maintain both a 1.3.x and a 2.0.x ebuild at least for the next few months until 2.0 is stable and Inverse officially recommends it over the 1.3.x series...

So, again, would like to hear from someone at gentoo (don't know how this kind of thing works) on whether or not there is interest in some official support from Inverse in maintaining these ebuilds and keeping them current.

Thanks...
Comment 4 Tobias Wallura 2012-04-13 16:05:25 UTC
(In reply to comment #1)
> I am not a programmer, but maybe the older ebuild for 1.3.7a could be
> modified?

A simple rename from sogo-1.3.7a.ebuild to sogo-1.3.14.ebuild does the trick.
Comment 5 Tobias Wallura 2012-04-13 16:10:30 UTC
Created attachment 308777 [details]
sogo-1.3.14.ebuild

gnustep-apps/sogo-1.3.14.ebuild

Make sure to emerge gnustep-base and gnustep-make with empty LDFLAGS, or at least without --as-needed.
This can be achieved by creating the following files:

/etc/portage/package.env/packages:
> gnustep-base/gnustep-make empty-ldflags
> gnustep-base/gnustep-base empty-ldflags

/etc/portage/env/empty-ldflags:
> LDFLAGS=""
Comment 6 Tobias Wallura 2012-04-13 16:11:39 UTC
Created attachment 308779 [details]
sope-1.3.14.ebuild

gnustep-libs/sope-1.3.14.ebuild
Comment 7 Tobias Wallura 2012-04-13 16:12:15 UTC
Created attachment 308781 [details]
sogod.confd
Comment 8 Tobias Wallura 2012-04-13 16:12:31 UTC
Created attachment 308783 [details]
sogod.initd
Comment 9 Vlad 2012-11-22 15:43:06 UTC
Is there any updates regarding ebuilds for 2.x versions of SOGo? Is somebody successfully installed SOGo on Gentoo?
Comment 10 Bernard Cafarelli gentoo-dev 2014-01-29 15:30:54 UTC
*** Bug 364377 has been marked as a duplicate of this bug. ***
Comment 11 Bernard Cafarelli gentoo-dev 2014-02-04 10:52:41 UTC
gnustep-apps/sogo-2.1.1b (and matching sope) is now in gnustep overlay with rewritten, simpler ebuilds. It was only tested with postgresql database and the web interface without apache redirection (via 127.0.0.1:20000)

Still, as the build system is now really really simpler, this could even go in main tree :) Thanks everyone in this bugreport for your work,