Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 408147 - app-admin/eselect-python with FEATURES="nomac nodoc" - eselect python does not set man page (...)
Summary: app-admin/eselect-python with FEATURES="nomac nodoc" - eselect python does no...
Status: RESOLVED DUPLICATE of bug 399139
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 10:28 UTC by BRULE Herman
Modified: 2014-01-19 01:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BRULE Herman 2012-03-14 10:28:44 UTC
Hello, for my ssd I have put:
FEATURES="noman noinfo nodoc"

But that's block all python version change:
amber user # eselect python list
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.2
amber user # eselect python set 1
Couldn't find a man page for python2.7; skipping.

Can you fix it?

Reproducible: Always

Steps to Reproduce:
1. FEATURES="noman noinfo nodoc"
2. emerge -eav world
3. eselect python set 1
Comment 1 Ben Kohler gentoo-dev 2012-03-14 16:13:17 UTC
It's just skipping the manpage switch, since none exist.  It's still setting the active python version like it should.
Comment 2 Jeroen Roovers gentoo-dev 2012-03-14 18:18:08 UTC
Looks like unsurprising and desirable behaviour to me.
Comment 3 BRULE Herman 2012-03-14 19:23:10 UTC
because just with the console output, it's hard to do the difference of real error, and warning. Can you add warning before? or drop this text (the user know it's haven't the man, it's have choice it)
Comment 4 Mike Gilbert gentoo-dev 2014-01-19 01:38:20 UTC

*** This bug has been marked as a duplicate of bug 399139 ***