Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 399139 - app-admin/eselect-python - Can't select python without man page
Summary: app-admin/eselect-python - Can't select python without man page
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
: 408147 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-17 07:45 UTC by BRULE Herman
Modified: 2014-01-19 01:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BRULE Herman 2012-01-17 07:45:53 UTC
I try change to right version of python into my minimal system without man page, doc, ...

Reproducible: Always

Steps to Reproduce:
1. emerge python with in make.conf: FEATURES="... noman noinfo nodoc ..."
2. eselect python set python3.1
Actual Results:  
eselect python set python2.7
Couldn't find a man page for python2.7; skipping.

Expected Results:  
Work in all case (else block important switching)
Comment 1 Jeroen Roovers gentoo-dev 2012-01-17 14:56:48 UTC
Indeed. Why does it say "skipping" and then do a return 1?
Comment 2 Mike Gilbert gentoo-dev 2014-01-19 01:37:16 UTC
This is not treated as a fatal condition, and the python interpreter is correctly changed.

Nothing to fix here.
Comment 3 Mike Gilbert gentoo-dev 2014-01-19 01:38:21 UTC
*** Bug 408147 has been marked as a duplicate of this bug. ***