Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 406773 - =sci-mathematics/maxima-5.34.1: Please stabilize
Summary: =sci-mathematics/maxima-5.34.1: Please stabilize
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement with 1 vote (vote)
Assignee: Gentoo Science Mathematics related packages
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 485632 511170
Blocks: 502978 527998
  Show dependency tree
 
Reported: 2012-03-03 13:59 UTC by Jeremy Murphy
Modified: 2015-04-21 19:23 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Murphy 2012-03-03 13:59:44 UTC
The latest stable version of Maxima is from 2009 -- please stabilize this one (5.26.0)!  Thanks.


Reproducible: Always
Comment 1 Jeremy Murphy 2012-11-11 04:25:27 UTC
May as well go for stabilizing 5.28.0.
Comment 2 Nuno Silva 2012-12-29 19:16:24 UTC
5.28.0 compiles and runs here (amd64). As I can reproduce bug 448242 with 5.29.1, this seems to be the latest version with no known bugs.

Meanwhile, as the stable version is not only old, but it also doesn't compile (it is affected by bug 411453, which was only fixed for 5.28.0), I suppose stabilizing 5.28.0 would be a good idea.
Comment 3 Jeremy Murphy 2013-03-09 13:08:35 UTC
Based on what I read in bug #448242 I do not see a reason to hold off on stabilizing 5.29.1.  There also does not seem to be any progress in stabilizing 5.28.0 anyway.
Comment 4 Pacho Ramos gentoo-dev 2014-02-08 21:25:22 UTC
What about 5.32.1-r1?
Comment 5 Jeremy Murphy 2014-02-09 02:33:25 UTC
(In reply to Pacho Ramos from comment #4)
> What about 5.32.1-r1?

Well, there seems to be a complex web of dependencies involving sbcl, asdf and gentoo-init that probably need stabilization first.  So until that is resolved, the version mentioned here is moot.
Comment 6 Pacho Ramos gentoo-dev 2014-02-15 20:47:25 UTC
I think the easier way to try to solve this is to open bugs for pending packages that need to go to stable before and try to go with latest version. That bug reports would be opened against each downstream maintainer and should block this one.

The other way will only delay things more and more instead of finally fixing them
Comment 7 Pacho Ramos gentoo-dev 2014-11-02 12:12:14 UTC
This is needed for texinfo stabilization... also, probably even a newer version could be stabilized here too :/
Comment 8 Nuno Silva 2014-11-02 17:40:29 UTC
Which version would you stabilize? 5.34.1?
Comment 9 Jeremy Murphy 2014-11-03 23:10:16 UTC
(In reply to Nuno Silva from comment #8)
> Which version would you stabilize? 5.34.1?

Might depend on which version of sbcl, asdf, uiop, etc are required.  If stabilizing version x requires stabilizing all of the above, then maybe it is better to go with stabilizing version x - 1.

Someone feel like making a version dependency matrix so we can easily see what is required for stabilizing a given version of maxima?  :)

This blocks texinfo???  How does that work?
Comment 10 Pacho Ramos gentoo-dev 2014-11-04 08:33:17 UTC
Per bug 465862 and bug 466730 looks like older versions are broken by texinfo-5
Comment 11 Nuno Silva 2014-11-13 22:51:27 UTC
I am doing some testing, but so far it seems that the newest ~arch versions of maxima and imaxima compile and run fine on amd64 and x86, with the stable sbcl and asdf for these architectures.

So, at least according to my testing:
- imaxima-1.0-r3 needs to be stabilized together with maxima, if we plan to stabilize >=maxima-29
- the highest versions of both maxima and imaxima seem to work with stable sbcl

But I didn't test with other lisp implementations.
Comment 12 Mark Wright gentoo-dev 2014-11-14 02:51:23 UTC
Changed Summary from:
=sci-mathematics/maxima-5.32.1-r1: Please stabilize
to:
=sci-mathematics/maxima-5.34.1: Please stabilize

arches: please stabilize sci-mathematics/maxima-5.34.1
Comment 13 Agostino Sarubbo gentoo-dev 2015-01-31 14:15:56 UTC
amd64 stable
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-03-29 14:01:13 UTC
x86 stable
Comment 15 Pacho Ramos gentoo-dev 2015-04-21 19:23:33 UTC
ppc stable, closing