Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 401437 - net-nntp/pan-0.135 fails to build with >=dev-libs/glib-2.31: #error "Only <glib.h> can be included directly.
Summary: net-nntp/pan-0.135 fails to build with >=dev-libs/glib-2.31: #error "Only <gl...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: net-news Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-01-30 06:59 UTC by Mathias
Modified: 2012-04-08 02:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias 2012-01-30 06:59:58 UTC
Compile failed because the new glib version.

Reproducible: Always

Steps to Reproduce:
1. emerge net-nntp/pan

Actual Results:  
i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I../..  -I../.. -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -pthread -I/usr/include/gmime-2.6 -I/usr/include/gpgme -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include     -march=prescott -O2 -pipe -fomit-frame-pointer -c -o progress.o progress.cc
In file included from file-util.h:28:0,
                 from line-reader.cc:8:
/usr/include/glib-2.0/glib/gtypes.h:28:2: #error "Only <glib.h> can be included directly."
Comment 1 biohazrd 2012-04-07 20:45:32 UTC
glib >2.31.0 breaks a lot of packages  Each package needs to be patched to account for the changes with the way includes are handled. The following packages on my system fail with the same error:

app-accessibility/gnome-speech-0.4.25-r1
media-sound/easytag-2.1.7-r1
net-irc/xchat-2.8.8-r2
net-nntp/pan-0.135
x11-libs/gksu-2.0.2

There was one other but the individual package got patched in the tree and it compiled fine.  I suspect all the packages affected need to be patched and there are bug reports opened for pan and xchat that I see. I had to have 2.32.0 unmasked for gnome 3.2.1
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-04-08 00:01:09 UTC
(In reply to comment #1)
> glib >2.31.0 breaks a lot of packages  Each package needs to be patched to
> account for the changes with the way includes are handled. The following
> packages on my system fail with the same error:
> 
> app-accessibility/gnome-speech-0.4.25-r1
> media-sound/easytag-2.1.7-r1
> net-irc/xchat-2.8.8-r2
> net-nntp/pan-0.135
> x11-libs/gksu-2.0.2

I have fixed app-accessibility/gnome-speech and x11-libs/gksu in cvs, and filed bug #411195 with a patch for xchat. On my machine, easytag builds fine with glib-2.32, so I suspect you are experiencing a different issue with it, namely bug #409281.

In the future, please file *separate* bugs for each package that fails due to glib-2.32. That way, they will be noticed by the maintainers of the affected packages, many of whom are not be subscribed to a bug about net-nntp/pan.
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-04-08 02:24:43 UTC
Thank you for reporting; fixed in cvs without a revision bump. (I used Dominique Leuenberger's patch because the corresponding commit from upstream git also included other changes that appeared to be somewhat invasive.)

>  08 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org> pan-0.135.ebuild,
>  +files/pan-0.135-glib-2.31.patch:
>  Fix building with >=glib-2.31 (bug #401437, thanks to Mathias for reporting).