Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 398253 - net-fs/openafs-1.6.1_pre1/1.6.1 does not build against 3.1.6/3.2.0-r1 kernel and heimdal-1.5.1-r1/1.5.2
Summary: net-fs/openafs-1.6.1_pre1/1.6.1 does not build against 3.1.6/3.2.0-r1 kernel ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andrej Filipcic
Depends on:
Reported: 2012-01-09 14:29 UTC by Mike Hammill
Modified: 2015-05-05 15:08 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

build log (net-fs:openafs-1.6.1_pre1:20120108-231638.log,733.05 KB, text/plain)
2012-01-09 15:20 UTC, Mike Hammill
build log (against 3.2.0-r1 gentoo-sources) (net-fs:openafs-1.6.1_pre1:20120109-153030.log,733.64 KB, text/plain)
2012-01-09 15:45 UTC, Mike Hammill

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Hammill 2012-01-09 14:29:09 UTC
Although net-fs/openafs-kernel-1.6.1_pre1 *does* build against gentoo-sources 3.0.6 and heimdal-1.5.1-r1 (both stable), net-fs/openafs-1.6.1_pre1 fails to build.  According to Bug 397845, it should build against a 3.2 kernel.  It's not clear to me if it is supposed to build against stable 3.0.6, but thought I should report that it does not in case it is assumed it works against anything in the 3+ series.

Reproducible: Always

Steps to Reproduce:
1. Use all stable x86_64 system to build latest openafs.  Kernel ebuild builds, but userspace part fails to build.

# emerge --info openafs
Portage (default/linux/amd64/10.0/no-multilib, gcc-4.5.3, glibc-2.13-r4, 3.0.6-gentoo x86_64)
                        System Settings
System uname: Linux-3.0.6-gentoo-x86_64-Intel-R-_Pentium-R-_4_CPU_3.00GHz-with-gentoo-2.1
Timestamp of tree: Mon, 09 Jan 2012 00:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.6 [disabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo bleeding-edge sunrise betagarden mhammill
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/tex
mf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
EMERGE_DEFAULT_OPTS="--autounmask=y --autounmask-write"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US en_GB sv sv_SE"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/bleeding-edge /var/lib/layman/sunrise /var/lib/layman/betagarden /usr/local/portage"

USE="X aac aalib acl afs alsa amd64 apache2 apng aspell assistant autoipd avahi bash-completion berkdb bidi branding bzip2 cairo caps cdda cddb cdparanoia cdr cgi cli consolekit contrib cracklib crypt cups curl cvs cxx dbus desktop-integ
ration device-mapper dga dia djvu docbook dot dri dts dv dvd dvi dvi2tty dvipdfm emacs encode exif extensions extra extras fam ffmpeg fftw flac fltk fontconfig fortran fuse gcrypt gdbm gdu geoip gif gimp git gnuplot gnutls gpm graphics g
raphviz gs gstreamer gtk gtk3 hddtemp helpers hpn hwdb hyphenation iconv icu idn imagemagick imlib ipv6 jai java java6 javascript jpeg kerberos kpathsea lame latex latex3 lcms ldap libcaca libnotify libxml2 lightning live lm_sensors lua 
lxde lyx m17n-lib mad mailwrapper matroska md5sum mmx mng modules mp3 mpeg mpi mpm-worker mudflap nagios-ntp nagios-ssh nano-syntax ncurses network network-cron nls no-old-linux nptl nptlonly nsplugin nss ogg opencl opengl openmp openssl
 pam pcre pdf perl plotutils png policykit postscript ppds pppd pulseaudio python qt3support qt4 quicktime raw rcs readline rtf ruby sasl schroedinger screenshot secure-delete sensord session skins sound spell sse sse2 ssh ssl startup-no
tification stream subversion svg sysfs system-sqlite system-v8 t1lib tcl tcpd templates tex4ht theora threads tiff tk tor tordns truetype twolame udev unicode upnp v4l v4l2 vhosts vlm vorbis webdav webkit wmf wxwidgets x264 xattr xft xin
erana xorg xscreensaver xulrunner xv xvmc zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route 
share shm softvol" APACHE2_MODULES="access actions alias asis auth auth_anon auth_dbm auth_digest authz_default authz_host autoindex cache case_filter_in case_filter cern_meta cgi cgid charset_lite dav dav_fs dav_lock deflate dir disk_ca
che echo env expires ext_filter file_cache filter headers imap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_connect proxy_ftp proxy_http rewrite setenvif so speling status unique_id unique_id userdir us
ertrack vhost_alias authn_file authz_groupfile authz_user" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap sysl
og" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES
="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US en_GB sv sv_SE" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel radeon" XTABLES_AD
DONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

net-fs/openafs-1.6.0 was built with the following:
USE="kerberos pam -doc"

eix -I heimdal shows 1.5.1-r1

Comment 1 Mike Hammill 2012-01-09 14:37:09 UTC
Correction to original report a few minutes ago.  The building of openafs failed against 3.1.6 not 3.0.6.  (i.e., I was still running 3.0.6, but the kernel I was building against was 3.1.6).
Comment 2 Mike Hammill 2012-01-09 14:39:05 UTC
I received the same build error in an environment where 3.1.6 was the running kernel and also the one being built against on another x86_64 machine.  I will now test against a 3.2 kernel.
Comment 3 Mike Hammill 2012-01-09 15:20:45 UTC
Created attachment 298397 [details]
build log
Comment 4 Eray Aslan gentoo-dev 2012-01-09 15:27:16 UTC
heimdal part is duplicate of bug #356079.  And kernel part is probably a duplicate of bug #398111.
Comment 5 Mike Hammill 2012-01-09 15:42:08 UTC
(In reply to comment #4)
> heimdal part is duplicate of bug #356079.  And kernel part is probably a
> duplicate of bug #398111.

As far as the heimdal part, I am building against heimdal 1.5.1-r1 (NOT 1.4.1 as in the bug you say this is a duplicate of, bug #356079).  That bug has nothing to do with the issue I have.  In fact, heimdal 1.5.1-r1 builds perfectly against openafs-1.6.0 and gentoo-sources-3.0.6 or 3.1.6.  I am talking about a modern heimdal here, not the old krb4 stuff.

As for bug #398111, I can now report that the newest openafs-1.6.1_pre1 fails to build against gentoo-sources-3.2.0-gentoo-r1 just as I have described above for gentoo-sources-3.1.6.
Comment 6 Mike Hammill 2012-01-09 15:45:49 UTC
Created attachment 298399 [details]
build log (against 3.2.0-r1 gentoo-sources)
Comment 7 Andrej Filipcic 2012-01-09 16:25:19 UTC
Something is strange here. The build log reports failure in:

make[3]: Entering directory `/var/tmp/portage/net-fs/openafs-1.6.1_pre1/work/openafs-1.6.1pre1/src/dir'
x86_64-pc-linux-gnu-gcc -fPIC  -O -I/var/tmp/portage/net-fs/openafs-1.6.1_pre1/work/openafs-1.6.1pre1/src/config -I/var/tmp/portage/net-fs/openafs-1.6.1_pre1/work/openafs-1.6.1pre1/include -I. -I.  -D_LARGEFILE64_SOURCE   -c buffer.c
aklog.o: In function `rxkad_build_native_token':
aklog.c:(.text+0x43a): undefined reference to `krb5_524_conv_principal'
collect2: ld returned 1 exit status
make[3]: *** [aklog] Error 1

which is the issue described in the bug #356079

Also, the openafs (userspace) compile should not depend on kernel version.
Comment 8 Mike Hammill 2012-01-09 18:25:37 UTC
(In reply to comment #7)
> Something is strange here. The build log reports failure in:
> make[3]: Entering directory
> `/var/tmp/portage/net-fs/openafs-1.6.1_pre1/work/openafs-1.6.1pre1/src/dir'
> x86_64-pc-linux-gnu-gcc -fPIC  -O
> -I/var/tmp/portage/net-fs/openafs-1.6.1_pre1/work/openafs-1.6.1pre1/src/config
> -I/var/tmp/portage/net-fs/openafs-1.6.1_pre1/work/openafs-1.6.1pre1/include -I.
> -I.  -D_LARGEFILE64_SOURCE   -c buffer.c
> aklog.o: In function `rxkad_build_native_token':
> aklog.c:(.text+0x43a): undefined reference to `krb5_524_conv_principal'
> collect2: ld returned 1 exit status
> make[3]: *** [aklog] Error 1
> which is the issue described in the bug #356079

Yes, you're right about that.

> Also, the openafs (userspace) compile should not depend on kernel version.

Yes, you're also right about that.  I only tried the 3.2 version of the kernel because Bug 397845 mentions that openafs-1.6.1_pre1 is for the 3.2 kernels.  The problem I initially reported was with 3.1 kernel, but I figured someone there would simply stamp it WONTFIX because 397845 say openafs-1.6.1_pre1 is for 3.2.  I was just trying to add helpful information that openafs doesn't build with 3.2 either (in contrast to 397845).
Comment 9 Mike Hammill 2012-02-19 18:22:32 UTC
The same error (i.e., undefined reference to `krb5_524_conv_principal' in aklog.c) occurs with heimdal-1.5.2.  

The same error is true for x86 as for amd64.

On the somewhat positive side, I can report that running a 3.2.1 kernel with heimdal 1.5.2 and openafs-kernel 1.6.1_pre1 and openafs 1.6.0 (since 1.6.1_pre1 fails) on a amd64 architecture does seem to work in practice (i.e., I have not run into cases where access to files from my AFS cell did not go as expected).
Comment 10 Mike Hammill 2012-02-19 19:43:40 UTC
It appears Eray Aslan (perhaps <>?) has asked about the error on one of the Heimdal discussion lists:
or equivalently:

I don't see that there was ever any response to Eray's question.
Comment 11 Mike Hammill 2012-04-07 12:30:14 UTC
The more recent openafs-1.6.1 has the same problem as reported with the "pre" versions, i.e., openafs-kernel compiles but openafs does not against heimdal (1.5.1-r1 or 1.5.2) with same error 

tjasse ~ # grep -C1 "exit status" /var/log/portage/net-fs:openafs-1.6.1:20120407-091050.log
aklog.c:(.text+0x43a): undefined reference to `krb5_524_conv_principal'
collect2: ld returned 1 exit status
make[3]: *** [aklog] Error 1
Comment 12 Mike Hammill 2013-04-03 10:13:43 UTC
To the one assigned this bug: this bug has been left unconfirmed for ages and after looking around I found that I could work around the bug by implementing a solution for a completely different sounding bug, namely,  (Solution is in overlay mhammill.)  In any case, newer openafs does compile correctly against newer gentoo sources so there is probably no reason look into this bug any more, i.e., I assume most who run afs want only the newest version for security reasons.
Comment 13 Andrew Savchenko gentoo-dev 2015-03-22 21:18:24 UTC
Please test with 1.6.11 version.
Comment 14 Andrew Savchenko gentoo-dev 2015-05-01 08:34:52 UTC
Feel free to reopen if the issue is still present in 1.6.11.
Comment 15 Mike Hammill 2015-05-05 09:26:16 UTC
(In reply to Andrew Savchenko from comment #13)
> Please test with 1.6.11 version.

I can say openafs-kernel- compiles against gentoo-sources 3.18.11 without problem on x86.  I have not tried with x86_64 or ppc32 yet.
Comment 16 Andrew Savchenko gentoo-dev 2015-05-05 15:08:41 UTC
We don't have support for ppc arch.
If you are interested in one, please file a separate bug with keyword request.