Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 395889 - [science-overlay] embassy-domalign-0.1.0-r5 fails to fetch embassy-domalign-0.1.0-r5.tar.gz
Summary: [science-overlay] embassy-domalign-0.1.0-r5 fails to fetch embassy-domalign-0...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-24 13:24 UTC by Juergen Rose
Modified: 2015-03-28 17:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
An embassy-domalign ebuild which solved the issue. (embassy-domalign-0.1.0-r5.ebuild,511 bytes, text/plain)
2011-12-24 13:38 UTC, Juergen Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2011-12-24 13:24:18 UTC
'emerge world' fails with:
root@impala:/usr/local/portage/sci-biology(314)# emerge -uvND world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sci-biology/embassy-domalign-0.1.0-r5 [0.1.0-r4] USE="X mysql%* pdf%* png postgres%* -static-libs%" 0 kB [0=>1]
...
>>> Starting parallel fetch

>>> Emerging (1 of 15) sci-biology/embassy-domalign-0.1.0-r5 from science
 * Fetching files in the background. To view fetch progress, run
 * `tail -f /var/log/emerge-fetch.log` in another terminal.
!!! Fetched file: embassy-domalign-0.1.0-r5.tar.gz VERIFY FAILED!
!!! Reason: Insufficient data for checksum verification
!!! Got:      
!!! Expected: MD5 RMD160 SHA1 SHA256 SHA512 WHIRLPOOL
 * Fetch failed for 'sci-biology/embassy-domalign-0.1.0-r5', Log file:
 *  '/var/tmp/portage/sci-biology/embassy-domalign-0.1.0-r5/temp/build.log'


There is not any embassy-domalign-* in /usr/portage/distfiles/:

root@impala:/usr/local/portage/sci-biology(316)# ll /usr/portage/distfiles/embassy-domalign-*
/bin/ls: cannot access /usr/portage/distfiles/embassy-domalign-*: No such file or directory
Comment 1 Juergen Rose 2011-12-24 13:38:50 UTC
Created attachment 296853 [details]
An embassy-domalign ebuild which solved the issue.

The SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/DOMALIGN-0.1.0.tar.gz" was added to the ebuild and the patch was disabled, because it does work.
So the question remains, whether this is embassy-domalign-0.1.0-r5.ebuild or embassy-domalign-0.1.0.ebuild
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2011-12-24 13:54:39 UTC
*** Bug 395895 has been marked as a duplicate of this bug. ***
Comment 3 Justin Lecher gentoo-dev 2012-02-20 14:34:34 UTC
# Justin Lecher <jlec@gentoo.org> (20 Feb 2012)
# They are broken in one or the other way
# Need to be bumped to emboss-6.4.0
sci-biology/emboss::science
sci-biology/embassy::science
sci-biology/embassy-cbstools::science
sci-biology/embassy-domainatrix::science
sci-biology/embassy-domalign::science
sci-biology/embassy-domsearch::science
sci-biology/embassy-emnu::science
sci-biology/embassy-esim4::science
sci-biology/embassy-hmmer::science
sci-biology/embassy-iprscan::science
sci-biology/embassy-mse::science
sci-biology/embassy-phylipnew::science
sci-biology/embassy-signature::science
sci-biology/embassy-structure::science
sci-biology/embassy-topo::science
sci-biology/embassy-vienna::science