Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 394903 - x11-libs/qt-*-4.8 version bumps
Summary: x11-libs/qt-*-4.8 version bumps
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Qt Bug Alias
URL: http://labs.qt.nokia.com/2011/12/15/q...
Whiteboard:
Keywords:
Depends on: 380013 395063 397917 398283
Blocks: 363939
  Show dependency tree
 
Reported: 2011-12-16 08:45 UTC by Sergey Ilinykh
Modified: 2012-01-30 15:04 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Ilinykh 2011-12-16 08:45:12 UTC
subj.

Reproducible: Always
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2011-12-16 13:25:52 UTC
If you want quick access to some applicable ebuilds, look into using the qting-edge overlay.
Comment 2 Sergey Ilinykh 2011-12-16 13:29:09 UTC
thanks. I know.

I hope with this release bug about missing bearer plugins will be fixed as well.
Comment 3 Rafał Mużyło 2011-12-16 15:07:32 UTC
0-day bumps and all that, but there's one little tidbit, that should be addressed, that hasn't been yet in the overlay.

As upstream has finally cleaned up the source (:roll: just in time for qt5), qtconfig can now be moved from qt-qt3suport to qt-gui.
Comment 4 Alex Alexander (RETIRED) gentoo-dev 2011-12-16 20:30:12 UTC
I'm working on the bump, it'll hit the overlay first, then the tree :)
Comment 5 Rafał Mużyło 2011-12-17 14:16:28 UTC
There's one thing I forgot about - I've mentioned it on IRC.
x11-libs/cairo[qt] will need a fix, otherwise desktops with it will break with this update due to a missing private function.
Comment 6 Rafał Mużyło 2011-12-19 02:54:54 UTC
OK, seeing as qting-edge got an ebuild using '-fpermissive', which may or may not work for any dependent packages, I propose a different workaround, one that filters the flags from qt-webkit build: https://bugs.webkit.org/show_bug.cgi?id=64803.
Comment 7 Davide Pesavento gentoo-dev 2012-01-30 15:04:03 UTC
Bumped by wired.