Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 397917 - x11-libs/qtscriptgenerator fails with qt-4.8
Summary: x11-libs/qtscriptgenerator fails with qt-4.8
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: http://code.google.com/p/qtscriptgene...
Whiteboard:
Keywords:
: 398407 (view as bug list)
Depends on:
Blocks: 394903
  Show dependency tree
 
Reported: 2012-01-06 18:16 UTC by vltg0903
Modified: 2012-01-10 17:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vltg0903 2012-01-06 18:16:56 UTC
qtscriptgenerator needs to be patched to build against qt-4.8. This bug report contains details and the link to a patch they use over at fedora:

http://code.google.com/p/qtscriptgenerator/issues/detail?id=80

Reproducible: Always
Comment 1 Johannes Huber gentoo-dev 2012-01-10 09:07:54 UTC
+*qtscriptgenerator-0.1.0-r1 (10 Jan 2012)
+
+  10 Jan 2012; Johannes Huber <johu@gentoo.org>
+  +files/qtscriptgenerator-0.1.0-qt48.patch, +qtscriptgenerator-0.1.0-r1.ebuild:
+  Revision bump. EAPI 4, use qt4-r2 eclass, add fedora patch to compile with Qt
+  4.8, fixes bug #397917.
+
Comment 2 Johannes Huber gentoo-dev 2012-01-10 17:03:30 UTC
*** Bug 398407 has been marked as a duplicate of this bug. ***