Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 392013 - Gnome 3 standard mode is incompatible with "Zaphod mode" multi-monitor configurations
Summary: Gnome 3 standard mode is incompatible with "Zaphod mode" multi-monitor config...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-26 20:42 UTC by Cesko Voeten
Modified: 2011-11-28 16:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cesko Voeten 2011-11-26 20:42:46 UTC
Hello

Gnome 3 will not allow me to log in with my Xinerama setup. Gdm starts up just fine, but after entering my password it immediately says 'Failed to load session gnome' and I get logged out.

~/.xsession-errors:

/etc/gdm/Xsession: Beginning session setup...
localuser:cesko being added to access control list
which: no keychain in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.3:/usr/games/bin:/opt/vmware/bin)
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/dbus-launch --exit-with-session /usr/bin/ssh-agent -- gnome-session
gnome-session[5121]: WARNING: Session 'gnome' runnable check failed: Exited with code 1
gnome-session[5121]: WARNING: Unable to find default provider 'notification-daemon' of required provider 'notifications'

xorg.conf:

Section "Device"
  Identifier    "RightCard"
  Driver        "ati"
  Option        "Monitor-VGA-0" "RightMonitor"
  Option        "DynamicPM" "true"
  BusID         "PCI:01:00:0"
EndSection
Section "Device"
  Identifier    "LeftCard"
  Driver        "intel"
  Option        "Monitor-HDMI-3" "LeftMonitor"
  BusID         "PCI:00:02:0"
EndSection
Section "Monitor"
  Identifier    "RightMonitor"
  VendorName    "CTX"
  Option        "Enable"   "true"
  Option        "Primary"  "true"
EndSection
Section "Monitor"
  Identifier    "LeftMonitor"
  VendorName    "SAM"
  Option        "Enable"   "true"
  Option        "Primary"  "false"
EndSection
Section "Screen"
  Identifier    "LeftScreen"
  Device        "LeftCard"
EndSection
Section "Screen"
  Identifier    "RightScreen"
  Device        "RightCard"
EndSection
Section "ServerLayout"
  Identifier    "BOTHSCREENS"
  Screen 0      "RightScreen"
  Screen 1      "LeftScreen" LeftOf "RightScreen"
EndSection
Section "ServerFlags"
  Option        "DontZap"    "false"
  Option        "DefaultServerLayout"  "BOTH_SCREENS"
EndSection

/etc/portage/package.unmask:

gnome-base/gnome-session
net-wireless/gnome-bluetooth
gnome-base/gnome-control-center
x11-wm/mutter
gnome-base/libgnomekbd
gnome-base/gnome-shell
gnome-base/gnome-settings-daemon
gnome-base/nautilus
dev-python/pygobject
dev-libs/gobject-introspection
gnome-extra/gnome-tweak-tool
gnome-base/gnome-menus
net-libs/gnome-online-accounts
gnome-extra/sushi
app-text/evince
dev-libs/gjs
media-libs/clutter
dev-lang/spidermonkey
gnome-extra/evolution-data-server
dev-libs/json-glib
media-libs/cogl
dev-python/pyatspi
dev-libs/folks
app-accessibility/caribou
dev-libs/libgweather
net-misc/networkmanager
dev-libs/libgdata
gnome-extra/nm-applet
gnome-base/gdm
app-admin/eselect-gnome-shell-extensions
gnome-extra/gnome-shell-extensions

emerge --info:

Portage 2.1.10.38 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r0, 3.1.2-gentoo x86_64)
=================================================================
System uname: Linux-3.1.2-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_650_@_3.20GHz-with-gentoo-2.1
Timestamp of tree: Sat, 26 Nov 2011 19:45:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1-r1
sys-devel/binutils:       2.22
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.14.1
Repositories: gentoo x-portage vmware x-lukynz
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -ggdb -floop-interchange -floop-strip-mine -floop-block"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -ggdb -floop-interchange -floop-strip-mine -floop-block"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --deep --with-bdeps=y --autounmask-write --quiet-build=n"
FEATURES="assume-digests binpkg-logs candy ccache distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/"
INSTALL_MASK="      .keep*      .directory      /usr/share/doc"
LANG="nl_NL.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="nl"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/vmware /var/lib/layman/lukynz"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="64bit X a52 aac aacs acl acpi aio aisleriot all_sfx alsa amd64 amr ao apng applet archive artworkextra asf atm audio automount background blksha1 bonobo branding bzip2 cairo caps ccache cdda cdemud cdio cdr cg charmap classic cleartype cli client client-only clipboard clutter compressed-lumas consolekit corefonts css cue cups curl curlwrappers cursors custom-optimization d3d dbus development dhcpcd dia dirac djvu dri drm dv dvd dvdr dvi eds emerald emulation encode eselect exceptions expat extensions faac faad fat fbcon fbcondecor ffmpeg findbugs flac fluidsynth fontconfig fts3 fuse gallium gbm gcrypt gdu gecko gecko-mediaplayer gedit general gif glib global-menu glut gmp gnome gnome-online-accounts gnome-shell gnumeric gpc gpm graphite gs gstreamer gtk gtk3 gtkstyle gucharmap gudev gzip handbook hddtemp highlight hs20 hunspell hwdb icon-manager iconv icu ieee1394 imagemagick inkjar inotify interlaced introspection ipc iproute2 iptables ithreads java6 jemalloc jit jpeg justify keymap lame laptop lcdfilter lcms ldap less libevent libkms libnotify libssh2 libxml2 lightning llvm lm_sensors logrotate lqr lto luatex lzma lzo mad matroska melt methodjit midi mikmod minimal minizip mmap mmx mmxext mng modules monolithic-build mouse mozilla mp3 mp4 mpeg mpg123 mplayer msn mta multicall multilib music nano-syntax nat native natspec nautilus ncurses networkmanager new-login nfs nio2 nls nm-applet nptl nptlonly nsplugin nspluginwrapper nss ntfs ntfsprogs ntlm ocamlopt offensive ogg openal opengl openmedia openmp openssl openvg optimization optimized-qmake orc osmesa ovftool pam passwordsave pcre pdf pdfimport pgo physfs png policykit postproc previewer ps pth pulseaudio python3 q32 q64 quote rar raster rdesktop readline reiserfs rtc rtf rule_generator samba savedconfig schroedinger sdl sdl-image sensord sha512 shared-dricore shared-glapi shm showtabbar smbclient smbsharemodes smp sndfile sound sounds sqlite sqlite3 sse sse2 sse3 sse4 ssh ssh1 ssl ssse3 startup-notification strong-optimization sudo svg symlink synctex sysfs syslog sysvipc tdb templates terminal theora threads threadsafe thumbnail tiff timidity toolame track-src-odirect transcode truetype twolame udev udev_acl udisks unicode unlock-notify unsupported unzip upnp upower utp uuid vaapi vapigen vba vcd vdpau video videos vlc vmware-tools vmware_guest_freebsd vmware_guest_linux vmware_guest_netware vmware_guest_solaris vmware_guest_winPre2k vmware_guest_windows vorbis vpnc vpx vte wallpapers wav wavpack weather webdav-neon webgl webm webstart wide-unicode win32 win64 winbind wma wmf x264 xattr xcb xcomposite xinerama xml xorg xpdf-headers xpm xrandr xrender xscreensaver xulrunner xv xvfb xvid xvmc zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="nl" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon intel i965 r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-11-26 22:28:22 UTC
Please re-emerge gnome-base/gnome-session with debug USE flag enabled, try to log in again, and attach the resulting ~/.xsession-errors
Comment 2 Cesko Voeten 2011-11-27 11:09:18 UTC
~/.xsession-errors is exactly the same. The cause may be this:

>>> Completed installing gnome-session-3.2.1 into /var/tmp/portage/gnome-base/gnome-session-3.2.1/image/

 * QA Notice: Unrecognized configure options:
 * 
 * 	configure: WARNING: unrecognized options: --enable-debug, --disable-gtk-doc
 * 	configure: WARNING: unrecognized options: --enable-debug, --disable-gtk-doc
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-11-28 06:37:59 UTC
(In reply to comment #2)
> ~/.xsession-errors is exactly the same.

I apologize, I had given you out of date instructions.

The correct instructions are: please edit (as root) /usr/share/xsessions/gnome.desktop and change the line
Exec=gnome-session
to
Exec=gnome-session --debug

and post attach your ~/.xsession-errors after trying to log in.

Note: you probably will want to switch back to "Exec=gnome-session" after you get gnome-shell working, because in --debug mode .xsession-errors can grow rather large.

> *     configure: WARNING: unrecognized options: --enable-debug,
>--disable-gtk-doc

The unrecognized "--enable-debug" is an error in the ebuild; thanks for reporting it (it has now been fixed). The unrecognized "--disable-gtk-doc" is an old misfeature in gnome2.eclass and nothing to worry about (bug #262491, if you are curious).
Comment 4 Cesko Voeten 2011-11-28 08:33:05 UTC
That worked :-)

/etc/gdm/Xsession: Beginning session setup...
localuser:cesko being added to access control list
which: no keychain in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.3:/usr/games/bin:/opt/vmware/bin)
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/dbus-launch --exit-with-session /usr/bin/ssh-agent -- gnome-session --debug
gnome-session[9302]: DEBUG(+): Enabling debugging
gnome-session[9302]: DEBUG(+): GsmXsmpServer: SESSION_MANAGER=local/pc-van-cesko:@/tmp/.ICE-unix/9302,unix/pc-van-cesko:/tmp/.ICE-unix/9302

gnome-session[9302]: DEBUG(+): GsmShell: Not connected to the shell
gnome-session[9302]: DEBUG(+): GsmManager: setting client store 0x2659320
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Adding handler 1: signum=4 (nil)
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Registering for 4 signals
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Adding handler 2: signum=7 (nil)
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Registering for 7 signals
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Adding handler 3: signum=11 (nil)
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Registering for 11 signals
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Adding handler 4: signum=6 (nil)
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Registering for 6 signals
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Adding handler 5: signum=5 (nil)
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Registering for 5 signals
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Adding handler 6: signum=8 0x41d260
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Registering for 8 signals
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Adding handler 7: signum=1 0x41d260
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Registering for 1 signals
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Adding handler 8: signum=10 0x41d260
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Registering for 10 signals
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Adding handler 9: signum=15 0x41d260
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Registering for 15 signals
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Adding handler 10: signum=2 0x41d260
gnome-session[9302]: DEBUG(+): GdmSignalHandler: Registering for 2 signals
gnome-session[9302]: DEBUG(+): fill: *** Getting session 'gnome'
gnome-session[9302]: DEBUG(+): fill: *** Looking if /home/cesko/.config/gnome-session/sessions/gnome.session is a valid session file
gnome-session[9302]: DEBUG(+): Cannot use session '/home/cesko/.config/gnome-session/sessions/gnome.session': non-existing or invalid file.
gnome-session[9302]: DEBUG(+): fill: *** Looking if /etc/xdg/gnome-session/sessions/gnome.session is a valid session file
gnome-session[9302]: DEBUG(+): Cannot use session '/etc/xdg/gnome-session/sessions/gnome.session': non-existing or invalid file.
gnome-session[9302]: DEBUG(+): fill: *** Looking if /usr/share/gnome/gnome-session/sessions/gnome.session is a valid session file
gnome-session[9302]: DEBUG(+): Cannot use session '/usr/share/gnome/gnome-session/sessions/gnome.session': non-existing or invalid file.
gnome-session[9302]: DEBUG(+): fill: *** Looking if /usr/local/share/gnome-session/sessions/gnome.session is a valid session file
gnome-session[9302]: DEBUG(+): Cannot use session '/usr/local/share/gnome-session/sessions/gnome.session': non-existing or invalid file.
gnome-session[9302]: DEBUG(+): fill: *** Looking if /usr/share/gnome-session/sessions/gnome.session is a valid session file
gnome-session[9302]: DEBUG(+): fill: *** Launching helper '/usr/libexec/gnome-session-check-accelerated' to know if session is runnable
gnome-session[9302]: WARNING: Session 'gnome' runnable check failed: Geëindigd met code 1
gnome-session[9302]: DEBUG(+): fill: *** Session is not runnable
gnome-session[9302]: DEBUG(+): fill: *** Getting session 'gnome-fallback'
gnome-session[9302]: DEBUG(+): fill: *** Looking if /home/cesko/.config/gnome-session/sessions/gnome-fallback.session is a valid session file
gnome-session[9302]: DEBUG(+): Cannot use session '/home/cesko/.config/gnome-session/sessions/gnome-fallback.session': non-existing or invalid file.
gnome-session[9302]: DEBUG(+): fill: *** Looking if /etc/xdg/gnome-session/sessions/gnome-fallback.session is a valid session file
gnome-session[9302]: DEBUG(+): Cannot use session '/etc/xdg/gnome-session/sessions/gnome-fallback.session': non-existing or invalid file.
gnome-session[9302]: DEBUG(+): fill: *** Looking if /usr/share/gnome/gnome-session/sessions/gnome-fallback.session is a valid session file
gnome-session[9302]: DEBUG(+): Cannot use session '/usr/share/gnome/gnome-session/sessions/gnome-fallback.session': non-existing or invalid file.
gnome-session[9302]: DEBUG(+): fill: *** Looking if /usr/local/share/gnome-session/sessions/gnome-fallback.session is a valid session file
gnome-session[9302]: DEBUG(+): Cannot use session '/usr/local/share/gnome-session/sessions/gnome-fallback.session': non-existing or invalid file.
gnome-session[9302]: DEBUG(+): fill: *** Looking if /usr/share/gnome-session/sessions/gnome-fallback.session is a valid session file
gnome-session[9302]: DEBUG(+): fill: *** Checking required components and providers
gnome-session[9302]: DEBUG(+): fill: provider 'windowmanager' looking for component: 'metacity'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking for file 'metacity.desktop'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/home/cesko/.config/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/etc/xdg/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/home/cesko/.local/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: found in XDG dirs: '/usr/share/applications/metacity.desktop'
gnome-session[9302]: DEBUG(+): fill: provider 'notifications' looking for component: 'notification-daemon'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking for file 'notification-daemon.desktop'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/home/cesko/.config/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/etc/xdg/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/home/cesko/.local/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/applications'
gnome-session[9302]: WARNING: Unable to find default provider 'notification-daemon' of required provider 'notifications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking for file 'gnome-panel.desktop'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/home/cesko/.config/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/etc/xdg/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/home/cesko/.local/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: found in XDG dirs: '/usr/share/applications/gnome-panel.desktop'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking for file 'gnome-settings-daemon.desktop'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/home/cesko/.config/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/gnome/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/etc/xdg/autostart'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/home/cesko/.local/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gnome/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/local/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: Looking in '/usr/share/gdm/applications'
gnome-session[9302]: DEBUG(+): GsmUtil: found in XDG dirs: '/etc/xdg/autostart/gnome-settings-daemon.desktop'
gnome-session[9302]: DEBUG(+): fill: *** Done checking required components and providers
gnome-session[9302]: DEBUG(+): fill: *** Session is not runnable
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-11-28 09:07:07 UTC
OK, now it's clear what is happening.

gnome-session first tries to check whether to start standard mode; however, it determines that your system's opengl support is not good enough to run gnome-shell, and therefore stops.

gnome-session then tries to start fallback mode. However, it appears that you had emerged gnome-base/gnome with USE=-fallback, so at least one of the dependencies needed for fallback mode (e.g. >=x11-misc/notification-daemon-0.7) are missing.

As a result, gnome-session fails to start anything, and returns you back to gdm.

----

What you need to do:

1. emerge gnome-base/gnome with the fallback USE flag enabled (or just emerge gnome-base/gnome-fallback).
2. from a terminal in gnome's fallback mode, run the following command:
/usr/libexec/gnome-session-check-accelerated-helper
It should print an error message which will explain why gnome-shell cannot run on your system.
Comment 6 Cesko Voeten 2011-11-28 10:50:32 UTC
There we are:
gnome-session-is-accelerated: Zaphod mode not supported.

So I guess this is a missing feature in gnome-session... so should I mark this bug as 'enhancement' then?
Comment 7 Gilles Dartiguelongue gentoo-dev 2011-11-28 13:06:24 UTC
This means the specific way you set Xorg xinerama is not supported by gnome-shell. I guess there is already a bug report upstream that should explain why this is not supported and maybe provide a patch.
Comment 8 Cesko Voeten 2011-11-28 16:03:49 UTC
I've reported this upstream (I couldn't find any existing bug reports on my issue): https://bugzilla.gnome.org/show_bug.cgi?id=665061

Thank you very much for all your help!
Comment 9 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-11-28 16:33:52 UTC
(In reply to comment #6)
> There we are:
> gnome-session-is-accelerated: Zaphod mode not supported.
> 
> So I guess this is a missing feature in gnome-session... so should I mark this
> bug as 'enhancement' then?

Unfortunately, "Zaphod mode" (meaning dualhead configurations with multiple Device sections in xorg.conf) are considered to be fundamentally incompatible with gnome-shell (see https://bugzilla.gnome.org/show_bug.cgi?id=651799), probably because such configurations have problems with hardware opengl acceleration across screens. This is unlikely to change without rewriting core parts of gnome-shell.

The best we can do is document this fact so that other users will be aware of it.

RCS file: /var/cvsroot/gentoo/xml/htdocs/proj/en/desktop/gnome/howtos/gnome-3.2-upgrade.xml,v
retrieving revision 1.6
diff -u -r1.6 gnome-3.2-upgrade.xml
--- gnome-3.2-upgrade.xml	27 Nov 2011 05:07:01 -0000	1.6
+++ gnome-3.2-upgrade.xml	28 Nov 2011 16:30:23 -0000
@@ -17,8 +17,8 @@
 <!-- See http://creativecommons.org/licenses/by-sa/2.5 -->
 <license/>
 
-<version>0.2.4</version>
-<date>2011-11-27</date>
+<version>0.2.5</version>
+<date>2011-11-28</date>
 
 <chapter>
 <title>Changes</title>
@@ -393,6 +393,21 @@
 </p>
 </body>
 </section>
+
+<section>
+<title>Dualhead configurations</title>
+
+<body>
+<p>
+As reported in <uri link="https://bugs.gentoo.org/show_bug.cgi?id=392013">bug
+#392013</uri>, GNOME Shell will refuse to start under "Zaphod mode" dualhead
+configurations (i.e. the configurations where multiple <e>Device</e> sections in
+<path>xorg.conf</path>). If you are using such a dualhead configuration, you
+will only be able to use fallback mode.
+</p>
+</body>
+</section>
+
 </chapter>
 
 <chapter>