Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 387147 - sys-auth/pam_mount-2.12: running xfce4-session-logout eats all memory
Summary: sys-auth/pam_mount-2.12: running xfce4-session-logout eats all memory
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal critical with 1 vote (vote)
Assignee: Hanno Böck
URL:
Whiteboard:
Keywords:
: 392455 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-14 17:06 UTC by larophel
Modified: 2016-09-26 11:28 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description larophel 2011-10-14 17:06:59 UTC
I use pam_mount to mount my LUKS encrypted home partition on login. 
After upgrading to sys-auth/pam_mount-2.12 I have noticed that running xfce4-session-logout eats all my memory / swap.
This causes a freeze in about one to two minutes.
This also happens with sys-auth/pam_mount-2.11.
It does not happen with sys-auth/pam_mount-2.10.


Reproducible: Always

Steps to Reproduce:
1. Upgrade to sys-auth/pam_mount-2.12
2. Start xfce4-session-logout

Actual Results:  
Memory gets quickly used up, the computer freezes. 

Expected Results:  
Memory usage should stay the same, computer should not freeze.

"top" does not show any process in particular taking up a lot of memory.
Instead, there are thousands of mount processes started, which probably cause the memory shortage.

Example: 
5197 ? S 0:00 /sbin/mount.crypt /dev/sda7 /home/larophel -o rw,noexec,nosuid,nodev,remount,noauto,user,noatime,commit=600 

emerge --info
Portage 2.1.10.27 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 3.0.0-gentoo x86_64)
=================================================================
System uname: Linux-3.0.0-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T6600_@_2.20GHz-with-gentoo-2.1
Timestamp of tree: Fri, 14 Oct 2011 13:30:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.7-r2, 2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r3
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-mtune=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-mtune=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--ask --buildpkg y --keep-going --autounmask-write"
FEATURES="assume-digests binpkg-logs buildpkg distlocks ebuild-locks fixlafiles metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://mirror.datapipe.net/gentoo http://gentoo.mirrors.hoobly.com/ http://gentoo.mirrors.easynews.com/linux/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en es de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apng berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus device-mapper dri dts dvd dvdr emboss encode exif extras fam ffmpeg firefox flac fortran gallium gdbm gdu gif gpm gtk iconv ipv6 java jpeg lcms ldap libnotify mad mjpeg mmx mng modules mp3 mp4 mpeg mplayer mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ntfs ogg opengl openmp pam pango pcre pdf php png policykit postproc ppds pppd qt3support qt4 readline sdl session spell sqlite sse sse2 ssl startup-notification subtitles svg sysfs system-sqlite tcpd theora threads tiff tools truetype udev unicode usb vaapi vdpau vmware_guest_windows vorbis x264 xcb xfce xml xorg xulrunner xv xvid xvmc zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en es de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 turtle 2011-12-08 05:00:57 UTC
Do you run any other WM's ?
Could you post the output of ck-list-sessions ?
You do not get this error until you logout?
So you can login to a xfce session and access your encrypted disk?
Do you have a forums post?
Comment 3 Johannes Huber gentoo-dev 2011-12-13 21:15:34 UTC
*** Bug 392455 has been marked as a duplicate of this bug. ***
Comment 4 larophel 2011-12-26 19:12:18 UTC
Hello turle,

I do not use an encrypted home dir anymore, so I cannot do any additional tests, unfortunately.
However, I will answer your questions from memory:

"Do you run any other WM's ?"

No.

"Could you post the output of ck-list-sessions ?"

Session1:
	unix-user = '1000'
	realname = '(null)'
	seat = 'Seat1'
	session-type = ''
	active = FALSE
	x11-display = ''
	x11-display-device = ''
	display-device = '/dev/tty1'
	remote-host-name = ''
	is-local = TRUE
	on-since = '2011-12-26T17:24:13.797019Z'
	login-session-id = '11'
	idle-since-hint = '2011-12-26T17:24:47.281143Z'
Session2:
	unix-user = '1000'
	realname = '(null)'
	seat = 'Seat1'
	session-type = ''
	active = TRUE
	x11-display = ':0'
	x11-display-device = '/dev/tty7'
	display-device = '/dev/tty1'
	remote-host-name = ''
	is-local = TRUE
	on-since = '2011-12-26T17:24:20.921894Z'
	login-session-id = '11'

"You do not get this error until you logout?"

The error only appeared if you ran "xfce4-session-logout".
Using this program, you could chose which action to run (shutdown, reboot, logout, etc.).
It was not necessary to pick any action at all, just running the "xfce4-session-logout" program was enough to trigger the problem.

"So you can login to a xfce session and access your encrypted disk?"

Yes.

"Do you have a forums post?"

Yes, I think you already found it: http://forums.gentoo.org/viewtopic-t-891078.html
Comment 5 Matt Turner gentoo-dev 2013-10-05 01:17:52 UTC
pam_mount-2.14 is now in the tree. Check if you still have the problem?
Comment 6 Hanno Böck gentoo-dev 2016-09-26 11:28:30 UTC
All the references seem to be more than 4 years old and no feedback from reporter.

I'll close this for now, if this is still an issue you can reopen. But I'd recommend discussing this with upstream, as it's most likely not a gentoo bug.