Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 381365 - sys-auth/pam_mount uses all virtual memory with app-cdr/k3b-2.0.2-r1
Summary: sys-auth/pam_mount uses all virtual memory with app-cdr/k3b-2.0.2-r1
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Hanno Böck
URL: http://sourceforge.net/tracker/?func=...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-31 21:18 UTC by Philip L
Modified: 2014-04-26 16:39 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kernel configuration (config.gz,14.65 KB, application/gzip)
2011-08-31 21:19 UTC, Philip L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philip L 2011-08-31 21:18:20 UTC
Since a recent system update, simply starting k3b causes all my virtual memory to be consumed (main memory first, then swap is gradually used up). This usually starts before the k3b window appears and continues even after closing everything and logging out. Top doesn't show any processes using a large amount of memory, but does show kswapd0 using 100% CPU. Using a fresh k3b configuration doesn't help.

This may not be bug in k3b, but I'm reporting it as a k3b bug because I can't tie it to anything else.

Reproducible: Always




Portage 2.1.10.11 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.0.4-gentoo x86_64)
=================================================================
System uname: Linux-3.0.4-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-gentoo-2.0.3
Timestamp of tree: Wed, 31 Aug 2011 17:45:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r2, 3.2-r2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo blah
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://mirror.datapipe.net/gentoo http://mirrors.rit.edu/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en ja"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync27.us.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acl acpi alsa amd64 apng audiofile bash-completion berkdb bzip2 cairo cdparanoia cdr cjk cli consolekit cracklib crypt cups cxx dbus device-mapper djvu doc dri dvd dvdr dvdread enca encode exif ffmpeg flac fluidsynth fontconfig fuse gd gdbm gif glitz gnome gnutls gpm graphviz gstreamer gtk iconv id3tag immqt-bc inotify ipv6 jack jadetex java joystick jpeg jpeg2k kde kde4 kvm ladspa lame latex lcms libnotify libsamplerate lirc lm_sensors lvm lvm2 lzo mad mbox md mdadm mmx mng modplug modules motif mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin nvidia offensive ogg openal openexr opengl openmp pam pcre pdf perl png policykit pppd python qt3support qt4 quicktime readline rtc samba scim sdl semantic-desktop session smp sndfile speex sse sse2 sse3 sse4 sse4_1 ssh ssl ssse3 svg sysfs tcpd theora threads tiff truetype udev unicode usb v4l v4l2 vaapi vdpau vim-syntax vim-with-x vorbis wma x264 xattr xcb xcomposite xft xml xmp xorg xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="mouse keyboard evdev joystick wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ja" LIRC_DEVICES="devinput" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vga vesa dummy none nv nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Philip L 2011-08-31 21:19:37 UTC
Created attachment 285195 [details]
kernel configuration
Comment 2 Philip L 2011-09-10 01:33:03 UTC
I managed to find the source of this bug. After an update to another system (running Arch) I began seeing the same symptoms when running pm-hibernate or pm-suspend, which I traced to 'mount -o remount,commit=0' being run on a partition (my home dir) mounted with -t crypt through pam_mount. On both that system and my gentoo box I switched from using pam_mount to using separate cryptsetup and mount steps. This alleviated both this bug and the suspend/hibernate bug, but I'm not sure how it's connected to k3b.
Comment 3 Andreas K. Hüttel gentoo-dev 2011-09-22 21:54:54 UTC
Err... no idea about this. But maybe someone from base-system knows?
Comment 4 Philip L 2011-09-22 22:13:59 UTC
I filed a bug on the pam_mount tracker about this a while back but it hasn't received a response.

http://sourceforge.net/tracker/?func=detail&aid=3407320&group_id=41452&atid=430593
Comment 5 Johannes Huber gentoo-dev 2012-01-21 17:10:07 UTC
Maybe pam mount maintainer have any idea how to solve this.
Comment 6 Michael Palimaka (kensington) gentoo-dev 2013-01-08 13:37:30 UTC
Reassigning since this appears to definitely be a pam_mount issue.

I found this patch[1] from Debian that sounds like it may solve the issue. Is anyone able to test?

[1]http://patch-tracker.debian.org/patch/series/view/libpam-mount/2.14~zgit2+aa0d624e-1/fix-mount-crypt-fork-bomb
Comment 7 Matt Turner gentoo-dev 2013-08-12 05:36:27 UTC
Anyone able to reproduce and also able to test the patch?
Comment 8 Matt Turner gentoo-dev 2013-10-05 01:21:50 UTC
pam_mount-2.14 is now in the tree. Check if you still have the problem?
Comment 9 Johannes Huber gentoo-dev 2014-04-26 11:24:50 UTC
(In reply to Matt Turner from comment #8)
> pam_mount-2.14 is now in the tree. Check if you still have the problem?

Is stable since some time, i guess this can be closed as reporter is not responsive.