Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 386811 - New ebuild: dev-perl/Text-BibTeX (biber dependency)
Summary: New ebuild: dev-perl/Text-BibTeX (biber dependency)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD
Depends on: 386801 386803
Blocks: 340353
  Show dependency tree
 
Reported: 2011-10-11 15:35 UTC by Christopher Schwan
Modified: 2013-08-03 20:47 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Text-BibTeX ebuild (Text-BibTeX-0.60.ebuild,485 bytes, text/plain)
2011-10-11 15:36 UTC, Christopher Schwan
Details
updated ebuild for version 0.61 (Text-BibTeX-0.61.ebuild,574 bytes, text/plain)
2011-12-24 11:23 UTC, Christopher Schwan
Details
Tex-BibTeX version 0.62 (Text-BibTeX-0.62.ebuild,574 bytes, text/plain)
2012-04-06 19:31 UTC, Michael Schindhelm
Details
Text-BibTeX-0.66 ebuild (Text-BibTeX-0.66.ebuild,574 bytes, text/plain)
2013-02-02 09:27 UTC, Markus Oehme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Schwan 2011-10-11 15:35:11 UTC
Please add the following ebuild. It is a dependency for dev-tex/biber (bug #340353).


Reproducible: Always
Comment 1 Christopher Schwan 2011-10-11 15:36:13 UTC
Created attachment 289589 [details]
Text-BibTeX ebuild
Comment 2 Torsten Veller (RETIRED) gentoo-dev 2011-10-17 13:32:53 UTC
The Text-BibTeX package bundles a version of dev-libs/btparse.
Comment 3 Christopher Schwan 2011-10-17 13:47:12 UTC
OK, I will try to get rid of that.
Comment 4 Christopher Schwan 2011-10-18 08:22:01 UTC
First of all, thanks for adding all the biber-related perl modules into the overlay!

Unfortunately, it is not straightforward to remove btparse. There are a number of trivial (ushort renamed to btshort, inclusion of non-dist binaries) as well as non-trivial changes (e.g. Text-BibTeX extends btparse with UTF-8 functionality) which makes it hard to get rid of it.

Therefore, I would like to know first if it is reasonable to do that instead of just marking btparse as a blocker in Text-BibTeX. This is not the perfect way, but as far as I understand btparse (whose author also started Text-BibTeX) is discontinued and Text-BibTeX should be understood as a successor:

From Text-BibTeX's CHANGES:

Release 0.40_2 - 15 February, 2010
----------------------------------
* merged btparse library into Text::BibTeX code. I am sorry for all
  other languages that might be using this library. For them my
  suggestion is that they make Text::BibTeX as a dependency.
Comment 5 Christopher Schwan 2011-12-24 11:23:30 UTC
Created attachment 296839 [details]
updated ebuild for version 0.61
Comment 6 Christopher Schwan 2011-12-24 11:25:10 UTC
The updated ebuild will be required for the latest version of biber and is also compatible with previous versions of it.
Comment 7 Michael Schindhelm 2012-04-06 19:31:49 UTC
Created attachment 308023 [details]
Tex-BibTeX version 0.62

added ebuild of version 0.62 which is a depency of biber 0.99
Comment 8 Mira Ressel 2012-07-30 18:23:51 UTC
biber-1.1 now depends on >=Text-BibTeX-0.64. The ebuild for 0.62 can be reused for that.
Comment 9 Markus Oehme 2013-02-02 09:27:25 UTC
Created attachment 337652 [details]
Text-BibTeX-0.66 ebuild

Simple version bump to 0.66 for biber-1.5.
Comment 10 Dennis Schridde 2013-03-19 20:42:42 UTC
There appear to be a few QA issues with this pacakge:

WARNING: the following files are missing in your kit:
        MYMETA.yml

* QA Notice: Package triggers severe warnings which indicate that it
 *            may exhibit random runtime failures.
 * btparse/tests/tex_test.c:21:16: warning: incompatible implicit declaration of built-in function ‘strlen’ [enabled by default]
 * btparse/tests/purify_test.c:18:16: warning: incompatible implicit declaration of built-in function ‘strlen’ [enabled by default]
 * btparse/tests/postprocess_test.c:12:27: warning: incompatible implicit declaration of built-in function ‘strlen’ [enabled by default]
 * btparse/tests/postprocess_test.c:13:4: warning: incompatible implicit declaration of built-in function ‘strcpy’ [enabled by default]
 * btparse/tests/name_test.c:133:13: warning: incompatible implicit declaration of built-in function ‘strlen’ [enabled by default]
 * btparse/tests/macro_test.c:58:18: warning: incompatible implicit declaration of built-in function ‘strlen’ [enabled by default]
Comment 11 Sven 2013-08-03 19:11:57 UTC
(In reply to Dennis Schridde from comment #10)
> There appear to be a few QA issues with this pacakge:

Not sure about the MYMETA.yml file. But the strlen/strcpy problems seem to be caused by the fact that the author of the tests omitted a simple #include <string.h>. A patch is easy to write.
Comment 12 Manuel Rüger (RETIRED) gentoo-dev 2013-08-03 20:47:13 UTC
*Text-BibTeX-0.66 (03 Aug 2013)

  03 Aug 2013; Manuel Rüger <mrueg@gentoo.org> +Text-BibTeX-0.66.ebuild,
  +metadata.xml:
  Initial ebuild. Ebuild by Christopher Schwan, Michael Schindhelm and Markus
  Oehme. Fixes bug #386811