Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 340353 - dev-tex/biber - A BibTeX replacement for users of biblatex
Summary: dev-tex/biber - A BibTeX replacement for users of biblatex
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 5 votes (vote)
Assignee: Manuel Rüger (RETIRED)
URL: http://biblatex-biber.sourceforge.net/
Whiteboard:
Keywords:
Depends on: 382625 386805 386809 386811 386815 386817 428798 428802 428808 428818 428820 437116 442342
Blocks:
  Show dependency tree
 
Reported: 2010-10-10 14:36 UTC by Christoph Lange
Modified: 2013-08-14 06:54 UTC (History)
25 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
biblatex-biber-0.6 ebuild (biblatex-biber-0.6.ebuild,1000 bytes, text/plain)
2010-11-23 14:31 UTC, Moshe Kamensky
Details
biblatex-biber 0.9.3 ebuild (biblatex-biber-0.9.3.ebuild,1001 bytes, text/plain)
2011-08-16 09:35 UTC, Christopher Schwan
Details
updated ebuild for version 0.9.5 (biblatex-biber-0.9.5.ebuild,1.02 KB, text/plain)
2011-10-16 08:51 UTC, Christopher Schwan
Details
updated ebuild for version 0.9.9 (biblatex-biber-0.9.9.ebuild,1.02 KB, text/plain)
2012-04-06 19:38 UTC, Michael Schindhelm
Details
XML-Writer-String (XML-Writer-String-0.1.ebuild,338 bytes, text/plain)
2012-04-28 20:41 UTC, Michael Schindhelm
Details
dev-tex/biber-1.1.ebuild (biber-1.1.ebuild,1.16 KB, text/plain)
2012-07-31 13:31 UTC, Mira Ressel
Details
dev-tex/biber-1.1.ebuild (biber-1.1.ebuild,1.12 KB, text/plain)
2012-07-31 16:34 UTC, Mira Ressel
Details
Updated ebuild for biber-1.2 (biber-1.2.ebuild,1.06 KB, text/plain)
2012-09-11 18:34 UTC, Mira Ressel
Details
biber-1.2.ebuild (biber-1.2.ebuild,1.14 KB, text/plain)
2012-10-05 18:56 UTC, Mira Ressel
Details
biber-1.2-drop-Mozilla-CA.patch (biber-1.2-drop-Mozilla-CA.patch,5.12 KB, text/plain)
2012-10-05 18:57 UTC, Mira Ressel
Details
biber-1.3 ebuild (biber-1.3.ebuild,1.07 KB, text/plain)
2012-11-08 11:48 UTC, Thomas Witt
Details
biber-1.4 ebuild (biber-1.4.ebuild,1.07 KB, text/plain)
2012-11-29 13:23 UTC, Thomas Witt
Details
biber-1.5 ebuild (biber-1.5.ebuild,1.13 KB, text/plain)
2013-02-02 09:25 UTC, Markus Oehme
Details
Remove RDEPEND on Mozilla-CA (biblatex-biber-1.5-remove-mozilla-ca.patch,6.03 KB, patch)
2013-04-04 12:41 UTC, Christopher Schwan
Details | Diff
Ebuild for biber 1.6 (biblatex-biber-1.6.ebuild,1.40 KB, text/plain)
2013-05-03 06:53 UTC, Christopher Schwan
Details
Patch to get rid of Mozilla-CA and use the system-wide certificates instead (biblatex-biber-1.6-remove-mozilla-ca.patch,8.33 KB, patch)
2013-05-03 06:54 UTC, Christopher Schwan
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Lange 2010-10-10 14:36:53 UTC
app-text/texlive-2010 (bug 339098) will contain the BibLaTeX package, which recommends the Perl-based Biber (http://biblatex-biber.sourceforge.net/) over the traditional BibTeX tool.  Biber's advantages in a nutshell: Unicode support, better scalability, XML import/export.  Therefore, I suggest an ebuild dev-tex/biber.
Comment 1 Moshe Kamensky 2010-11-23 14:31:40 UTC
Created attachment 255185 [details]
biblatex-biber-0.6 ebuild

biblatex-biber ebuild (version 0.6). It requires some perl modules not in the tree, which can be generated using g-cpan.
Comment 2 Christopher Schwan 2011-08-16 09:34:50 UTC
Since bug #376831 was fixed, biblatex-biber is no longer bundled with texlive-core-2011. I therefore wrote a new ebuild. Some remarks:

- At the time of writing, 0.9.4 is the latest stable version but not compatible with texlive-2011. When I try to compile with 0.9.4 biber says:

[..]
WARN - Warning: Found biblatex control file version 1.5, expected version 1.6
[..]
Use of uninitialized value $maxan in numeric gt (>) at /usr/lib64/perl5/vendor_perl/5.12.3/Biber.pm line 1306.
Use of uninitialized value $visible_names_alpha in concatenation (.) or string at /usr/lib64/perl5/vendor_perl/5.12.3/Biber.pm line 1334.
[..]

Compilation of the latex-document does not work, (lua)latex aborts with several keyval errors. I therefore think 0.9.4 is no longer compatible, 0.9.3 works fine with my ebuild

- biblatex-biber needs seven additional perl dependencies for which no ebuilds currently exist:

  + dev-perl/Config-AutoConf
  + dev-perl/ExtUtils-LibBuilder
  + dev-perl/File-Slurp-Unicode
  + dev-perl/List-AllUtils
  + dev-perl/Text-BibTeX
  + dev-perl/Unicode-Collate
  + dev-perl/XML-LibXML-Simple

I have written these as well, you can find them in my personal overlay at https://github.com/cschwan/cschwan-overlay. If someone is interested, I can file bugs for these.
Comment 3 Christopher Schwan 2011-08-16 09:35:43 UTC
Created attachment 283529 [details]
biblatex-biber 0.9.3 ebuild
Comment 4 Christopher Schwan 2011-08-16 09:37:47 UTC
One additional remark: I was not able to find out how to use the mirror:// syntax for sourceforge - everytime I tried it was fetching a development version. Maybe someone finds out how to do that.
Comment 5 Sven 2011-09-29 16:24:44 UTC
TeXLive 2011 is in portage. Installed it, found biblatex, got excited, missed biber a lot! Please add biber. Biblatex + bibtex is like a car with a horse as an engine.
Comment 6 Alexis Ballier gentoo-dev 2011-10-11 15:12:14 UTC
(In reply to comment #2)
> - biblatex-biber needs seven additional perl dependencies for which no ebuilds
> currently exist:
> 
>   + dev-perl/Config-AutoConf
>   + dev-perl/ExtUtils-LibBuilder
>   + dev-perl/File-Slurp-Unicode
>   + dev-perl/List-AllUtils
>   + dev-perl/Text-BibTeX
>   + dev-perl/Unicode-Collate
>   + dev-perl/XML-LibXML-Simple
> 


yes! please! i'll need the perl team to add these packages before adding biber
Comment 7 Christopher Schwan 2011-10-11 15:46:50 UTC
OK, I filed a bug for every dependency; I also saw someone adding blockers for this bug.
Comment 8 Christopher Schwan 2011-10-11 15:56:00 UTC
This someone was myself - so sorry for the confusion; I added the necessary blockers.
Comment 9 Thomas Witt 2011-10-11 18:24:04 UTC
Your 0.9.3 ebuild works fine for biblatex-biber-0.9.5. However, biblatex-1.6 is needed explicitly.

(https://bugs.gentoo.org/show_bug.cgi?id=383613)
Comment 10 Christopher Schwan 2011-10-12 15:55:03 UTC
So you mean if I upgrade to 0.9.5 I will need biblatex as well?
Comment 11 Thomas Witt 2011-10-13 09:00:05 UTC
(In reply to comment #10)
> So you mean if I upgrade to 0.9.5 I will need biblatex as well?

yes, biber-0.9.5 depends on >=dev-tex/biblatex-1.6
Comment 12 Christopher Schwan 2011-10-16 08:50:45 UTC
OK, I finally found some time to test it. Biblatex-biber-0.9.3 depends on biblatex-1.5 which is shipped with dev-texlive/texlive-bibtexextra-2011 and biblatex-biber-0.9.5 depends on dev-tex/biblatex-1.6, as you told me. Thank you very much!

The following ebuild is updated accordingly and adds a new dependency on dev-perl/XML-LibXSLT which is needed in case one wants to use biber's --convert_control function.
Comment 13 Christopher Schwan 2011-10-16 08:51:22 UTC
Created attachment 289929 [details]
updated ebuild for version 0.9.5
Comment 14 Christopher Schwan 2011-10-16 08:57:14 UTC
It should be possible to use biber with texlive-2010 now - I hope someone can verify that.
Comment 15 Ryan Hope 2011-11-05 15:44:54 UTC
What is the status/progress on getting biber into Portage? I really want to remove bibtex from my life!
Comment 16 Christopher Schwan 2011-12-24 11:17:03 UTC
In the meantime 0.9.6, 0.9.7 and 0.9.8 were released. These require perl 5.14 which is currently marked testing; as soon as it goes unstable I am going to upload the latest release.
Comment 17 Dennis Schridde 2012-02-19 23:39:43 UTC
Any progress of getting this into portage?
Comment 18 Michael Schindhelm 2012-04-06 19:38:45 UTC
Created attachment 308027 [details]
updated ebuild for version 0.9.9

Hi,
I created this ebuild from the earlier one and changed the depencies (some from the archlinux AUR) and some by reading the biber documentation. maybe some depencies are not realy needed. but it works on my machiene without any errors at configure and compile time. i even dont get any errors on calling it to create a bibliography
Comment 19 Dmitry Dzhus 2012-04-15 09:09:39 UTC
(In reply to comment #18)

Thank you Michael and Christopher for providing these ebuilds. It seems to work fine with my TeX Live 2011 installation.
Comment 20 Markus Oehme 2012-04-22 17:55:23 UTC
I tried to install biber-0.9.9 but was unable to find an ebuild for dev-perl/XML-Writer-String which is a dependency. I could neither find this in Bugzilla nor Google. Am I missing something obvious here?
Comment 21 Thomas Witt 2012-04-23 07:28:41 UTC
(In reply to comment #20)
> Am I missing something obvious here?

cschwan-overlay, comment 2
Comment 22 Michael Schindhelm 2012-04-28 20:41:04 UTC
Created attachment 310359 [details]
XML-Writer-String

Here is the ebuild for XML-Writer-String, which is a depency for biber 0.9.9
Comment 23 Michael Schindhelm 2012-04-28 20:49:54 UTC
Comment on attachment 308027 [details]
updated ebuild for version 0.9.9

># Copyright 1999-2011 Gentoo Foundation
># Distributed under the terms of the GNU General Public License v2
># $Header: $
>
>EAPI="4"
>
>inherit perl-app
>
>DESCRIPTION="Biber is a BibTeX replacement for users of biblatex"
>HOMEPAGE="http://biblatex-biber.sourceforge.net/"
>SRC_URI="http://downloads.sourceforge.net/project/${PN}/${PN}/${PV}/${PN}.tar.gz -> ${P}.tar.gz"
>
>LICENSE="Artistic-2"
>SLOT="0"
>KEYWORDS="~amd64"
>
>RESTRICT="mirror"
>
>DEPEND=">=dev-lang/perl-5.14
>	virtual/perl-Module-Build"
>RDEPEND="dev-perl/config-general
>	dev-perl/Data-Dump
>	dev-perl/Data-Compare
>	dev-perl/Date-Simple
>	dev-perl/File-Slurp-Unicode
>	dev-perl/File-Which
>	dev-perl/IPC-Run3
>	perl-core/IPC-Cmd
>	dev-perl/List-AllUtils
>	dev-perl/regexp-common
>	dev-perl/Log-Log4perl
>	dev-perl/Readonly
>	dev-perl/Readonly-XS
>	dev-perl/Unicode-String
>	dev-perl/XML-LibXML-Simple
>	dev-perl/XML-LibXSLT
>	dev-perl/libwww-perl
>	dev-perl/XML-Writer
>	>=dev-perl/Text-BibTeX-0.62
>	>=dev-perl/Unicode-Collate-0.89
>	>=dev-tex/biblatex-1.7"
>
>S="${WORKDIR}/${PN}-v${PV}"
>
>SRC_TEST="do"
Comment 24 Michael Schindhelm 2012-04-28 20:50:26 UTC
this should work also
Comment 25 Stephen Bosch 2012-04-29 17:56:37 UTC
(In reply to comment #21)
> (In reply to comment #20)
> > Am I missing something obvious here?
> 
> cschwan-overlay, comment 2

That overlay doesn't include 0.9.9.
Comment 26 Stephen Bosch 2012-04-29 19:08:33 UTC
No hope of 0.9.9 for x86?
Comment 27 Stephen Bosch 2012-04-29 19:40:22 UTC
Okay, the cschwan-overlay is hopeless, the biblatex-biber ebuild tries to pull all the dependencies from the main portage tree. (Thanks all the same, Christopher.)

How far are we away from getting a functional ebuild for biber into the main tree? Biber is not a fringe package, lots of people use it...
Comment 28 Dmitry Dzhus 2012-04-30 12:37:10 UTC
(In reply to comment #27)
> Okay, the cschwan-overlay is hopeless, the biblatex-biber ebuild tries to
> pull all the dependencies from the main portage tree. (Thanks all the same,
> Christopher.)

I've put together the required ebuilds for biber 0.9.9 at my personal dumpspace at http://dzhus.org/hg/gentoo-overlay, you can plug it in and merge the fresh biber. `overlays` entry for layman is `http://dzhus.org/hg/gentoo-overlay/raw-file/tip/overlay.xml`
Comment 29 Martin Väth 2012-05-01 11:19:54 UTC
I checked the sources for biblatex-biber-0.9.9, and I cannot see why the
following packages are listed as dependencies in the overlay's ebuild:

dev-perl/config-general
dev-perl/File-Which
dev-perl/Unicode-String

So maybe these dependencies can be removed?
On the other hand, I found some dependencies which are missing:

dev-perl/XML-LibXML
virtual/perl-Digest-MD5
virtual/perl-Encode
virtual/perl-File-Spec
virtual/perl-File-Temp

(Yes, XML-LibXML is an indirect dependency anyway, but it is also used
directly by biblatex-biber-0.9.9.
Moreover, the mentioned virtual packages are all satisfied in some version
by perl-0.14.2, but it is probably cleaner to make this dependency explicit. Perhaps with these packages even perl-5.12.4 could be sufficient -
I did not try this.)
Comment 30 Martin Väth 2012-05-01 11:37:35 UTC
Forgot to add: If

dev-perl/XML-LibXSLT

is really only needed for --convert_control, I suggest to make this
dependency optional with a USE-Flag (perhaps USE=debug since
--convert-control seems only useful for debugging - if at all.)
Comment 31 Christopher Schwan 2012-05-04 08:58:52 UTC
I think people now try to get biber 0.9.9 into the tree. I am fine with that, but it depends on >=perl-5.14. I did not follow the tracker bug 356171 for perl, does someone who did has an idea when we may expect it to get into ~arch?
Comment 32 Thomas Witt 2012-06-14 08:52:10 UTC
(In reply to comment #31)
> I think people now try to get biber 0.9.9 into the tree. I am fine with
> that, but it depends on >=perl-5.14. I did not follow the tracker bug 356171
> for perl, does someone who did has an idea when we may expect it to get into
> ~arch?

perl 5.16 is in ~arch now.
Comment 33 Christopher Schwan 2012-06-14 13:04:21 UTC
(In reply to comment #32)
> (In reply to comment #31)
> > I think people now try to get biber 0.9.9 into the tree. I am fine with
> > that, but it depends on >=perl-5.14. I did not follow the tracker bug 356171
> > for perl, does someone who did has an idea when we may expect it to get into
> > ~arch?
> 
> perl 5.16 is in ~arch now.

Thats great! I will try to test it at the weekend.
Comment 34 Thomas Witt 2012-07-28 15:05:11 UTC
Texlive-2012 is in the tree now. Therefore, biber needs to rdepend on 

|| (>=dev-texlive/texlive-bibtexextra-2012 >=dev-tex/biblatex-1.7)

instead of just biblatex.

And, current version is now 1.0 by the way.
Comment 35 Mira Ressel 2012-07-31 13:31:57 UTC
Created attachment 319858 [details]
dev-tex/biber-1.1.ebuild

Updated ebuild for v1.1
Comment 36 Christopher Schwan 2012-07-31 16:14:56 UTC
For those who did not look into the ebuild: The new biber also works with stable perl (5.14).
Comment 37 Alexis Ballier gentoo-dev 2012-07-31 16:18:31 UTC
it'd be great to have biber in the tree but we are currently blocked because perl deps are not in the tree, can anyone go through the blocker bugs and see what needs to be done ?
Comment 38 Mira Ressel 2012-07-31 16:34:26 UTC
Created attachment 319892 [details]
dev-tex/biber-1.1.ebuild

Biblatex got removed from dev-texlive/texlive-bibtexextra-2012 (see #428434), the || ( ... ) statement can be dropped.
Comment 39 Mira Ressel 2012-07-31 16:40:36 UTC
(In reply to comment #36)
> For those who did not look into the ebuild: The new biber also works with
> stable perl (5.14).

It works with 5.14, that's right. But 5.14 is not only not stable, it's even masked. Guess you mixed something up here... ;)
Comment 40 Christopher Schwan 2012-07-31 16:42:48 UTC
(In reply to comment #39)
> (In reply to comment #36)
> > For those who did not look into the ebuild: The new biber also works with
> > stable perl (5.14).
> 
> It works with 5.14, that's right. But 5.14 is not only not stable, it's even
> masked. Guess you mixed something up here... ;)

Err ... I upgraded from 5.12 to 5.16 and thought 5.14 was stable when I was finished :-/

Sorry for the confusion!
Comment 41 Mira Ressel 2012-07-31 20:44:37 UTC
Until biber makes its way to the main portage tree, people who want to install it the easy way (TM) can also use my overlay at http://git.spheniscida.de/?p=spiderlay;a=summary . Here's the xml file for layman: http://git.spheniscida.de/?p=spiderlay;a=blob_plain;h=refs/tags/spiderlay-xml
Comment 42 Kent Fredric (IRC: kent\n) gentoo-dev 2012-08-06 18:02:03 UTC
This might be of use to you lynx, 

emerge =dev-perl/Gentoo-PerlMod-Version-0.5.0
gentoo-perlmod-version.pl  0.1   

This will translate "upstreams" versions to normalised versions that gentoo can use consistently ( and what perl-herd will probably request / provide in terms of a packages version )

We use the normalised form in cat/pkg-v , and the upstream form in a MODULE_VERSION=  

( ie: see dev-perl/Class-Load/Class-Load-0.200.0 for an example )

XML-Writer-String-0.1  ->  XML-Writer-String-0.100.0
Business-ISSN-0.91     ->  Business-ISSN-0.910.0


yes, this aught to be documented in the herd docs somewhere, just nobodys' had the tuits to =).
Comment 43 Sven 2012-08-06 18:25:39 UTC
(In reply to comment #42)
> ( ie: see dev-perl/Class-Load/Class-Load-0.200.0 for an example )
> 
> XML-Writer-String-0.1  ->  XML-Writer-String-0.100.0
> Business-ISSN-0.91     ->  Business-ISSN-0.910.0
> 
> yes, this aught to be documented in the herd docs somewhere, just nobodys'
> had the tuits to =).

Can you explain why this is done? Is it even correct?
I mean, the version number 0.2 is clearly smaller than 0.11, however, according to your normailization example above, 0.2 would be normaled to 0.200.0 and 0.11 would be normalized to 0.110.0 - but 0.110.0 is smaller than 0.200.0.
Comment 44 Kent Fredric (IRC: kent\n) gentoo-dev 2012-08-06 18:47:52 UTC
(In reply to comment #43)
> (In reply to comment #42)
> > ( ie: see dev-perl/Class-Load/Class-Load-0.200.0 for an example )
> > 
> > XML-Writer-String-0.1  ->  XML-Writer-String-0.100.0
> > Business-ISSN-0.91     ->  Business-ISSN-0.910.0
> > 
> > yes, this aught to be documented in the herd docs somewhere, just nobodys'
> > had the tuits to =).
> 
> Can you explain why this is done? Is it even correct?
> I mean, the version number 0.2 is clearly smaller than 0.11, however,
> according to your normailization example above, 0.2 would be normaled to
> 0.200.0 and 0.11 would be normalized to 0.110.0 - but 0.110.0 is smaller
> than 0.200.0.

No, not in Perl it is not.  0.2 is a decimal, 0.11 is a decimal. 0.20 > 0.11 .

If you see 'v0.2' however, then thats equivalent to '0.002' in decimal, so 'v0.11  > v0.2' 

0.2.0 and v0.2 are essentially both the same thing, they're both 0.002000 in decimal form. 

Versions are, needlessly complicated, enough there is a whole article on the mess: http://www.dagolden.com/index.php/369/version-numbers-should-be-boring/

This too both a) unifies all upstream versions into a singular scheme across all of portage. b) translates the numbers to be semantically the same in portage as they do upstream.
Comment 45 Sven 2012-08-06 18:57:37 UTC
(In reply to comment #44)
> Versions are, needlessly complicated, enough there is a whole article on the
> mess: http://www.dagolden.com/index.php/369/version-numbers-should-be-boring/

Oh I see. Perl versions numbers (at least those for modules) are a mess.
Thanks for the link.
Comment 46 Mira Ressel 2012-08-07 09:39:35 UTC
(In reply to comment #42)
> This might be of use to you lynx, 

Yes, it cleary is. Thanks for the tip! I updated the ebuilds in my overlay, but I hope I don't have to upload all these new ebuilds to the respective bugs?
Comment 47 Mira Ressel 2012-09-09 18:36:48 UTC
Biber 1.2 is out. It still works with >=biblatex-1.1, so the ebuild doesn't need to be changed.
Comment 48 Mira Ressel 2012-09-11 12:36:35 UTC
(In reply to comment #37)
> it'd be great to have biber in the tree but we are currently blocked because
> perl deps are not in the tree, can anyone go through the blocker bugs and
> see what needs to be done ?

Tove pushed some of the dependencies to the tree (thanks!), but there are still some left. Most of them (Business::ISBN, Mozilla::CA, XML::Writer::String) should be unproblematic. The deps of Text::BibTeX are already in perl-experimental, so that should be unproblematic, too. The only remaining problem is Unicode::Collate. It's also in perl-experimental (virtual/perl-Unicode-Collate & perl-core/Unicode-Collate), but it's hardmasked with the reason "experimental perl-core stuff".

When everything is ready, I'd offer to proxy-maintain biber if no dev is willing to do that himself, so that shouldn't be a problem either.
Comment 49 Sven 2012-09-11 12:59:28 UTC
On cygwin, they devliver a biber.exe which is a PAR binary, which mean that it contains a perl interpreter and all perl packages and native libraries that are needed to run biber.

Now while that is a pretty crappy way of packaging biber (the executable is 14MB is size, and first time it is run, it unpacks itself to /tmp/..., the biber executable contaisn copies of some stuff which violates gentoo security guidelines), it works.
Comment 50 Kent Fredric (IRC: kent\n) gentoo-dev 2012-09-11 16:19:13 UTC
> The only remaining problem is Unicode::Collate. It's also in perl-experimental
>(virtual/perl-Unicode-Collate & perl-core/Unicode-Collate), but it's hardmasked
> with the reason "experimental perl-core stuff".

You don't /need/ to depend on the virtual unless you need a specific minimum version of Unicode::Collate.

Unicode::Collate has been part of perl itself since well before Perl 5.8, the only thing that is really "experimental" about it is the dual-lifing system, which we try not forcing into tree until something needs a specific minimum version.
Comment 51 Mira Ressel 2012-09-11 16:26:00 UTC
Ah, ok, I didn't know this. Then I'll just remove the dep from the ebuild... Thanks!
Comment 52 Mira Ressel 2012-09-11 18:34:01 UTC
Created attachment 323538 [details]
Updated ebuild for biber-1.2
Comment 53 Mira Ressel 2012-10-05 18:56:47 UTC
Created attachment 325746 [details]
biber-1.2.ebuild

Patched biber to remove the dep on Mozilla::CA, as requested by tove. I'm not 100% sure if it will work this way, but the source says "We have to explicitly set the cert path because otherwise the https module can't find the .pem when PAR::Packer'ed".

We don't plan use PAR::Packer on the program, so it should be fine if we just dropped this part. Could some perl dev please look at this?

If this patch works, the last thing which has to be done is to get Text-BibTeX in the tree...
Comment 54 Mira Ressel 2012-10-05 18:57:08 UTC
Created attachment 325748 [details]
biber-1.2-drop-Mozilla-CA.patch
Comment 55 Manuel Rüger (RETIRED) gentoo-dev 2012-11-02 11:02:14 UTC
biber-1.3 was released.

@ Luis
Have you notified upstream about your patch?
Comment 56 Thomas Witt 2012-11-08 11:48:50 UTC
Created attachment 328794 [details]
biber-1.3 ebuild

They changed the source tarball without the version number. The ebuild in mrueg-overlay does not work. New Dependency: dev-perl/Data-Diver
Comment 57 Eugene Shalygin 2012-11-08 13:42:45 UTC
> They changed the source tarball without the version number. The ebuild in
> mrueg-overlay does not work. New Dependency: dev-perl/Data-Diver

This is brecause after release tarballs were containing version 1.2 instead of 1.3. Now this is fixed and they contain 1.3

Also, biber asks for Text-BibTeX >= 0.65
Comment 58 Manuel Rüger (RETIRED) gentoo-dev 2012-11-08 15:28:26 UTC
> > They changed the source tarball without the version number. The ebuild in
> > mrueg-overlay does not work. New Dependency: dev-perl/Data-Diver
> 
> This is brecause after release tarballs were containing version 1.2 instead
> of 1.3. Now this is fixed and they contain 1.3
> 
> Also, biber asks for Text-BibTeX >= 0.65
Thank you for your information. It worked for me, so I added it to the overlay. Now (with 1.3 sources) the Mozilla-CA patch doesn't apply anymore, so I dropped it and added Mozilla-CA as a dep.
Comment 59 Mira Ressel 2012-11-08 19:07:12 UTC
(In reply to comment #58)
> Thank you for your information. It worked for me, so I added it to the
> overlay. Now (with 1.3 sources) the Mozilla-CA patch doesn't apply anymore,
> so I dropped it and added Mozilla-CA as a dep.

The patch doesn't apply anymore because upstream was so kind to introduce a possibilty for using external CA data instead of Mozilla::CA after I talked to them.

I'll have a closer look at this tomorrow. The interaction with external CA data has to be tested, but apart from that, I don't see any blockers.

@TeX Herd: Would you mind taking care of the package after we got it into the tree?
Comment 60 Thomas Witt 2012-11-29 13:23:34 UTC
Created attachment 330934 [details]
biber-1.4 ebuild

biber 1.4 released, needs biblatex-2.4 from bug #437116
Comment 61 Christopher Schwan 2013-01-01 12:09:45 UTC
I've checked your ebuild. The following dependencies are still needed:

- dev-perl/LWP-Protocol-https. Since USE=ssl is default in most desktop profiles, it is pulled in by libwww-perl[ssl]. So we should either depend on that or explicitly on dev-perl/LWP-Protocol-https. In my overlay I used the former method. Without that the tests fail, btw.
- dev-perl/Mozilla-CA is needed as well, at least for the test to succeed.
- dev-perl/URI. This is pulled in with libwww-perl again, but biber directly depends on it. See lib/Biber/Input/file/ris.pm

Apart from that your ebuild is fine (at least as far as I see). It is also nice that you found some superfluous deps:

- dev-perl/Config-AutoConf
- dev-perl/ExtUtils-LibBuilder
- dev-perl/List-MoreUtils
Comment 62 Manuel Rüger (RETIRED) gentoo-dev 2013-01-01 13:51:28 UTC
(In reply to comment #50)
> > The only remaining problem is Unicode::Collate. It's also in perl-experimental
> >(virtual/perl-Unicode-Collate & perl-core/Unicode-Collate), but it's hardmasked
> > with the reason "experimental perl-core stuff".
> 
> You don't /need/ to depend on the virtual unless you need a specific minimum
> version of Unicode::Collate.
> 
> Unicode::Collate has been part of perl itself since well before Perl 5.8,
> the only thing that is really "experimental" about it is the dual-lifing
> system, which we try not forcing into tree until something needs a specific
> minimum version.


I think it is needed now? 

 * Using Module::Build
 * perl Build.PL --installdirs=vendor --libdoc= --destdir=/var/tmp/portage/dev-tex/biber-1.4/image/ --create_packlist=0
Checking prerequisites...
  requires:
    !  Unicode::Collate (0.89) is installed, but we need version >= 0.90

(Installed perl version: 5.16.1)
Comment 63 theodor 2013-01-20 00:09:35 UTC
Biber 1.5 was released. What are the chances to see it added to the portage tree?
Comment 64 Markus Oehme 2013-02-02 09:25:52 UTC
Created attachment 337648 [details]
biber-1.5 ebuild

I bumped the biber-1.4 ebuild to biber-1.5 and added the mentioned dependencies. Everything worked out fine.
Comment 65 Dennis Schridde 2013-03-19 20:28:51 UTC
This bugreport needs to depend on bug #386803, since dev-perl/ExtUtils-LibBuilder is currently not in the tree.
Comment 66 Dennis Schridde 2013-03-19 20:31:28 UTC
(In reply to comment #65)
> This bugreport needs to depend on bug #386803, since
> dev-perl/ExtUtils-LibBuilder is currently not in the tree.
Sorry, the dependency is indirect and already tracked in bug #386811.
Comment 67 Dennis Schridde 2013-03-19 20:44:50 UTC
But there are actual issues with this ebuild:
Checking prerequisites...
  requires:
    !  Mozilla::CA is not installed
    !  Unicode::Collate (0.89) is installed, but we need version >= 0.90
Comment 68 Christopher Schwan 2013-04-04 12:41:55 UTC
Created attachment 344370 [details, diff]
Remove RDEPEND on Mozilla-CA

I updated the patch that removes the dependency on Mozilla-CA. This should be used instead of "biber-1.2-drop-Mozilla-CA.patch". The patch also does not harm the tests.

However, I noticed that there is one test (the "HTTPS Test" in t/remote-files.t) that fails randomly because the HTTPS server sends data that differs from time to time; but this is not related to this patch. I reported the behavior to upstream at https://sourceforge.net/p/biblatex-biber/bugs/142/ .
Comment 69 Manuel Rüger (RETIRED) gentoo-dev 2013-05-01 00:10:59 UTC
Biber-1.6 was released and added 
"Encode::EUCJPASCII" : "0",
"Encode::HanExtra" : "0",
"Encode::JIS2K" : "0", 
"Unicode::GCString" : "0", 
as new dependencies. (dev-perl/Encode-HanExtra is already available in tree)

These deps have now raised versions: 
"Unicode::Collate" : "0.97", (0.90, currently available included in perl-5.16.3 is 0.89)
"perl" : "v5.16.0" (was 5.14.0 before)
Comment 70 Christopher Schwan 2013-05-03 06:53:17 UTC
Created attachment 347206 [details]
Ebuild for biber 1.6

There are a number of dependencies that are not referenced anywhere in the source.  This includes the newly added Encode packages. Just ignore the warnings.
Comment 71 Christopher Schwan 2013-05-03 06:54:24 UTC
Created attachment 347208 [details, diff]
Patch to get rid of Mozilla-CA and use the system-wide certificates instead
Comment 72 Erik Quaeghebeur 2013-05-19 20:55:25 UTC
(In reply to comment #69)
I installed from mrueg overlay. I tested (tool mode only) it and it works. Thanks for providing it; a bit more convenient than downloading from here. Some feedback:

* There is a file-size mismatch (download file was changed?)

* The pdf docs are not installed (perhaps this also holds for the ebuild attached to this bug?), while biber.pdf (for biber 1.0) from texlive is installed, creating a version mismatch.
Comment 73 Manuel Rüger (RETIRED) gentoo-dev 2013-05-19 21:43:34 UTC
(In reply to comment #72)
> (In reply to comment #69)
> I installed from mrueg overlay. I tested (tool mode only) it and it works.
> Thanks for providing it; a bit more convenient than downloading from here.
> Some feedback:
> 
> * There is a file-size mismatch (download file was changed?)
> 
> * The pdf docs are not installed (perhaps this also holds for the ebuild
> attached to this bug?), while biber.pdf (for biber 1.0) from texlive is
> installed, creating a version mismatch.

Thanks for your report, I fixed the manifest and added a doc useflag, that installs the missing pdf.
Comment 74 Florian Manschwetus 2013-07-09 13:33:18 UTC
biber 1.7 is released for use with biblatex 2.7
Comment 75 Manuel Rüger (RETIRED) gentoo-dev 2013-07-11 18:27:05 UTC
Version bumped in my overlay. Biblatex-2.7 is already in the tree.

In the next week I'll add biber (including Mozilla-CA, as it is needed in a test) and its dependencies to the tree, if there are no objections against it.
Comment 76 Manuel Rüger (RETIRED) gentoo-dev 2013-08-03 20:51:29 UTC
I've added most of the missing depencies to the tree.

Missing dependencies, will add them in the next days: 

Encode-EUCJPASCII
Encode-JIS2K
Mozilla-CA
Comment 77 Christopher Schwan 2013-08-04 07:00:51 UTC
Thanks for taking care of this, Manuel! Did you test my patch for getting rid of the Mozilla-CA? AFAIR everything worked, even the tests.
Comment 78 Manuel Rüger (RETIRED) gentoo-dev 2013-08-06 00:07:12 UTC
I rebased the patch so it applies to biber-1.7 and disabled the ssl-test.

So after more than 2.5 years, it's time to close this bug. Many thanks for your help!

*biber-1.7 (06 Aug 2013)

  06 Aug 2013; Manuel Rüger <mrueg@gentoo.org> +biber-1.7.ebuild, +metadata.xml:
  Initial version. Thanks to Luis Ressel (original patch author) and all the
  other users in bug #340353 (which is fixed now)
Comment 79 Erik Quaeghebeur 2013-08-08 08:07:16 UTC
(In reply to Manuel Rüger from comment #78)
> *biber-1.7 (06 Aug 2013)

Dear Manuel: I needed the live ebuild biber-9999 in your overlay, and still do (due to a regression in 1.7 that is fixed in the upcoming 1.8). It seems the live ebuild is gone. Would it be possible to revive it?
Comment 80 Christoph Lange 2013-08-14 06:54:21 UTC
(In reply to Manuel Rüger from comment #78)
> So after more than 2.5 years, it's time to close this bug. Many thanks for
> your help!
Let me, the original poster, say thanks to all of you for your hard work!