Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 378953 - net-nds/389-ds-base-1.2.8.3 with use selinux build fail
Summary: net-nds/389-ds-base-1.2.8.3 with use selinux build fail
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Fabio Erculiani (RETIRED)
URL:
Whiteboard:
Keywords:
: 378661 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-12 17:05 UTC by Andreis Vinogradovs ( slepnoga )
Modified: 2011-08-14 09:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
gzipped build log (build.log.gz,50.12 KB, text/plain)
2011-08-12 17:10 UTC, Andreis Vinogradovs ( slepnoga )
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreis Vinogradovs ( slepnoga ) 2011-08-12 17:05:28 UTC
net-nds/389-ds-base-1.2.8.3 with use selinux build fail 

Reproducible: Always




after bug #378661 closed, I have build 389-ds-base again.
Build fail.
Comment 1 Andreis Vinogradovs ( slepnoga ) 2011-08-12 17:07:57 UTC
@sttyexec\@,/bin/stty,g' -e 's,@initconfigdir\@,/etc/default,g' -e 's,@updatedir\@,/usr/share/dirsrv/updates,g' -e 's,@ldaplib\@,mozldap,g' -e 's,@ldaplib_defs\@,,g' ldap/ldif/template-sasl.ldif.in > ldap/ldif/template-sasl.ldif
make[1]: Leaving directory `/var/tmp/portage/net-nds/389-ds-base-1.2.8.3/work/389-ds-base-1.2.8.3'
make -j4 -f selinux/Makefile 
if [ ! -e /usr/share/selinux/devel/Makefile ]; then echo "You need to install the SELinux policy development tools (selinux-policy)" && exit 1; fi
You need to install the SELinux policy development tools (selinux-policy)
make: *** [all] Error 1
emake failed
 * ERROR: net-nds/389-ds-base-1.2.8.3 failed (compile phase):
 *    build selinux policy failed
 * 
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 3194:  Called die
 * The specific snippet of code:
Comment 2 Andreis Vinogradovs ( slepnoga ) 2011-08-12 17:10:27 UTC
Created attachment 283075 [details]
gzipped build log

overdimensioning ( 1,4 мб)
Comment 3 Fabio Erculiani (RETIRED) gentoo-dev 2011-08-13 06:08:35 UTC
Done

+  13 Aug 2011; Fabio Erculiani <lxnay@gentoo.org> 389-ds-base-1.2.8.3.ebuild,
+  +files/selinux.patch:
+  apply back a patch for selinux, close bug 378953

Thanks.
Comment 4 Alexey Shvetsov gentoo-dev 2011-08-13 20:42:47 UTC
*** Bug 378661 has been marked as a duplicate of this bug. ***
Comment 5 Alexey Shvetsov gentoo-dev 2011-08-13 20:43:26 UTC
Reopened per  Andreis_Vinogradovs request
Comment 6 Fabio Erculiani (RETIRED) gentoo-dev 2011-08-14 09:01:45 UTC
As I said, it's been fixed with the latest commit.
Patched, tested, committed.