Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 376987 - Unmask dev-lang/spidermonkey-1.8.5
Summary: Unmask dev-lang/spidermonkey-1.8.5
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Dirkjan Ochtman
URL:
Whiteboard:
Keywords:
Depends on: 360971 363575 376979 376993 377025 378367 390631 391269 391297
Blocks: gnome3.2
  Show dependency tree
 
Reported: 2011-07-29 19:56 UTC by Ian Stakenvicius (RETIRED)
Modified: 2012-10-11 20:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Stakenvicius (RETIRED) gentoo-dev 2011-07-29 19:56:10 UTC
This is a tracker bug to support the unmasking of dev-lang/spidermonkey-1.8.5 .. I am in the process of reviewing all ebuilds that depend on spidermonkey and am filing bugs on each of them in order to handle (at minimum) compile-time support.



Reproducible: Always
Comment 1 Ian Stakenvicius (RETIRED) gentoo-dev 2011-07-29 21:06:18 UTC
..ok I think that's all the deps.  

It should be noted that www-client/elinks currently does not support spidermonkey-1.8.5 (DEPENDs already show this).

Also, net-libs/libproxy may need a patch to support discovery of spidermonkey-1.8.5 instead of xulrunner-2, if they turn javascript support back on (see bug 360893 comment 16)
Comment 2 Ian Stakenvicius (RETIRED) gentoo-dev 2011-08-09 15:34:17 UTC
regarding bug 376979 , the maintainer has said that current versions of app-accessibility/edbrowse can be masked when spidemronkey-1.8.5 is unmasked (the next release will support spidermonkey-1.8.5)
Comment 3 Ian Stakenvicius (RETIRED) gentoo-dev 2011-11-22 21:12:41 UTC
OK, checklist:

app-accessibility/edbrowse - works
dev-db/couchdb - works as of 1.1.1
dev-db/mongodb - got three bugs on activities related to this one
dev-libs/gjs - works as of 1.30.0
dev-perl/JavaScript-SpiderMonkey - fixed now that js shell is available
dev-vcs/veracity - n/a, they embed their own version
gnome-base/gnome-shell - good to go, needs 1.8.5
media-gfx/freewrl - supports 1.8.5
media-libs/coin - doesn't work with any >=1.8 atm, not a holdback
media-video/gpac - removed javascript support
media-video/gxine - crashing at runtime but not related to sm-1.8.5
net-misc/mediatomb - fixed
net-misc/plowshare - fixed now that js shell is available
www-client/elinks - fix ready, waiting for maintainer to approve/commit


Looks like we're nearly ready.  All that's left is committing the change for elinks (bug 391297) and resolving mongodb (the other three).
Comment 4 Ian Stakenvicius (RETIRED) gentoo-dev 2011-11-24 18:06:47 UTC
Anarchy gave the go-ahead to unmask, as the remaining bugs are not serious enough to block things (all of their current deps are valid).


+  24 Nov 2011; Ian Stakenvicius <axs@gentoo.org> package.mask:
+  Unmasked dev-lang/spidermonkey-1.8.5 and non-gnome3 package versions that
+  depend on it
+