Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 370645 - net-analyzer/dsniff with sys-libs/glibc-2.14 - ./filesnarf.c:14:21: fatal error: rpc/rpc.h: No such file or directory
Summary: net-analyzer/dsniff with sys-libs/glibc-2.14 - ./filesnarf.c:14:21: fatal err...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
: 630642 (view as bug list)
Depends on:
Blocks: glibc-rpc
  Show dependency tree
 
Reported: 2011-06-08 09:09 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2018-03-02 21:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (dsniff-2.4_beta1-r5:20110607-213045.log,8.49 KB, text/plain)
2011-06-08 09:09 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-06-08 09:09:07 UTC
Created attachment 276261 [details]
Build log

Portage 2.1.10 (default/linux/x86/10.0, gcc-4.6.0-asneeded, glibc-2.14-r0, 2.6.39 i686)
=================================================================
System uname: Linux-2.6.39-i686-Quad-Core_AMD_Opteron-tm-_Processor_2350-with-gentoo-2.0.2
Timestamp of tree: Mon, 06 Jun 2011 20:30:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.2
dev-util/cmake:           2.8.4-r1
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21
sys-devel/gcc:            4.6.0
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.14
Repositories: gentoo
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/tomoyo/conf /usr/share/bufrtables /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /usr/share/qpsmtpd/plugins /var/lib/hsqldb /var/phxd /var/qmail/alias /var/qmail/control /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms split-log strict test test-fail-continue unknown-features-warn unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.wheel.sk/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j14"
PKGDIR="/var/spool/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/tree"
PORTDIR_OVERLAY=""
SYNC="rsync://yamato.home.flameeyes.eu/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 java5 java6 modules mudflap mysql ncurses nls nostatic nptl nptlonly openmp pam pcre pcsc-lite perl postgres pppd python qt3support readline ruby semantic-desktop session ssl sysfs tcpd unicode vhosts x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest cgi" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18 jruby ruby19 ree18" USERLAND="GNU" VIDEO_CARDS="intel radeon nouveau vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
=== Window terminated (Tue Jun  7 08:54:06 2011) ===
Comment 1 Steev Klimaszewski gentoo-dev 2013-08-06 07:18:13 UTC
Is this bug even valid anymore?  It builds here against glibc 2.15, and I'm pretty sure I built it on a system with glibc 2.17
Comment 2 Jeroen Roovers gentoo-dev 2013-08-06 11:21:26 UTC
The bug will be valid again when Gentoo stops patching RPC support into glibc. We could intermittently close all bugs that block bug #381391 or we just leave them as they are now.
Comment 3 Larry the Git Cow gentoo-dev 2017-09-16 15:48:49 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d57c699afeb1df34ac362f360473ea81258df3ab

commit d57c699afeb1df34ac362f360473ea81258df3ab
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2017-09-16 15:47:54 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2017-09-16 15:48:28 +0000

    net-analyzer/dsniff: Fix build against glibc-2.26, bug 370645
    
    The autotools patch does the absolute minimum for a successful build;
    more elegant solutions are certainly possible.
    Buildtested against glibc-2.25 (with included rpc support) and glibc-2.26
    (without).
    
    Closes: https://bugs.gentoo.org/370645
    Package-Manager: Portage-2.3.8, Repoman-2.3.3

 net-analyzer/dsniff/dsniff-2.4_beta1-r8.ebuild     | 13 +++++++++++-
 net-analyzer/dsniff/files/2.4_beta1-libtirpc.patch | 24 ++++++++++++++++++++++
 2 files changed, 36 insertions(+), 1 deletion(-)
Comment 4 Jeroen Roovers gentoo-dev 2017-09-17 18:43:19 UTC
--- a/Makefile.in
+++ b/Makefile.in
@@ -37,8 +37,8 @@
 X11INC = @X_CFLAGS@
 X11LIB = @X_LIBS@ @X_PRE_LIBS@ -lXmu -lX11 @X_EXTRA_LIBS@

-INCS   = -I. $(X11INC) -I$(srcdir)/missing
-LIBS   = @LIBS@ -L$(srcdir) -lmissing
+INCS   = -I. $(X11INC) -I$(srcdir)/missing @TIRPC_CFLAGS@
+LIBS   = @LIBS@ -L$(srcdir) -lmissing @TIRPC_LIBS@

 INSTALL    = @INSTALL@
 INSTALL_PROGRAM = @INSTALL_PROGRAM@

Now every binary gets the libtirpc tacked on, and we have an addition to the Makefile that does not use the same format as other auxiliary libraries. Who signed off on this, again?
Comment 5 Andreas K. Hüttel gentoo-dev 2017-10-04 13:58:57 UTC
(In reply to Jeroen Roovers from comment #4)
> --- a/Makefile.in
> +++ b/Makefile.in
> @@ -37,8 +37,8 @@
>  X11INC = @X_CFLAGS@
>  X11LIB = @X_LIBS@ @X_PRE_LIBS@ -lXmu -lX11 @X_EXTRA_LIBS@
> 
> -INCS   = -I. $(X11INC) -I$(srcdir)/missing
> -LIBS   = @LIBS@ -L$(srcdir) -lmissing
> +INCS   = -I. $(X11INC) -I$(srcdir)/missing @TIRPC_CFLAGS@
> +LIBS   = @LIBS@ -L$(srcdir) -lmissing @TIRPC_LIBS@
> 
>  INSTALL    = @INSTALL@
>  INSTALL_PROGRAM = @INSTALL_PROGRAM@
> 
> Now every binary gets the libtirpc tacked on, and we have an addition to the
> Makefile that does not use the same format as other auxiliary libraries. Who
> signed off on this, again?

The same person who did nothing for 3 years about this bug, knowing it will become important at some point again?
Comment 6 Andreas K. Hüttel gentoo-dev 2017-11-01 21:19:39 UTC
*** Bug 630642 has been marked as a duplicate of this bug. ***
Comment 7 Larry the Git Cow gentoo-dev 2018-03-02 17:31:58 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=17e48ce1fb4274f1d358b7e37a5c08e7511fd260

commit 17e48ce1fb4274f1d358b7e37a5c08e7511fd260
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2018-03-02 17:04:28 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2018-03-02 17:31:28 +0000

    net-analyzer/dsniff: Get rid of libtirpc automagic and depend on it instead
    
    Closes: https://bugs.gentoo.org/370645
    Package-Manager: Portage-2.3.24, Repoman-2.3.6

 net-analyzer/dsniff/dsniff-2.4_beta1-r10.ebuild | 83 +++++++++++++++++++++++++
 net-analyzer/dsniff/files/2.4_beta1-rpc.patch   | 39 ++++++++++++
 2 files changed, 122 insertions(+)