Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 368997 - net-misc/tightvnc with media-fonts/font-misc-misc[-nls] - /etc/init.d/vnc: Fatal server error: could not open default font 'fixed'
Summary: net-misc/tightvnc with media-fonts/font-misc-misc[-nls] - /etc/init.d/vnc: Fa...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard: Pending removal: 2016-09-21
Keywords: PMASKED
: 411397 573410 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-28 09:55 UTC by Florian Schmaus
Modified: 2016-10-01 07:05 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
first proposed solution (tightvnc-1.3.10-r1-ebuild.patch,363 bytes, patch)
2014-03-20 13:09 UTC, Jan Zahornadsky
Details | Diff
ebuild patch (first variant) (tightvnc-1.3.10-r1-ebuild.patch,363 bytes, patch)
2014-03-20 13:29 UTC, Jan Zahornadsky
Details | Diff
ebuild patch (second variant) (tightvnc-1.3.10-r1-ebuild-var2.patch,1.05 KB, patch)
2014-03-20 13:30 UTC, Jan Zahornadsky
Details | Diff
tightvnc-1.3.10 patch for "fixed" as popup font fallback (tightvnc-1.3.10-fixed-font.patch,942 bytes, patch)
2014-03-20 13:32 UTC, Jan Zahornadsky
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Schmaus 2011-05-28 09:55:31 UTC
* Starting TightVNC server ...
Couldn't start Xvnc; trying default font path.
Please set correct fontPath in the vncserver script.
Couldn't start Xvnc process.

28/05/11 11:37:57 Xvnc version TightVNC-1.3.10
28/05/11 11:37:57 Copyright (C) 2000-2009 TightVNC Group
28/05/11 11:37:57 Copyright (C) 1999 AT&T Laboratories Cambridge
28/05/11 11:37:57 All Rights Reserved.
28/05/11 11:37:57 See http://www.tightvnc.com/ for information on TightVNC
28/05/11 11:37:57 Desktop name 'X' (xxx:1)
28/05/11 11:37:57 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
28/05/11 11:37:57 Listening for VNC connections on TCP port 5901
28/05/11 11:37:57 Listening for HTTP connections on TCP port 5801
28/05/11 11:37:57   URL http://xxx:5801
Font directory '/usr/share/fonts/Type1/' not found - ignoring

Fatal server error:
could not open default font 'fixed'
28/05/11 11:37:58 Xvnc version TightVNC-1.3.10
28/05/11 11:37:58 Copyright (C) 2000-2009 TightVNC Group
28/05/11 11:37:58 Copyright (C) 1999 AT&T Laboratories Cambridge
28/05/11 11:37:58 All Rights Reserved.
28/05/11 11:37:58 See http://www.tightvnc.com/ for information on TightVNC
28/05/11 11:37:58 Desktop name 'X' (servitor:1)
28/05/11 11:37:58 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
28/05/11 11:37:58 Listening for VNC connections on TCP port 5901
28/05/11 11:37:58 Listening for HTTP connections on TCP port 5801
28/05/11 11:37:58   URL http://xxx:5801
Font directory '/usr/X11R6/lib/X11/fonts/misc/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/Speedo/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/Type1/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/75dpi/' not found - ignoring
Font directory '/usr/X11R6/lib/X11/fonts/100dpi/' not found - ignoring


It seems like vncserver is unable to find some needed fonts. It's the same problem as reported on the forums: http://forums.gentoo.org/viewtopic-t-867073.html?sid=38c9d28d0e20ac793d970b1c14043a85

Diff of font-misc-misc w and w/o NLS Use Flag: http://paste.pocoo.org/show/396590/

emerge --info from affected system: http://paste.pocoo.org/show/396592/
Comment 1 David Sparks 2011-09-09 14:14:47 UTC
I can confirm re-emerging font-misc-misc with +nls fixes the "could not open default font 'fixed'" problem:

user $ vncserver -name XYZ -depth 16 -geometry 1024x768 :32
Couldn't start Xvnc; trying default font path.
could not open default font 'fixed'
...

root # USE=nls emerge -v font-misc-misc
...

user $ vncserver -name XYZ -depth 16 -geometry 1024x768 :32

New 'XYZ' desktop is gentoo:32

Starting applications specified in /home/gentoo/.vnc/xstartup
...
Comment 2 Andre 2011-10-18 08:15:31 UTC
This is a dup of Bug 357331, I think.

https://bugs.gentoo.org/show_bug.cgi?id=357331
Comment 3 Raúl Porcel (RETIRED) gentoo-dev 2012-06-03 16:57:08 UTC
*** Bug 411397 has been marked as a duplicate of this bug. ***
Comment 4 Longpoke 2012-06-23 17:37:43 UTC
This just happened to me as well while trying to start tightvnc server.

/usr/share/fonts/misc/fonts.alias had an entry like this:
fixed        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1

but /usr/share/fonts/misc/fonts.dir had no entry for "-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1"

moreover /usr/share/fonts/misc/fonts.alias was missing until I did emerge -1 media-fonts/font-alias

media-fonts/font-alias-1.0.3
media-fonts/font-misc-misc-1.1.2
net-misc/tightvnc-1.3.10-r1:0
Comment 5 Longpoke 2012-06-23 17:45:55 UTC
forgot to mention adding the nls useflag to media-fonts/font-misc-misc fixed it for me as well
Comment 6 Frank Sieber 2014-01-23 17:20:09 UTC
Same problem here. Default font fixed not found when starting vncserver.

Installing font-misc-misc with USE flag nls solves the problem for me too.
Comment 7 Frank Sieber 2014-01-23 17:23:40 UTC
By the way: Why is version 2.X of tightvnc not in portage?
Comment 8 Jan Zahornadsky 2014-03-20 13:09:43 UTC
Created attachment 373092 [details, diff]
first proposed solution
Comment 9 Jan Zahornadsky 2014-03-20 13:29:09 UTC
Created attachment 373098 [details, diff]
ebuild patch (first variant)
Comment 10 Jan Zahornadsky 2014-03-20 13:30:44 UTC
Created attachment 373100 [details, diff]
ebuild patch (second variant)
Comment 11 Jan Zahornadsky 2014-03-20 13:32:08 UTC
Created attachment 373102 [details, diff]
tightvnc-1.3.10 patch for "fixed" as popup font fallback
Comment 12 Jan Zahornadsky 2014-03-20 13:33:03 UTC
Frank Sieber, it looks like the tight vnc version >=2 is windows-only.

I can confirm this issue on multiple different setups, it starts showing up with tightvnc anywhere I disable the nls flag.

The media-fonts/font-misc-misc[nls] fixed it for me too. So did

$ echo "*popup*font: fixed" | xrdb -merge

in the X session before running the vncviewer.

I assume it's caused by the lack of creating the fonts for ISO-8859-1 encoding, causing the default fallback *popup*font Xresource not to be resolved.

So I see two quick solutions, although specific only to this package (I haven't experienced it with any other, but then, I don't use anywhere near as many packages):

1. make sure tightvnc ebuild requests media-fonts/font-misc-misc with the nls flag. That might confuse some people who have -nls system now and think they don't need the flag...

2. add nls flag to the tightvnc that (if disabled) would change the fallback popup font (-*-helvetica-bold-r-*-*-16-*-*-*-*-*-*-*) to something more generic (I've used fixed without any further specification, maybe something else would serve better).

These both solve it for me and I've attached the patches here (sorry for the duplicate).

There might be also some other, better, solution, probably by changing the media-fonts/font-misc-misc to install ISO 8859-1 encoding, even with -nls?

What do you think?
Comment 13 Pacho Ramos gentoo-dev 2016-05-21 14:53:07 UTC
Are you willing to proxy maintain this?
wiki.gentoo.org/wiki/Project:Proxy_Maintainers

Thanks
Comment 14 Pacho Ramos gentoo-dev 2016-05-21 15:04:34 UTC
*** Bug 573410 has been marked as a duplicate of this bug. ***
Comment 15 Pacho Ramos gentoo-dev 2016-08-08 10:46:08 UTC
Also, if I don't misremember, tigervnc forked this and maybe we could treeclean this old software (that is dead since version 2 is only for windows and it is the only one still being developed)
Comment 16 Pacho Ramos gentoo-dev 2016-10-01 07:05:35 UTC
removed