Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 357331 - xorg-2.eclass: Various x apps (xterm, xfontsel) don't start due to missing fonts (See Comment #7)
Summary: xorg-2.eclass: Various x apps (xterm, xfontsel) don't start due to missing fo...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal with 2 votes (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 357693 359679 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-04 10:42 UTC by Andre
Modified: 2018-05-26 20:30 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andre 2011-03-04 10:42:59 UTC
app-text/xpdf-3.02-r4  does not start up any more for me.
Even without any document to load, it warns about not finding a font. 
The full error message is pasted below.

I encountered the failure after a complete world rebuild I did 
after the upgrade to glibc-2.11.3.

Due to the many references to Motif in the Error message 
I tried rebuilding openmotif and xpdf, to no avail.
Also I tried openmotif with the xft use flag enabled, which did not help either.

The git version (-9999) of xpdf works fine.
There are some font warnings as well, but it does start up:

# xpdf
Warning: Cannot convert string "-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1" to type FontStruct
Warning: Cannot convert string "-*-courier-medium-r-normal--12-*-*-*-*-*-iso8859-1" to type FontStruct
Warning: Cannot convert string "-*-times-bold-i-normal--20-*-*-*-*-*-iso8859-1" to type FontStruct
Warning: Cannot convert string "-*-times-medium-r-normal--16-*-*-*-*-*-iso8859-1" to type FontStruct


I'm not shure what further info may be helpful, so don't hesitate to ask
for encores.

The rather repetetive error message is as follows:

# xpdf
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-efont-biwidth-medium-r-normal--14-*-*-*-*-*-*-*,        -gnu-unifont-medium-r-normal--16-*-*-*-p-*-*-*,   -adobe-helvetica-medium-r-normal-*-14-*-*-*-p-*-iso10646-1,   -adobe-helvetica-medium-r-normal-*-14-*-*-*-p-*-iso8859-*,  -cronyx-helvetica-medium-r-normal-*-14-*-*-*-p-*-koi8-r,          -*-lucida-medium-r-normal-*-14-*-*-*-p-*-iso8859-*,               -*-*-medium-r-normal-*-14-*-*-*-p-*-*-*,               -*-*-medium-r-normal-*-16-*-*-*-p-*-*-*,                         -*-*-*-*-*-*-14-*-*-*-*-*-*-*,                         -*-*-*-*-*-*-16-*-*-*-*-*-*-*,*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: pageNum
    Class: XmTextField
    XmFontListGetNextFont failed.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: Text
    Class: XmTextField
    XmFontListGetNextFont failed.

Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: text
    Class: XmTextField
    XmFontListGetNextFont failed.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-efont-biwidth-medium-i-normal--24-*-*-*-p-*-iso10646-1,-*-times-bold-i-normal--18-*-*-*-*-*-iso10646-1,-*-times-bold-i-normal--18-*-*-*-*-*-iso8859-*,-*-*-medium-i-normal--24-*-*-*-c-*-*-*,-*-*-medium-r-normal--24-*-*-*-c-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: 
    Name: aboutBigFont
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-efont-biwidth-medium-r-normal--14-*-*-*-p-*-iso10646-1,-*-times-medium-r-normal--14-*-*-*-*-*-iso10646-1,-*-times-medium-r-normal--14-*-*-*-*-*-iso8859-*,-*-*-medium-r-normal--14-*-*-*-c-*-*-*,-*-*-medium-r-normal--16-*-*-*-c-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: 
    Name: aboutVersionFont
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string "-efont-biwidth-medium-r-normal--12-*-*-*-p-*-iso10646-1,-*-courier-medium-r-normal--12-*-*-*-*-*-iso10646-1,-*-courier-medium-r-normal--12-*-*-*-*-*-iso8859-1,-*-*-medium-r-normal--12-*-*-*-c-*-*-*,-*-*-medium-r-normal--16-*-*-*-c-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: 
    Name: aboutFixedFont
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: text
    Class: XmTextField
    XmFontListGetNextFont failed.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: printCmd
    Class: XmTextField
    XmFontListGetNextFont failed.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: printFile
    Class: XmTextField
    XmFontListGetNextFont failed.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: printFirstPage
    Class: XmTextField
    XmFontListGetNextFont failed.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: 
    Name: printLastPage
    Class: XmTextField
    XmFontListGetNextFont failed.

Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Warning: 
    Name: _MOTIF_DEFAULT_LOCALE
    Class: XmRendition
    Conversion failed.  Cannot load font.

Warning: No font found.
Comment 1 Andre 2011-03-07 12:57:24 UTC
Things are getting strange. 

Now xpdf-9999 will no more start up as well.
Aditionally, xdvi and gv will no more start up with 
similar errors...

There seems to be a more fundamental flaw somewhere.

I did not change my system too much since the original 
report, none of the upgrades were related. 
I did a reboot, but hey?

Will enquire further, but any pointers are appreciated.
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-03-07 18:53:58 UTC
*** Bug 357693 has been marked as a duplicate of this bug. ***
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2011-03-07 22:06:35 UTC
Judging from its Summary, it looks like bug #357693 has the better analysis. But please paste your `emerge --info' into a comment.
Comment 4 Andre 2011-03-08 09:51:54 UTC
The other issue does not seem to be a dup, 
I used ghostscript-gpl-8.71-r6 in the first place.
I gave an upgrade to the -9 version a try, 
which does not help out at all.

xdvi, gs etc bail out complaining they can't load
a usable ISO8859 font like this:

# gv
Warning: translation table syntax error: Unknown keysym name:  apLineDel
Warning: ... found while parsing '<Key>apLineDel:       GV_Page(page+5)        '
Warning: String to TranslationTable conversion encountered errors
Warning: Cannot convert string "-*-Helvetica-Medium-R-Normal--*-140-*-*-P-*-ISO8859-1" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Unable to load any usable ISO8859 font
Segmentation fault

Anyway, here is my emerge --info. 

# emerge --info
Portage 2.2.0_alpha26 (default/linux/x86/10.0/desktop, gcc-4.4.5, glibc-2.11.3-r0, 2.6.36.2 i686)
=================================================================
System uname: Linux-2.6.36.2-i686-Intel-R-_Core-TM-2_Duo_CPU_E8500_@_3.16GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 07 Mar 2011 09:30:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 3.1.3-r1
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
Repositories: gentoo
Installed sets: 
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/init.d /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /usr/share/X11 /usr/share/X11/xkb /usr/share/X11/xkb/compat /usr/share/X11/xkb/geometry /usr/share/X11/xkb/keycodes /usr/share/X11/xkb/keymap /usr/share/X11/xkb/rules /usr/share/X11/xkb/symbols/macintosh_vndr /usr/share/X11/xkb/symbols/sun_vndr /usr/share/X11/xkb/types"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi bash-completion berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dri dts dvd dvdr emboss encode exif expat fam firefox flac fortran gdu gif gnutls gpm gtk iconv ipv6 java jpeg lcms mad mikmod mmx mng modules mp3 mp4 mpeg mudflap ncurses nptl nptlonly ogg opengl openmp pango pcre pdf perl png policykit ppds pppd python qt3support readline session spell sqlite sse sse2 ssl svg sysfs system-sqlite tcpd threads tiff truetype udev unicode usb vim-syntax vorbis wmf x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LINGUAS="en_US" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Andre 2011-03-23 10:12:00 UTC
I found xterm also suffering from this problem.
When invoking any of the menus via <Ctrl>-<Mouseclick>
xterm dies a sudden death, leaving the message:

Warning: Cannot convert string "-adobe-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-*" to type FontStruct
Warning: Unable to load any usable ISO8859 font
Warning: Unable to load any usable ISO8859 font
Error: Aborting: no font found

As this applies 
to xpdf, xdvi and gs for startup and 
xterm on menu invocation, I think the summary should
be adapted, but alas, it's not open for my editing 
pleasure.

I reproduced the issue on a rather barebone system,
another one of my systems is still operational,
I did not do a world rebuild recently there.
Anyway, this issue does not seem to be ghostscript 
related at all, as xterm does not depend on it 
(and it's not even installed on the barebones system).

Anyway, as this seems to have rather widespread repercussions
I tentatively increase priority.
Comment 6 Andre 2011-03-25 12:54:28 UTC
Following the analysis in http://bugs.gentoo.org/show_bug.cgi?id=359679,
I switched to USE=nls for 
media-fonts/font-adobe-100dpi
media-fonts/font-misc-misc

and things are back to work.
Hooray.

I don't believe that is what -nls is supposed to result in, though :-)

So this could be resolved Worksforme, but I leave this decision
to someone with some understanding of this issue...
Comment 7 William Throwe 2011-05-25 21:49:08 UTC
I believe this was broken in revision 1.24 of xorg-2.eclass (diff http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/eclass/xorg-2.eclass?r1=1.23&r2=1.24 ), which changed USE=-nls from
--disable-iso8859-2 --disable-iso8859-3 ...
to
--disable-all-encodings

The problem is that --disable-all-encodings is also disabling iso8859-1, which is needed for English.
Comment 8 Samuli Suominen (RETIRED) gentoo-dev 2011-07-09 12:34:02 UTC
*** Bug 359679 has been marked as a duplicate of this bug. ***
Comment 9 Larry the Git Cow gentoo-dev 2018-05-26 20:30:37 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0f65e2f961b2771dc5b627e4d2fc15a863849289

commit 0f65e2f961b2771dc5b627e4d2fc15a863849289
Author:     Matt Turner <mattst88@gentoo.org>
AuthorDate: 2018-05-26 19:52:46 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2018-05-26 20:29:46 +0000

    xorg-2.eclass: Always install iso8859-1
    
    Closes: https://bugs.gentoo.org/357331
    Closes: https://bugs.gentoo.org/368335
    Closes: https://bugs.gentoo.org/651046

 eclass/xorg-2.eclass | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)