Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 364941 - net-dialup/rp-pppoe kernel-mode PPPoE support
Summary: net-dialup/rp-pppoe kernel-mode PPPoE support
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords: PullRequest
: 507458 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-26 14:39 UTC by Oleg Gawriloff
Modified: 2021-12-01 21:29 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info output (emerge.info,3.91 KB, text/plain)
2011-04-26 19:47 UTC, Oleg Gawriloff
Details
compile log (build.log.txt,13.78 KB, text/plain)
2011-04-26 19:48 UTC, Oleg Gawriloff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Gawriloff 2011-04-26 14:39:07 UTC
Stable version of rp-pppoe (rp-pppoe-3.8-r2) does not detect kernel-mode PPPoE support mode. Here's relevant string from:  ebuild rp-pppoe-3.8-r2.ebuild clean compile
checking for Linux 2.4.X kernel-mode PPPoE support... no
At the same time unstable rp-pppoe-3.10-r1.ebuild detects it well.

checking for Linux 2.4.X kernel-mode PPPoE support... yes

Update stable version pls. Working patch may be found here: https://bugs.archlinux.org/task/8498

Reproducible: Always
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2011-04-26 17:31:27 UTC
1) Please attach the entire build log to this bug report.
2) Please post your `emerge --info' output too.
Comment 2 Oleg Gawriloff 2011-04-26 19:47:42 UTC
Created attachment 271265 [details]
emerge --info output
Comment 3 Oleg Gawriloff 2011-04-26 19:48:13 UTC
Created attachment 271267 [details]
compile log
Comment 4 Pacho Ramos gentoo-dev 2015-01-07 12:10:59 UTC
*** Bug 507458 has been marked as a duplicate of this bug. ***
Comment 5 Pacho Ramos gentoo-dev 2015-01-07 12:14:30 UTC
+*rp-pppoe-3.11-r3 (07 Jan 2015)
+
+  07 Jan 2015; Pacho Ramos <pacho@gentoo.org> +files/rp-pppoe-3.11-kmode.patch,
+  +rp-pppoe-3.11-r3.ebuild, -rp-pppoe-3.10-r1.ebuild, -rp-pppoe-3.11-r1.ebuild:
+  Don't hardcode ppp detection at some phases and try to autodetect on others,
+  fix kmode detection using ArchLinux approach (#364941), rename X USE flag to
+  'tk' (#349014), drop old
+

Does it work ok for you?
Comment 6 xpue 2016-01-04 22:59:00 UTC
Currently net-dialup/rp-pppoe does not build kernel plugin but only installs symlink to very old plugin which comes bundled with net-dialup/ppp. Can you fix this?
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2020-02-06 11:35:37 UTC
With 3.13:

checking for Linux 2.4.X kernel-mode PPPoE support... yes

I only found this because it triggered automatic loading of the module in question right from the sandbox:

[85331.663632][T32401] PPP generic driver version 2.4.2
[85331.663632][T32401] PPP generic driver version 2.4.2
[85331.871619][T32401] NET: Registered protocol family 24
[85331.871619][T32401] NET: Registered protocol family 24
Comment 8 Maxim Britov 2021-05-06 16:48:03 UTC
From ppp-2.4.9 README:

* The rp-pppoe plugin has been renamed to pppoe, to distinguish it
  from the upstream rp-pppoe code.  Its options have changed names,
  but the old names are kept as aliases.


Since ppp-2.4.9 plugin renamed to pppoe.so
Comment 9 Jaco Kroon 2021-09-20 20:37:01 UTC
I'm working on a PR for https://bugs.gentoo.org/715396.

And found this.  For the other bug, a simple fix is a one-line change to the Makefile to update PLUGIN_PATH=pppoe.so (and then update the ebuild to not install ANYTHING into /etc/ppp/plugins.  Binaries IMHO doesn't belong there anyway.

However, based on this bug there seems to be a need to use the plugin from rp-pppoe.

There are two things here:

Using the ppp plugin means we don't need to actually remerge rp-pppoe when ppp gets remerged (it's small and quick though).  I will need to test, but I believe ppp can be bumped to purely RDEPEND.

If we use the rp-pppoe.so from this package, then we do need to remerge.  ppp remains in RDEPEND as well as DEPEND (as current, should be :=).  Currently it's := purely to correctly update the symbolic link (which is now broken anyway).

This is currently a compile-time option for rp-pppoe, and looking at the ML I doubt we will get support in changing this from upstream side.  I don't mind a patch if there is demand for it, but my suggestion is to add a USE flag that selects between using the pppoe plugin from ppp package, and the rp-pppoe plugin from rp-pppoe package.  For the case where we use the rp-pppoe plugin, I also recommend we install into the correct plugins folder (/usr/libX/pppd/${ppp-PV}/) rather than /etc/ppp/plugins.


If this is not desirable I recommend just using the one from ppp as per current, and just adjusting the build to work out of the box rather than being broken out of the box.

I've already looked into the required, so happy to do a PR, just need guidance on what would be preferred, my recommendations above.
Comment 10 Jaco Kroon 2021-11-30 13:16:32 UTC
Just so all is clear:

3.15-r1 will use the rp-pppoe.so plugin (which ships with rp-pppoe package).

To vary this will require some C code changes, which I'm happy to do, if there is demand.  As you can deduce from time of posting previous comment till now - it's been somewhat busy on this end.
Comment 11 Larry the Git Cow gentoo-dev 2021-12-01 21:29:24 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d413bc84e352fd761aabeadd7fe5a2412fd2b9bf

commit d413bc84e352fd761aabeadd7fe5a2412fd2b9bf
Author:     Jaco Kroon <jaco@uls.co.za>
AuthorDate: 2021-11-30 12:12:46 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-12-01 21:29:15 +0000

    net-dialup/rp-pppoe: revision bump to fix bugs.
    
    Closes: https://bugs.gentoo.org/715396
    Closes: https://bugs.gentoo.org/364941
    Package-Manager: Portage-3.0.28, Repoman-3.0.3
    Signed-off-by: Jaco Kroon <jaco@uls.co.za>
    Closes: https://github.com/gentoo/gentoo/pull/23126
    Signed-off-by: Sam James <sam@gentoo.org>

 net-dialup/rp-pppoe/metadata.xml            |  2 +-
 net-dialup/rp-pppoe/rp-pppoe-3.15-r1.ebuild | 89 +++++++++++++++++++++++++++++
 2 files changed, 90 insertions(+), 1 deletion(-)