Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 363635 - after upgrade to media-libs/libsdl-1.2.14-r6 virtualbox-bin-4.0.4 guest does not recognize sound dev
Summary: after upgrade to media-libs/libsdl-1.2.14-r6 virtualbox-bin-4.0.4 guest does ...
Status: RESOLVED DUPLICATE of bug 310793
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal minor with 3 votes (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-14 20:47 UTC by victor romanchuk
Modified: 2012-01-05 23:28 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
media-libs/libsdl-1.2.14-r6 ebuild without --disable-alsa-shared (libsdl-1.2.14-r6.ebuild,4.47 KB, text/plain)
2011-05-29 07:17 UTC, Eric Westbrook
Details
Patch file form for the one-line change (libsdl-1.2.14-r6.ebuild.alsa-shared.patch,438 bytes, patch)
2011-05-29 07:18 UTC, Eric Westbrook
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description victor romanchuk 2011-04-14 20:47:29 UTC
after an upgrade of media-libs/libsdl to version 1.2.14-r6 virtualbox-bin-4.0.4 guest does not recognize emulated sound device: when booting guest os (win xp in my case) the vbox displays warning: HostAudioNotResponding

sound at host side works fine. things like pulseaudio, esd etc are not used

Reproducible: Always




SDL lib downgrade to previous stable version (1.2.13-r1) solves the issue

I guess the problem is in virtualbox as other apps requiring libSDL function properly (at least sound works as expected)

installation info and environment:

$ emerge --info app-emulation/virtualbox-bin
Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.11.3-r0, 2.6.37-gentoo-r4 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.37-gentoo-r4-x86_64-Intel-R-_Core-TM-2_CPU_T7600_@_2.33GHz-with-gentoo-2.0.2
Timestamp of tree: Thu, 14 Apr 2011 19:00:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 2.4 [disabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/ccache:     2.4-r9
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
sys-kernel/linux-headers: 2.6.36.1
virtual/os-headers:  0
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL AdobeFlash-10.1 skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -g0 -march=core2 -mtune=generic -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -g0 -march=core2 -mtune=generic -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distcc distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles"
LANG="en_US.UTF8"
LC_ALL="en_US.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j9"
PKGDIR="/home/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://gentoo.local/gentoo-portage"
USE="X acpi alsa amd64 berkdb bluetooth bzip2 cairo cli consolekit cracklib crypt cups custom-optimization cxx dri emacs exif fts3 gdbm gif gnome gnome-keyring gpm gstreamer gtk iconv jpeg laptop lcms mmx modules mp3 mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl png policykit pppd python readline session smp spell sse sse2 ssl ssse3 svg sysfs tcpd threads tiff truetype type1 unicode wmf xorg zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-emulation/virtualbox-bin-4.0.4 was built with the following:
USE="additions chm (multilib) python -headless -rdesktop-vrdp -sdk -vboxwebsrv"
Comment 1 Dmitry Bigunyak 2011-04-15 10:37:06 UTC
Has exactly the same problem.
Comment 2 Lionel Cordesses 2011-04-16 19:51:22 UTC
Same problem with stable virtualbox-bin-3.2.12-r1 and libsdl-1.2.14-r6 on amd64.
Lionel
Comment 3 Renato Alves 2011-04-22 17:51:08 UTC
Same problem here. Not using any sound system besides raw alsa. Sound on host works, and virtualbox complains about audio not responding.

In media-libs/libsdl-1.2.14-r6 removing the line that contains --disable-alsa-shared solves the problem.

Can this be added as a flag or other more suitable behavior?
Comment 4 Joseph 2011-04-27 05:13:43 UTC
(In reply to comment #3)
> Same problem here. Not using any sound system besides raw alsa. Sound on host
> works, and virtualbox complains about audio not responding.
> 
> In media-libs/libsdl-1.2.14-r6 removing the line that contains
> --disable-alsa-shared solves the problem.
> 
> Can this be added as a flag or other more suitable behavior?


Which file did you edit?
I have the same problem with virtualbox-3.2.12
Comment 5 Filipe Dios 2011-05-03 14:21:32 UTC
Note to confirm that manually editing the libsdl ebuild fixed the issue for virtualbox. For the other poster, the file that needs to be edited is /usr/portage/media-libs/libsdl/libsdl-1.2.14-r6.ebuild
Comment 6 Joseph 2011-05-03 17:46:27 UTC
Confirmed:
Commenting out the "--disable-alsa-shared"
ebuild /usr/portage/media-libs/libsdl/libsdl-1.2.14-r6.ebuild manifest
emerge libsdl

fixed the problem.
Comment 7 Eric Westbrook 2011-05-29 07:17:24 UTC
Created attachment 274995 [details]
media-libs/libsdl-1.2.14-r6 ebuild without --disable-alsa-shared

This is a trivial change, but perhaps it is not being committed since no one has actually posted to the bug an updated ebuild with the one-line change.  So here it is.
Comment 8 Eric Westbrook 2011-05-29 07:18:37 UTC
Created attachment 274997 [details, diff]
Patch file form for the one-line change

In case a patch file style submission is preferable, here is that too.
Comment 9 Stefan Kiesler 2011-07-21 14:27:53 UTC
It's quite annoying that such simple changes don't seem to make it into the main tree anymore.
Wasn't Gentoo "all about choice" a long time ago?

Also, isn't ALSA default on Gentoo? How can two packages declared stable  (libsdl/virtualbox-bin) break each other in their default configuration?
Comment 10 Denilson Sá 2011-08-12 07:35:06 UTC
This bug seems like a duplicate of bug 310793
Comment 11 Christoph Junghans gentoo-dev 2012-01-05 23:28:04 UTC
There is an ebuild without "--disable-alsa-shared" in moonrise and cj-overlay.

*** This bug has been marked as a duplicate of bug 310793 ***