Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310793 - >=app-emulation/virtualbox-bin-3.1.4 has broken sound with >=media-libs/libsdl-1.2.14-r1
Summary: >=app-emulation/virtualbox-bin-3.1.4 has broken sound with >=media-libs/libsd...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal with 11 votes (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
: 322015 363635 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-22 21:07 UTC by Ivan Ivanich
Modified: 2013-12-13 08:26 UTC (History)
36 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
bug fix for virtualbox and alsa (libsdl-1.2.14-r3.ebuild,4.46 KB, text/plain)
2010-08-22 01:32 UTC, William Blanton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Ivanich 2010-03-22 21:07:11 UTC
The problem is when start virtual machine it crash in a few seconds after start. With disabled sound in virtualbox propereties it works fine. Problem began after upgrade libsdl from 1.2.14 to 1.2.14-r1, downgrade back to libsdl-1.2.14 fixed the crashes. 
I think that the reason for this:
15 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org>                                                          
  +libsdl-1.2.14-r1.ebuild:                                                                                     
  don't use dlopen to open libraries but instead link against them.

Reproducible: Always
Comment 1 Rion 2010-03-23 09:16:04 UTC
i confirm. with 1.2.14 sound works fine, but not with 1.2.14-r1
it doesn't crash for me though just silence with 1.2.14-r1
Comment 2 Bernd Pachur 2010-03-24 13:42:17 UTC
i have a similar problem. with libsdl-1.2.14-r1 virtualbox-bin complains about "HostAudioNotResponding" when using alsa. with oss the problem is no longer present, but access needs to be exclusive. this is not a good option for me.

downgrading to libsdl-1.2.14 fixed it.

should this be considered a bug for virtualbox-bin or is it rather a bug for libsdl?
Comment 3 Optimus 2010-03-29 09:33:23 UTC
Confirm with virtualbox-bin-3.1.6. Downgrade to libsdl-1.2.14 fixed it.
Comment 4 peak eyed 2010-04-03 03:49:10 UTC
Ditto here
Comment 5 Optimus 2010-04-09 05:51:35 UTC
libsdl-1.2.14-r2 + virtualbox-bin-3.1.6 = broken alsa. Anybody look at this bug?
Comment 6 Silvio 2010-04-28 08:56:23 UTC
(In reply to comment #5)
> libsdl-1.2.14-r2 + virtualbox-bin-3.1.6 = broken alsa. Anybody look at this
> bug?
> 

Same problem here. I had to downgrade to libsdl 1.2.14, masking both r1 and r2.
Comment 7 Bernd Butscheidt 2010-05-09 10:01:47 UTC
Here too - no sound in WindowsXP guest.

Commenting out the following lines in the current ebuild like this:

		#--disable-alsa-shared \
		#--disable-esd-shared \
		#--disable-pulseaudio-shared \
		#--disable-arts-shared \
		#--disable-nas-shared \
		#--disable-x11-shared \
		#--disable-osmesa-shared \

and reemerging (emerge -av =libsdl-1.2.14-r2) made sound in Virtualbox 3.1.6 come again here.
Comment 8 Benigno B. Junior 2010-05-12 19:37:12 UTC
(In reply to comment #7)
> Here too - no sound in WindowsXP guest.
> 
> Commenting out the following lines in the current ebuild like this:
> 
>                 #--disable-alsa-shared \
>                 #--disable-esd-shared \
>                 #--disable-pulseaudio-shared \
>                 #--disable-arts-shared \
>                 #--disable-nas-shared \
>                 #--disable-x11-shared \
>                 #--disable-osmesa-shared \
> 
> and reemerging (emerge -av =libsdl-1.2.14-r2) made sound in Virtualbox 3.1.6
> come again here.
> 

For people who uses alsa, the problem is here: --disable-alsa-shared (Enabling alsa won't do --enable-alsa-shared).

It looks like no --disable-*-shared should be set, just like in libsdl-1.2.14.ebuild, because it won't be enabled after --enable-*.
Comment 9 Chris Hall 2010-05-13 18:04:35 UTC
ah finally got my sound working in vbox with these tips :) should implement this someway =)
Comment 10 Lars Wendler (Polynomial-C) gentoo-dev 2010-05-20 20:43:01 UTC
Is this still an issue with >=app-emulation/virtualbox-bin-3.1.8?
Comment 11 Rion 2010-05-21 06:06:54 UTC
app-emulation/virtualbox-bin-3.2.0
media-libs/libsdl-1.2.14-r2

no sound, same error :-(
Comment 12 Lars Wendler (Polynomial-C) gentoo-dev 2010-05-29 18:23:22 UTC
*** Bug 322015 has been marked as a duplicate of this bug. ***
Comment 13 Cyrius 2010-05-29 18:36:33 UTC
Hi, i 've reached the same conclusion.
For the users using alsa, the compiling option --enable-alsa-shared is absolutely needed.
The others no (But for those who use pulse audio, i've down a use also). 
And it solved the problem for me. 
Have a look to the duplicated bugg i created.



Comment 14 Lars Wendler (Polynomial-C) gentoo-dev 2010-05-29 22:19:41 UTC
games herd, what do you think?
Comment 15 Mr. Bones. (RETIRED) gentoo-dev 2010-05-31 19:35:29 UTC
No way are we exposing the dynamic loading again.  That is way too error prone.
Comment 16 Cyrius 2010-06-01 06:56:37 UTC
Mr Bones, could you explain please ? or give a bugg reference for my understanding ?
Cause i'm not aware about this dynamic load that is giving errors. If i am, i will be able to understand what's happening if it occurs on my desk with this modified ebuild.

Thx
Comment 17 Rion 2010-07-20 15:24:09 UTC
is anybody going to fix this bug or should i keep masked >=media-libs/libsdl-1.2.14-r1 ? =)
Comment 18 Silvio 2010-08-08 23:12:44 UTC
(In reply to comment #17)
> is anybody going to fix this bug or should i keep masked
> >=media-libs/libsdl-1.2.14-r1 ? =)
> 

It is still present. 

I did not understand where this bug came out in the sub-release version of libsdl.
Comment 19 William Blanton 2010-08-22 01:32:33 UTC
Created attachment 243983 [details]
bug fix for virtualbox and alsa

Edited ebuild like in connment #8 sound now works with alsa in virtualbox 3.28 and libsdl-1.2.14-r3 just recompile and sound will work tested 8-21 0930 with virtualbox 3.2.8 on kernel 2.6.34
Comment 20 William Blanton 2010-08-22 01:34:23 UTC
ommenting out the following lines in the current ebuild like this:

                #--disable-alsa-shared \
                #--disable-esd-shared \
                #--disable-pulseaudio-shared \
                #--disable-arts-shared \
                #--disable-nas-shared \
                #--disable-x11-shared \
                #--disable-osmesa-shared \

and reemerging (emerge -av =libsdl-1.2.14-r3) made sound in Virtualbox 3.1.6
come again here.

TESTED and working on virtualbox 3.2.8 and libsdl-1.2.14-r3
Comment 21 Lars Wendler (Polynomial-C) gentoo-dev 2010-08-22 02:21:31 UTC
Please see comment #15. Games herd is not interested in this kind of fix.

Unfortunately due to the nature of virtualbox-bin being a binary package this leaves us (vbox maintainers) with no real solution to this problem.

You might have two options here which are both not quite satisfactory:

- maintain your own libsdl ebuild via private overlay.
- convince upstream to let vbox-bin use libsdl without dynamic loading (which I doubt they even can implement reliably).
Comment 22 Rion 2010-08-22 16:12:23 UTC
cool solution. "if we have broken something just because this is cool. fix it yourself or ask somebody to fix" =)
of course i don't know what didn't work with shared sdl, but maintainers should be sure that at least most popular packages work fine before commiting smth or closing bugs IMHO.

at least don't remove last working versions..
Comment 23 Timo A. Hummel 2010-10-25 16:46:28 UTC
I do not accept the solution "CANTFIX". It worked with libsdl-1.2.14 and libsdl-1.2.14-r3 breaks a working solution. 

Comment 24 Lars Wendler (Polynomial-C) gentoo-dev 2010-10-25 18:57:17 UTC
Guys, please don't think that we vbox maintainers do not want to help you. 
The problem here is that libsdl is not maintained by us but by the games herd. And if they dropped dlopen it was for some (most probably good) reason.

Of course I'd love to see someone from games herd explaining to us in detail why they dropped dlopen. If someone from games herd reads this, please be so kind and drop a comment here. And if you really want to do us a favour, maybe you can come up with some idea how to solve this problem. 

Fact is that there is not much we vbox maintainers can do here because the problem is within a binary package (which means no source code that can be patched and no chance to disable libsdl support).
I am going to try poking vbox upstream about the problem but like I said before, I doubt they are willing to come with a solution to this.
Comment 25 Cyrius 2010-10-26 09:08:44 UTC
Then if i good understand you don't why they dropped dlopen. As i'm using "tell me more", i need the sound in vbox windows. If you don't know why deactivating dlopen. please, just activate it via a USE option, add a comment at the end of the ebuild and let the users choose.
Cause today, i must patch it myself each time there is an upgrade on it.
When we'll know why deactivating is necessary then we'll be able to argument it.
Thx
Comment 26 Cyrius 2010-10-26 10:08:54 UTC
Ijust want to mention that i didn't encountered any problem with libsdl using the option --enable-alsa-shared since i'm using it.
Comment 27 Bernd Butscheidt 2010-10-26 11:04:36 UTC
Since I have no problems with my "hacked" libsdl either, therefore enjoying sound in my virtual maschine, I guess adding an appropriate USE-Flag to the libdsl package and making virtualbox-bin depend on it would be the right solution.

Wasn't gentoo about choice? To whom do we have to adress?


Comment 28 Mr. Bones. (RETIRED) gentoo-dev 2010-10-26 16:06:19 UTC
try it with media-libs/libsdl-1.2.14-r4
Comment 29 Gef 2010-10-26 18:08:44 UTC
(In reply to comment #28)
> try it with media-libs/libsdl-1.2.14-r4
> 
Still broken with latest virtualbox-bin.
Comment 30 Bernd Butscheidt 2010-10-26 19:31:01 UTC
same here. --disable-alsa-shared is still used. Commenting it out (=changing the ebuild) makes sound comes again in virtualbox-bin.

Comment 31 Lars Wendler (Polynomial-C) gentoo-dev 2010-10-26 20:13:30 UTC
polynomial-c@shanghai:~ $ diff -u $(portageq envvar PORTDIR)/media-libs/libsdl/libsdl-1.2.14-r{3,4}.ebuild
--- /var/portage/media-libs/libsdl/libsdl-1.2.14-r3.ebuild      2010-10-26 18:06:15.000000000 +0200
+++ /var/portage/media-libs/libsdl/libsdl-1.2.14-r4.ebuild      2010-10-26 18:03:26.000000000 +0200
@@ -1,6 +1,6 @@
 # Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.14-r3.ebuild,v 1.2 2010/10/26 16:03:26 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.14-r4.ebuild,v 1.1 2010/10/26 16:03:26 mr_bones_ Exp $
 
 EAPI=2
 inherit flag-o-matic multilib toolchain-funcs eutils libtool
polynomial-c@shanghai:~ $


mr_bones_ did you really change anything in the ebuild?

Let's reopen this bug till this is finally sorted out.
Comment 32 Lars Wendler (Polynomial-C) gentoo-dev 2010-10-26 20:22:27 UTC
Forget my previous comment about no changes. I was just told that the fix went into both revisions. So it seems like the fix really doesn't help.
Comment 33 SpanKY gentoo-dev 2010-10-27 04:37:51 UTC
the ABI changes due to the X11 configure flag and SDL does a lot of crap with it, so that's what was fixed in -r4.  however, the ABI now matches between 1.2.14 and 1.2.14-r4 and no one else seems to be affected.  alsa audio certainly still works between my systems and random games.  no interest in undoing these fixes that SDL has seen for one binary-only package.

as pointed out, Debian also does this with their sdl install.  so someone will need to investigate why the virtualbox binary doesnt work.  i certainly have no interest in troubleshooting binary only packages, especially when their open source counter part (virtualbox-ose) works fine.
Comment 34 Cyrius 2010-10-27 12:22:04 UTC
Allright, i really don't understand you.
Is it so difficult to add a USE like "AlsaShared" to enable it for the binary package of Virtual Box and let's the users choosing ?
By default it will be -AlsaShared. Then the games herd will be also happy.
Really, i don't understand your point of view on this.
That's a binary package. Some users of your distro wish to use it. They don't want to use the OSE version. They ask you to enable the flag with a USE and will assume any collaterals effects. 
Is gentoo just a copy of Debian ? Isn't more flexible than Debian ?
I wonder why i'm using Gentoo instead of Debian or Ubuntu then.
Again, i'm working with it since 6 months and have experimented no problem with it as i'm not a gamer.
I think a compromise that will satisfy everybody could be found on this.
Comment 35 Cyrius 2010-10-27 12:34:39 UTC
plz, have a look to bugg 322015.
Comment 36 Patrick 2010-12-14 04:50:39 UTC
(In reply to comment #33)
> i certainly have no
> interest in troubleshooting binary only packages, especially when their open
> source counter part (virtualbox-ose) works fine.

-ose works fine, but has limitations when compared to the -bin version (no USB device support, for example). That's why it's not just a 'save me the compiling' package.

Would be great if someone could fix this issue.
Comment 37 Rion 2010-12-14 04:54:47 UTC
-ose doesn't work for me (https://bugs.gentoo.org/show_bug.cgi?id=348302)
so i want fully functional binary package. =)
Comment 38 Lars Wendler (Polynomial-C) gentoo-dev 2011-01-07 01:54:41 UTC
I just added app-emulation/virtualbox-4.0.0 (please note the missing -ose in the package's name) to the tree. When you emerge this package with USE="extensions" set you get everything the -bin package also provides. Maybe that's an option you guys can live with.
Comment 39 Ronny Perinke 2011-01-09 13:27:47 UTC
Any chance to get this problem fixed? Going back to the current stable libdsl 1.2.13 just postpones the problem (especially for no-multilib user like me) until 1.2.14 gets stabilized.
Comment 40 Lars 2011-02-26 18:01:21 UTC
Same here for Virtualbox-4.0.4

All builds 1.2.14-r1 and later are resulting in no working sound for the VirtualBox Guest.

libsdl-1.2.14 is working.
Comment 41 Pablo Yanez Trujillo 2011-05-11 00:41:43 UTC
I also have sound problem with app-emulation/virtualbox-bin-4.0.6. I get the "HostAudioNotResponding" message when starting any virtual machine (every "Host driver" has the same problem). My VirtualBox does not crash though.

I had media-libs/libsdl-1.2.14-r6 but when I masked this version and media-libs/libsdl-1.2.13-r1 got installed, the problem flew away.
Comment 42 Oschtan 2011-05-29 16:13:51 UTC
(In reply to comment #40)
> Same here for Virtualbox-4.0.4
> 
> All builds 1.2.14-r1 and later are resulting in no working sound for the
> VirtualBox Guest.
> 
> libsdl-1.2.14 is working.

Hah. Of course. None "--disable-alsa-shared"
Comment 43 Cyrius 2011-05-30 18:46:02 UTC
More than one year later .... same state.
Comment 44 Tristan Heaven (RETIRED) gentoo-dev 2011-05-30 19:01:17 UTC
Complain to Oracle, or use KVM.
Comment 45 Bernd Butscheidt 2011-05-30 19:28:41 UTC
I still can't understand why we should address to someone else than the package maintainer. 

A simple USE-Flag should solve all the questions asked here. Until then, we have to switch to the non-binary version or do the change in the ebuild manually.
Comment 46 SpanKY gentoo-dev 2011-05-30 22:59:40 UTC
since no one has shown a bug in sdl, nothing for games to do
Comment 47 Bernd Butscheidt 2011-05-31 07:41:16 UTC
I still don't understand the politics here, but I really would:

No one speaks about a bug in libsdl. 

There is a missing feature in libsdl because of a hardcoded configuration. The idea is just to make it configurable to be used with virtualbox-bin.

Or does someone has to oben a new bug(report) here literally strictly adressing to libsdl?
Comment 48 Lars Wendler (Polynomial-C) gentoo-dev 2011-05-31 14:56:18 UTC
Please rad the whole bug. 
I'm afraid such a new bug would be closed as INVALID by the games herd members. Unfortunaltely there's nothing I can do here as co-maintainer of virtualbox-bin to change this narrow-minded opinion.
Comment 49 Cyrius 2011-05-31 19:25:15 UTC
TO GAMES HERD
TO Mr BONES

I saw that in the ebuild :
if use !audio || use !video || use !joystick ; then
		ewarn "Since you've chosen to turn off some of libsdl's functionality,"
		ewarn "don't bother filing libsdl-related bugs until trying to remerge"
		ewarn "libsdl with the audio, video, and joystick flags in USE."
		ewarn "You need to know what you're doing to selectively turn off parts of libsdl."
		epause 30
	fi
	if use custom-cflags ; then
		ewarn "Since you've chosen to use possibly unsafe CFLAGS,"
		ewarn "don't bother filing libsdl-related bugs until trying to remerge"
		ewarn "libsdl without the custom-cflags use flag in USE."
		epause 10
	fi

Would it be possible to add 'alsashared' 'use' with a comment at the begin and the end of the ebuild like those ones when used ?
I think it should be a good compromise. What's your opinion about ?
Comment 50 Bernd Butscheidt 2011-06-02 08:14:54 UTC
O.K.,

just another thing I won't understand ....

So I did it again - the whole story for someone else out there, if there is still life out there ....

1. Open /usr/portage/media-libs/libsdl/libsdl-1.2.14-r6.ebuild as root with a text editor,

2. adding a # before --disable-alsa-shared ====>
new code:

...

--enable-file \
-enable-cpuinfo \
#--disable-alsa-shared \
--disable-esd-shared \
--disable-pulseaudio-shared \

....

and finally:

cd /usr/portage/media-libs/libsdl
ebuild libsdl-1.2.14-r6.ebuild manifest
emerge -1av libsdl


So now my PC sings constantly like a drunken sailor, the FBI and the games herd is chasing me around the whole world and my shrink begs me to contact him (off course - I won't) but the good news:

!!!! My windowsXP guest in virtualbox-bin has sound again. !!!

Well, updating KDE is much more work than doing this change to the ebuild of libsdl so maybe one day I will finally live in peace with this matter.
Comment 51 Teh Tuxusah 2011-06-23 13:46:36 UTC
Same here.

VirtualBox 4.0.8, no sound in guest when alsa selected.

Removing --disable-alsa-shared from ebuild fixes the problem.

Is that really so difficult for package maintainer to do the same ?
Comment 52 Ryan Harris 2011-06-24 12:23:26 UTC
(In reply to comment #51)
> Same here.
> VirtualBox 4.0.8, no sound in guest when alsa selected.
> Removing --disable-alsa-shared from ebuild fixes the problem.
> Is that really so difficult for package maintainer to do the same ?

No offense intended but it's kind of pointless for people to keep commenting about this. We all know removing --disable-alsa-shared fixes this. Why the maintainer(s) can't add a simple use flag to fix it is beyond me. They have other use flags with warnings in this package but for some reason are just being bull-headed about this one. So unfortunately we're all stuck maintaining are own ebuilds in local overlays in order to use virtualbox-bin.
Comment 53 Bernd Butscheidt 2011-06-24 14:13:12 UTC
O.K.,

we lost hope that the maintaniners of libsdl will do something.

But at least in some way we can maintain our local work arounds together here. So I still enjoy to hear from you at least from time to time, that I am 

a) on the right track
b) that "it" (=the work around compiling libsdl with changed ebuild again) still works
Comment 54 Christoph Junghans gentoo-dev 2011-06-24 15:30:02 UTC
(In reply to comment #53)
> But at least in some way we can maintain our local work arounds together here.
> So I still enjoy to hear from you at least from time to time, that I am 
> a) on the right track
> b) that "it" (=the work around compiling libsdl with changed ebuild again)
> still works
I had the same problem back in the times, when I used virtualbox-bin. So I can add a version of libsdl to cj-overlay until we find a real solution, if you post a patch to ebuild here.
Comment 55 Ryan Harris 2011-06-24 15:36:35 UTC
(In reply to comment #54)
> (In reply to comment #53)
> > But at least in some way we can maintain our local work arounds together here.
> > So I still enjoy to hear from you at least from time to time, that I am 
> > a) on the right track
> > b) that "it" (=the work around compiling libsdl with changed ebuild again)
> > still works
> I had the same problem back in the times, when I used virtualbox-bin. So I can
> add a version of libsdl to cj-overlay until we find a real solution, if you
> post a patch to ebuild here.

There's a "-r7" version in funtoo with a alsa-shared and pulseaudio-shared USE flag i committed to funtoo a little while back when i was helping them. You could just copy that one.
https://github.com/funtoo/portage/blob/funtoo.org/media-libs/libsdl/libsdl-1.2.14-r7.ebuild
Comment 56 Christoph Junghans gentoo-dev 2011-06-24 18:03:04 UTC
(In reply to comment #55)
> There's a "-r7" version in funtoo with a alsa-shared and pulseaudio-shared USE
> flag i committed to funtoo a little while back when i was helping them. You
> could just copy that one.
> https://github.com/funtoo/portage/blob/funtoo.org/media-libs/libsdl/libsdl-1.2.14-r7.ebuild
Added -r7 to cj-overlay including alsa-shared and pulseaudio-shared use flag.
Comment 57 Motosauro 2011-10-21 09:24:46 UTC
(In reply to comment #50)
> O.K.,
> 
> just another thing I won't understand ....
> 
> So I did it again - the whole story for someone else out there, if there is
> still life out there ....
> cut ...
Yes, we're out here 
Solved the problem through your indications , thx
Comment 58 László Szalma 2011-11-04 11:12:08 UTC
I read this "thread" and I'm sad. All the users want to use virtualbox-bin must read pages of google matches to find this bug, and manually edit an ebuild or create overlay to fix a problem, that affecting thousands of users, just because libsdl maintainer is not agree on implementing a USE flag on this? Unbelievable.

This is not about the bug anymore, it's about gentoo package maintenance politics. I think it's not a package maintainer's job to decide what's useful, right, or free to do for users.
Comment 59 László Szalma 2011-11-04 11:30:25 UTC
(In reply to comment #58)
> I read this "thread" and I'm sad. All the users want to use virtualbox-bin must
> read pages of google matches to find this bug, and manually edit an ebuild or
> create overlay to fix a problem, that affecting thousands of users, just
> because libsdl maintainer is not agree on implementing a USE flag on this?
> Unbelievable.
> 
> This is not about the bug anymore, it's about gentoo package maintenance
> politics. I think it's not a package maintainer's job to decide what's useful,
> right, or free to do for users.

BTW the commenting out, and enabling alsa-shared in the ebuild (and rebuilding) didn't solved the problem for me.
Comment 60 Christoph Junghans gentoo-dev 2011-11-04 21:12:35 UTC
(In reply to comment #58)
> I read this "thread" and I'm sad. All the users want to use virtualbox-bin must
> read pages of google matches to find this bug, and manually edit an ebuild or
> create overlay to fix a problem, that affecting thousands of users, just
> because libsdl maintainer is not agree on implementing a USE flag on this?
> Unbelievable.
> 
> This is not about the bug anymore, it's about gentoo package maintenance
> politics. I think it's not a package maintainer's job to decide what's useful,
> right, or free to do for users.

This problem here has two sides "the virtualbox-bin (only bin) sound issue" vs. "the exposing the dynamic loading, which is too error prone". And it is not obvious what is the best for the majority of users.

That is why I put libsdl in my overlay to make it less painful for those who are on the virtualbox-bin side like me. So go and run these simple 5 commands:
$ emerge layman
$ layman -a cj-overlay
$ echo media-libs/libsdl >> /etc/portage/package.accept_keywords
$ echo "media-libs/libsdl alsa-shared pulseaudio-shared" >> /etc/portage/package.use
$ emerge media-libs/libsdl
Comment 61 Denilson Sá 2011-11-04 22:13:40 UTC
(In reply to comment #60)
> $ echo media-libs/libsdl >> /etc/portage/package.accept_keywords

I'd suggest against unmasking all libsdl libraries, as it might cause some trouble in future, whenever a new version gets released and the user forgets that line in package.keywords (it has already happened to me, but with another package).

It's better to run this:

$ echo '=media-libs/libsdl-1.2.14-r7' >> /etc/portage/package.accept_keywords
Comment 62 Christoph Junghans gentoo-dev 2011-11-04 22:35:22 UTC
(In reply to comment #61)
> (In reply to comment #60)
> > $ echo media-libs/libsdl >> /etc/portage/package.accept_keywords
> 
> I'd suggest against unmasking all libsdl libraries, as it might cause some
> trouble in future, whenever a new version gets released and the user forgets
> that line in package.keywords (it has already happened to me, but with another
> package).
> 
> It's better to run this:
> 
> $ echo '=media-libs/libsdl-1.2.14-r7' >> /etc/portage/package.accept_keywords

Well, yes and no. If the tree gets an revision bump, which happened in the past already, it will also be called r7 and I will have to create r8 and then the above line is not so useful anymore. However, the commands were more meant as an example anyway, gentoo user should know what is in their package.* files.
Comment 63 Matteo 'The Peach' Pescarin 2011-11-13 15:01:00 UTC
I just tried the build suggested by #(In reply to comment #55)
> There's a "-r7" version in funtoo with a alsa-shared and pulseaudio-shared USE
> flag i committed to funtoo a little while back when i was helping them. You
> could just copy that one.
> https://github.com/funtoo/portage/blob/funtoo.org/media-libs/libsdl/libsdl-1.2.14-r7.ebuild

Just tried this solution and definitely works, I don't know the implications of the two flags, but indeed having a static compile flags in the ebuild doesn't seem to be a good solution either. 
I wonder if libsdl maintainer can ever fix this, it seems to be going on since like 3 years or so.
Comment 64 Mariusz Kozakowski 2011-12-28 13:13:58 UTC
Fix is available on overlay moonrise - modified ebuild:
https://github.com/Barthalion/moonrise/blob/master/media-libs/libsdl/libsdl-1.2.14-r6.ebuild
Comment 65 Christoph Junghans gentoo-dev 2012-01-05 23:28:04 UTC
*** Bug 363635 has been marked as a duplicate of this bug. ***
Comment 66 Stefan Kiesler 2012-01-06 08:28:29 UTC
Well, it's nice to have a fix in some overlay, but I really think this should be fixed in the main tree.

The "Debian does it" excuse is ridiculous: This is Gentoo, we used to have "choice". There's so many ebuilds with custom USE flags, full of warnings and "be sure to know what you're doing", heck there are even undocumented USE flags like "I_KNOW_WHAT_I_AM_DOING" and "MYSQL_INIT_I_KNOW_WHAT_I_AM_DOING".

Start listening to your users and get this "herd A vs. herd B" politics crap out of the distribution!

Else we could just drop the whole "USE flag" feature altogether and rename this distribution to Gentoobian, if we're exposed to the maintainers' caprice anyway...

Note: This is not meant to piss any maintainers off. We have too few of them anyway, and I really appreciate their hard work. This is also not meant to piss the games herd off, who are also doing a great job. But the back and forth between two herds on this bug, each claiming not to be responsible doesn't help anyone, least of all the users.
Comment 67 Flavio 2012-03-06 09:35:32 UTC
Hello, 

the problem still persists here:

Host: Gentoo Linux 10.0 kernel 3.2.6 x86_64
VBox version: app-emulation/virtualbox-bin-4.1.8
Guest Additions 4.1.8r75467
Guest OS: Windows 7 64bit Ultimate

media-libs/libsdl-1.2.15 (X alsa audio fbcon joystick opengl video xv)


No errors, no audio. All seems to be OK in the guest, as the audio would reproduce as usual.

Further info at 
https://forums.virtualbox.org/viewtopic.php?p=219019#p219019
Comment 68 Nick 2012-03-07 08:56:38 UTC
I happened across this thread almost a year ago and masked libsdl > 1.2.14 so I wouldn't unknowingly lose sound in VirtualBox.  I also expected that by the time libsdl was required to be upgraded beyond 1.2.14, that this issue would have been fixed by the Gentoo maintainers. I agree w/ many other posters that it's disappointing to have to choose between losing sound and maintaining my own ebuild in an overlay.

One thing I noticed after having read all comments in this issue to date was a couple comments about no bug having been opened in SDL.  One comment (#46) from SpanKY:  https://bugs.gentoo.org/show_bug.cgi?id=310793#c46 :
"since no one has shown a bug in sdl, nothing for games to do"

So I'm wondering, has anyone actually opened a bug in SDL asking for support on this issue?
Comment 69 Nathan Caldwell 2012-03-07 22:18:51 UTC
(In reply to comment #68)
> I happened across this thread almost a year ago and masked libsdl > 1.2.14
> so I wouldn't unknowingly lose sound in VirtualBox.  I also expected that by
> the time libsdl was required to be upgraded beyond 1.2.14, that this issue
> would have been fixed by the Gentoo maintainers. I agree w/ many other
> posters that it's disappointing to have to choose between losing sound and
> maintaining my own ebuild in an overlay.
> 
> One thing I noticed after having read all comments in this issue to date was
> a couple comments about no bug having been opened in SDL.  One comment (#46)
> from SpanKY:  https://bugs.gentoo.org/show_bug.cgi?id=310793#c46 :
> "since no one has shown a bug in sdl, nothing for games to do"
> 
> So I'm wondering, has anyone actually opened a bug in SDL asking for support
> on this issue?

Because it isn't an upstream issue, it's a configuration issue. It works if you pass --enable-alsa-shared to configure, but games herd refuses to even add this as an option.
Comment 70 Christoph Junghans gentoo-dev 2012-03-07 22:39:32 UTC
Just use the ebuild without "--disable-alsa-shared" from moonrise or cj-overlay and wait for virtualbox-bin-(N+1).
Comment 71 Nick 2012-03-07 23:16:33 UTC
(In reply to comment #69)
> Because it isn't an upstream issue, it's a configuration issue. It works if
> you pass --enable-alsa-shared to configure, but games herd refuses to even
> add this as an option.

Maybe I used the wrong terminology.  I'm wondering if anyone opened a bug for the libsdl Gentoo package maintainers asking for support.  From this thread, I take it that's the "games herd"?

In other words, are we all assuming they won't help based on the comments that have been left in this bug?  Or has someone actually asked for help beyond this bug?
Comment 72 Nick 2012-03-07 23:24:29 UTC
(In reply to comment #70)
> Just use the ebuild without "--disable-alsa-shared" from moonrise or
> cj-overlay and wait for virtualbox-bin-(N+1).
Yes, I know how to work around the issue (semi-)manually.  I'd prefer a more official solution (and from this thread, it seems I'm not the only one).

Are you saying that the next virtualbox-bin version will solve this problem?  If so, can you substantiate that?
Comment 73 Christoph Junghans gentoo-dev 2012-03-07 23:43:53 UTC
(In reply to comment #72)
> (In reply to comment #70)
> Are you saying that the next virtualbox-bin version will solve this problem?
> If so, can you substantiate that?
No, but there is always a next version in which things may have changed ;-)
Comment 74 Lars Wendler (Polynomial-C) gentoo-dev 2012-03-08 11:36:45 UTC
(In reply to comment #70)
> Just use the ebuild without "--disable-alsa-shared" from moonrise or
> cj-overlay and wait for virtualbox-bin-(N+1).

I doubt virtualbox people will change anything in handling of libsdl in their future bin-packages.

Anyway I wonder why people seem to prefer virtualbox-bin over virtualbox source package. The only group of people we keep virtualbox-bin for are users of the "amd64 no-multilib" profile.
All people not using such a system can get the same kind of functionality with app-emulation/virtualbox and the extensions USE flag being enabled.
Comment 75 Flavio 2012-03-08 11:47:23 UTC
(In reply to comment #74)
> Anyway I wonder why people seem to prefer virtualbox-bin over virtualbox
> source package. The only group of people we keep virtualbox-bin for are
> users of the "amd64 no-multilib" profile.
OK, and then please tell me why is virtualbox-bin not masked for those people not using "amd64 no-multilib" profile?
Comment 76 Denilson Sá 2012-03-08 14:09:41 UTC
(In reply to comment #74)
> 
> Anyway I wonder why people seem to prefer virtualbox-bin over virtualbox
> source package.

virtualbox-bin used to have support for things that were not available in the open-source edition, like USB. Is it not true anymore? Does the open-source edition have the same features as the binary one?
Comment 77 Lars Wendler (Polynomial-C) gentoo-dev 2012-03-08 14:32:55 UTC
(In reply to comment #76)
> (In reply to comment #74)
> > 
> > Anyway I wonder why people seem to prefer virtualbox-bin over virtualbox
> > source package.
> 
> virtualbox-bin used to have support for things that were not available in
> the open-source edition, like USB. Is it not true anymore? Does the
> open-source edition have the same features as the binary one?

Since app-emulation/virtualbox-4.0.0 it supports USB-1 without any extensions package. With help of the app-emualtion/virtualbox-extpack-oracle package it has USB-2, VRDP and PXE-boot support like the -bin package. So no need to stick with virtualbox-bin for any of these features.
Comment 78 Flavio 2012-03-08 18:25:49 UTC
(In reply to comment #76)
> virtualbox-bin used to have support for things that were not available in
> the open-source edition, like USB. Is it not true anymore? Does the
> open-source edition have the same features as the binary one?
And this is why I use virtualbox-bin since many years! Actually I was using app-emulation/virtualbox before switching to virtualbox-bin just for that reason.
Comment 79 Nick 2012-03-10 11:48:32 UTC
(In reply to comment #77)
> (In reply to comment #76)
> > (In reply to comment #74)
> > > 
> > > Anyway I wonder why people seem to prefer virtualbox-bin over virtualbox
> > > source package.
> > 
> > virtualbox-bin used to have support for things that were not available in
> > the open-source edition, like USB. Is it not true anymore? Does the
> > open-source edition have the same features as the binary one?
> 
> Since app-emulation/virtualbox-4.0.0 it supports USB-1 without any
> extensions package. With help of the app-emualtion/virtualbox-extpack-oracle
> package it has USB-2, VRDP and PXE-boot support like the -bin package. So no
> need to stick with virtualbox-bin for any of these features.

The primary reason I was using the bin package (was for USB support).

So does app-emulation/virtualbox-bin have any advantages (from a feature set perspective) over app-emulation/virtualbox-4 + app-emualtion/virtualbox-extpack-oracle?
Comment 80 Francesco Lamonica 2012-03-27 08:52:02 UTC
Please update the ebuild in overlay. 1.2.15 went stable in main tree and does not get updated from overlay anymore...
I really hate this behaviour...
Comment 81 Francesco Lamonica 2012-03-27 09:00:20 UTC
@Lars (comment 77)
The devel of vbox say they cannot however guarantee that OSE will be working with the binary only extpack. Is that guaranteed by vbox-ose gentoo mantainers?

thansk (i'd rather switch to ose and get out of this mess with sdl! :) )
Comment 82 Christoph Junghans gentoo-dev 2012-03-27 14:53:51 UTC
(In reply to comment #80)
> Please update the ebuild in overlay. 1.2.15 went stable in main tree and
> does not get updated from overlay anymore...
> I really hate this behaviour...

lidsdl-1.2.15-r1 is in cj-overlay since Jan 2012.
Comment 83 Francesco Lamonica 2012-03-27 15:13:54 UTC
Christoph, sorry , should have explained better,
i was using moorise since i don't have mercurial installed.
However i fixed by copying the ebuild to -r999
Comment 84 Mariusz Kozakowski 2012-03-27 15:21:49 UTC
(In reply to comment #81)
> @Lars (comment 77)
> The devel of vbox say they cannot however guarantee that OSE will be working
> with the binary only extpack. Is that guaranteed by vbox-ose gentoo
> mantainers?
> 
> thansk (i'd rather switch to ose and get out of this mess with sdl! :) )

https://github.com/Barthalion/moonrise/blob/master/media-libs/libsdl/libsdl-1.2.15.ebuild
This is there for some time. Maybe something blocked you git pull?
If you use stable version of gentoo add ~amd64/~x86 to package.keywords. I specially made it for unstable.
Comment 85 Lars Wendler (Polynomial-C) gentoo-dev 2012-03-27 20:51:14 UTC
(In reply to comment #81)
> @Lars (comment 77)
> The devel of vbox say they cannot however guarantee that OSE will be working
> with the binary only extpack. Is that guaranteed by vbox-ose gentoo
> mantainers?
> 
> thansk (i'd rather switch to ose and get out of this mess with sdl! :) )

From my experience with vbox-ose on several machines the USB2 module seems to work properly. I tested VRDP only once but it seemed to work reliable as well.
On the other hand I haven't tested the PXE-boot images as I don't know how to test them properly...
Comment 86 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-11-11 20:44:24 UTC
This is the oldest most commented bug is the proxy maintainers queue, as well as a bug started in 2010; please evaluate the following options, so we can proceed:

1. Is this issue still present nowadays?

2. Which person or group can do something about this?

   -> If it it a maintainer, assign to him; drop proxy maintainers.
   -> If it is games, assign to them (drop p-m); but close as RESOLVED CANTFIX.
   -> If it is upstream, please close this bug as RESOLVED UPSTREAM.

3. Can a solution for this bug be provided in the Portage tree?

   -> If so, please indicate as such and let us know status updates.
   -> If not, please close the bug as RESOLVED WONTFIX; but given that
      you should probably have a good reason, do RESOLVED CANTFIX.
      Though as the latter isn't really possible, as it is fixed in overlay.

4. There are complaints in this thread that it is hard to find the existence
   of fixes in the overlay, can this be documented elsewhere like pkg_postinst?

5. If documentation is a valid enough resolution, then RESOLVED FIXED might work?

If no action happens, I suggest we re-evaluate this bug by the end of the year.

Thank you very much in advance.
Comment 87 Fat-Zer 2013-12-07 11:31:38 UTC
(In reply to Tom Wijsman (TomWij) from comment #86)
> This is the oldest most commented bug is the proxy maintainers queue, as
> well as a bug started in 2010; please evaluate the following options, so we
> can proceed:
> 
> 1. Is this issue still present nowadays?

Seems it's resolved... works fine for me with media-libs/libsdl-1.2.15-r4 and  app-emulation/virtualbox-bin-4.1.26
But it would be better if somebody else rechecked that.
Comment 88 Wadlax 2013-12-10 06:59:23 UTC
Sound works for me


media-libs/libsdl-1.2.15-r4
app-emulation/virtualbox-bin-4.2.20

kde-base/kde-meta-4.11.4
media-sound/amarok-2.8.0


WinXP in virtualbox , AudioDriver ALSA , AudioController ICH AC97


While playing music in amarok , started vbox , sound from winxp combines with sound from amarok.
Comment 89 Sergey Popov gentoo-dev Security 2013-12-13 08:26:47 UTC
Ok, marking this as OBSOLETE, feel free to reopen