Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 363061 - gnome-base/gnome-menus-3.0.0 should install or link applications.menu
Summary: gnome-base/gnome-menus-3.0.0 should install or link applications.menu
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome3
  Show dependency tree
 
Reported: 2011-04-11 09:47 UTC by Canek Peláez Valdés
Modified: 2012-02-12 14:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Canek Peláez Valdés 2011-04-11 09:47:36 UTC
gnome-shell does not show any applications nor favorites in the dock, and after less than a minute crash after the following log appears:

Window manager warning: Log level 6: applications.menu not found.

The crash can be precipitated by pressing the windows (meta) key, and selecting "Applications".

The problem is solved by linking /etc/xdg/menus/gnome-applications.menu to /etc/xdg/menus/applications.menu, at least in my case.

Reproducible: Always

Steps to Reproduce:
1. Make sure /etc/xdg/menus/applications.menu does not exist (gnome-base/gnome-menus-3.0.0 does not install it)
2. Start gnome-shell
3. Press the windows key and select "Applications"
Actual Results:  
Gnome-shell crashes and the message "oh no! something has gone wrong. a problem has occurred and the system can't recover. please log out and try again." appears.

Expected Results:  
Beautiful gnome-shell should not crash. And it would be nice to have applications.

The problem seems to be that gnome-shell expects the menus to be in /etc/xdg/menus/applications.menu, but gnome-base/gnome-menus-3.0.0 installs this file as /etc/xdg/menus/gnome-applications.menu. With a link from the latter to the former, gnome-shell works for me.
Comment 1 Gilles Dartiguelongue gentoo-dev 2011-04-11 09:55:31 UTC
no, just like previous releases didn't do it since 2.26 (iirc). Please read the einfo message from older gnome-menus.
Comment 2 Canek Peláez Valdés 2011-04-11 10:13:26 UTC
I do not understand. Should this bug be filled upstream? Or against another ebuild? Upgrading from GNOME 2 to GNOME 3, with a working GNOME 2 desktop, gnome-shell crashes. It is because of the /etc/xdg/menus/applications.menu file being missing. You are telling me I should see the einfo message from *previous* versions of gnome-menus?

This should work when installing GNOME 3 for the first time. Currently, it does not. Maybe my summary, title or ebuild attribution is incorrect, but *there is a bug*.

Please direct me where or to what I should fill it.
Comment 3 Gilles Dartiguelongue gentoo-dev 2011-04-11 10:27:01 UTC
The bug is not that applications.menu is missing since it is named gnome-applications.menu on purpose and this is the case since gnome 2.26. I have not witnessed this problem while upgrading and so do other people that are testing it in gnome overlay. Are you using gdm to start gnome ?
Comment 4 Canek Peláez Valdés 2011-04-11 10:38:58 UTC
(In reply to comment #3)
> The bug is not that applications.menu is missing since it is named
> gnome-applications.menu on purpose and this is the case since gnome 2.26.

And it worked for me up until GNOME 2.32.

> I have not witnessed this problem while upgrading and so do other people
> that are testing it in gnome overlay. Are you using gdm to start gnome ?

No, it doesn't work for me: it hangs without doing anything after I enter my password. I haven't reported it because I still don't investigate it further. I'm starting GNOME with startx, having "exec gnome-session" in my ~/.xinitrc.

Now I see that I need to set the XDG_MENU_PREFIX environment variable so it works. You're right: the bug is invalid.

Sorry for the noise, and thanks.
Comment 5 Gilles Dartiguelongue gentoo-dev 2011-04-11 10:52:21 UTC
(In reply to comment #4)
[...]
> Now I see that I need to set the XDG_MENU_PREFIX environment variable so it
> works. You're right: the bug is invalid.

beware that you might need other things, like consolekit, ...
In general you should make sure to run everything that is under /etc/X11/xinitrc.d/

> Sorry for the noise, and thanks.

No problem.