Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 356985 - x11-drivers/xf86-video-mach64-6.8.2 - aticonsole.c:719:48: error: 'struct _ScrnInfoRec' has no member named 'pixmapPrivate'
Summary: x11-drivers/xf86-video-mach64-6.8.2 - aticonsole.c:719:48: error: 'struct _Sc...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 354643
  Show dependency tree
 
Reported: 2011-03-01 15:11 UTC by Fernando (likewhoa)
Modified: 2011-05-01 14:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (xf86-video-mach64-6.8.2.build.log,28.14 KB, text/plain)
2011-03-01 15:11 UTC, Fernando (likewhoa)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fernando (likewhoa) 2011-03-01 15:11:30 UTC
worked before until this recent update.

Reproducible: Always

Steps to Reproduce:
1. emerge =x11-drivers/xf86-video-mach64-6.8.2





Portage 2.2.0_alpha25 (default/linux/x86/10.0, gcc-4.5.2, glibc-2.12.2-r0, 2.6.34-hardened-r1 i686)
=================================================================
System uname: Linux-2.6.34-hardened-r1-i686-with-gentoo-2.0.1
Timestamp of tree: Tue, 01 Mar 2011 10:00:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 3.1.4 [disabled]
app-shells/bash:     4.1_p10
dev-lang/python:     2.7.1-r1
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
Repositories: gentoo x11
Installed sets: 
ACCEPT_KEYWORDS="x86 ~amd64 ~x86"
ACCEPT_LICENSE="* -@EULA @BINARY-REDISTRIBUTABLE"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0 /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="bn brx cy dgo eo eu fa gl gu_IN id kk kn_IN kok ks ku mai mn mni my sa_IN sat sd ta_IN tn uz en ca"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X accessibility acl alsa atm avahi berkdb bindist branding bzip2 cairo cli cracklib crypt cups cxx dbus dri eds fbcondecor fortran gdbm gif gnome gnome-keyring gpm iconv ipv6 jpeg kde libnotify livecd loop-aes mmx mng modules mudflap nautilus ncurses networkmanager nls nouveau nptl nptlonly opengl openmp pam pcre perl png policykit portaudio pppd python qt3support qt4 readline semantic-desktop session socks5 sse sse2 ssl sysfs tcpd tiff truetype unicode usb vino x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics virtualbox" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="bn brx cy dgo eo eu fa gl gu_IN id kk kn_IN kok ks ku mai mn mni my sa_IN sat sd ta_IN tn uz en ca" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="qxl virtualbox nouveau glint intel mach64 mga neomagic nv r128 radeon savage tdfx trident vesa via vmware cirrus ast chips i128 i740 imstt s3virge tseng v4l vermilion" XFCE_PLUGINS="menu" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Fernando (likewhoa) 2011-03-01 15:11:42 UTC
Created attachment 264283 [details]
build.log
Comment 2 Rémi Cardona gentoo-dev 2011-03-02 07:51:44 UTC
Yeah, looks like the driver hasn't been updated for new xorg-server APIs/ABIs.

Upstream poking or p.masking will be necessary.
Comment 3 Fernando (likewhoa) 2011-03-02 20:34:16 UTC
just to add x11-base/xorg-server-1.10.0 on it comes from the x11 overlay, sorry i didn't mention this at first.
Comment 4 Chí-Thanh Christopher Nguyễn gentoo-dev 2011-05-01 14:05:23 UTC
Shoud be fixed in 6.9.0, please reopen if the problem persists.