Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 355025 - media-libs/netpbm-10.51.00-r1: compilation fails with media-libs/libpng-1.5.x
Summary: media-libs/netpbm-10.51.00-r1: compilation fails with media-libs/libpng-1.5.x
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Graphics Project
URL: http://sourceforge.net/mailarchive/fo...
Whiteboard:
Keywords:
: 364591 383715 (view as bug list)
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-02-15 14:32 UTC by Lars Wendler (Polynomial-C)
Modified: 2011-09-20 04:10 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
partial-netpbm-libpng-1.5.patch (partial-netpbm-libpng-1.5.patch,19.29 KB, patch)
2011-02-22 22:24 UTC, SpanKY
Details | Diff
NetPBM 10.51.00 patch for libpng-1.5 (netpbm-10.51.00-libpng-1.5.diff,16.45 KB, patch)
2011-07-18 15:06 UTC, Stuart Longland (RETIRED)
Details | Diff
NetPBM 10.51.00 patch for libpng-1.5, with *ALL* the fixes this time (netpbm-10.51.00-libpng-1.5.diff,41.92 KB, patch)
2011-07-19 01:36 UTC, Stuart Longland (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2011-02-15 14:32:01 UTC
i686-pc-linux-gnu-gcc -Wall -c -I.  -I"/var/tmp/portage/media-libs/netpbm-10.51.00-r1/work/netpbm-10.51.00"/importinc -I"/var/tmp/portage/media-libs/netpbm-10.51.00-r1/work/netpbm-10.51.00"/importinc/netpbm -I/var/tmp/portage/media-libs/netpbm-10.51.00-r1/work/netpbm-10.51.00/converter/other -I/usr/include/libpng15 -I/usr/include/libxml2 -DNDEBUG \
     -march=barcelona -O2 -pipe   -o pnmtopng.o pnmtopng.c
pnmtopng.c: In function ‘parseCommandLine’:
pnmtopng.c:468:48: error: ‘Z_DEFLATED’ undeclared (first use in this function)
pnmtopng.c:468:48: note: each undeclared identifier is reported only once for each function it appears in
pnmtopng.c:476:50: error: ‘Z_HUFFMAN_ONLY’ undeclared (first use in this function)
pnmtopng.c:478:50: error: ‘Z_FILTERED’ undeclared (first use in this function)
pnmtopng.c: In function ‘makePngLine’:
pnmtopng.c:2195:21: error: dereferencing pointer to incomplete type
pnmtopng.c:2196:21: error: dereferencing pointer to incomplete type
pnmtopng.c:2200:28: error: dereferencing pointer to incomplete type
pnmtopng.c:2207:28: error: dereferencing pointer to incomplete type
pnmtopng.c:2208:28: error: dereferencing pointer to incomplete type
pnmtopng.c:2221:21: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘doHistChunk’:
pnmtopng.c:2327:25: error: dereferencing pointer to incomplete type
pnmtopng.c:2328:25: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘setColorType’:
pnmtopng.c:2346:24: error: dereferencing pointer to incomplete type
pnmtopng.c:2348:24: error: dereferencing pointer to incomplete type
pnmtopng.c:2350:24: error: dereferencing pointer to incomplete type
pnmtopng.c:2352:33: error: dereferencing pointer to incomplete type
pnmtopng.c:2353:24: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘doGamaChunk’:
pnmtopng.c:2364:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2365:17: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘doChrmChunk’:
pnmtopng.c:2377:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2379:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2380:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2381:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2382:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2383:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2384:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2385:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2386:17: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘doPhysChunk’:
pnmtopng.c:2398:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2400:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2401:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2402:17: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘doTimeChunk’:
pnmtopng.c:2415:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2417:42: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘doTrnsChunk’:
pnmtopng.c:2454:28: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘doBkgdChunk’:
pnmtopng.c:2494:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2495:21: error: dereferencing pointer to incomplete type
pnmtopng.c:2496:21: error: dereferencing pointer to incomplete type
pnmtopng.c:2498:21: error: dereferencing pointer to incomplete type
pnmtopng.c:2503:36: error: dereferencing pointer to incomplete type
pnmtopng.c:2504:36: error: dereferencing pointer to incomplete type
pnmtopng.c:2505:36: error: dereferencing pointer to incomplete type
pnmtopng.c:2506:36: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘doSbitChunk’:
pnmtopng.c:2520:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2539:17: error: dereferencing pointer to incomplete type
pnmtopng.c:2544:25: error: dereferencing pointer to incomplete type
pnmtopng.c:2545:25: error: dereferencing pointer to incomplete type
pnmtopng.c:2546:25: error: dereferencing pointer to incomplete type
pnmtopng.c:2547:25: error: dereferencing pointer to incomplete type
pnmtopng.c:2549:25: error: dereferencing pointer to incomplete type
pnmtopng.c:2554:21: error: dereferencing pointer to incomplete type
pnmtopng.c:2555:21: error: dereferencing pointer to incomplete type
pnmtopng.c:2558:57: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘convertpnm’:
pnmtopng.c:2758:18: error: dereferencing pointer to incomplete type
pnmtopng.c:2759:18: error: dereferencing pointer to incomplete type
pnmtopng.c:2760:18: error: dereferencing pointer to incomplete type
pnmtopng.c:2764:18: error: dereferencing pointer to incomplete type
pnmtopng.c:2772:22: error: dereferencing pointer to incomplete type
pnmtopng.c:2779:20: error: dereferencing pointer to incomplete type
pnmtopng.c:2780:20: error: dereferencing pointer to incomplete type
pnmtopng.c:2781:20: error: dereferencing pointer to incomplete type
pnmtopng.c:2815:22: error: dereferencing pointer to incomplete type
pnmtopng.c:2819:22: error: dereferencing pointer to incomplete type
pnmtopng.c: In function ‘displayVersion’:
pnmtopng.c:2865:13: error: ‘ZLIB_VERSION’ undeclared (first use in this function)
pnmtopng.c:2865:27: error: ‘zlib_version’ undeclared (first use in this function)
make[2]: *** [pnmtopng.o] Error 1


Although there seems to be a mail in upstream's mailing list at sourceforge about the libpng-1.5 problem I wasn't able to extract the mail's content. So I don't know if there's already a working fix available.
Comment 1 Jory A. Pratt gentoo-dev 2011-02-16 04:55:21 UTC
(In reply to comment #0)
> 
> Although there seems to be a mail in upstream's mailing list at sourceforge
> about the libpng-1.5 problem I wasn't able to extract the mail's content. So I
> don't know if there's already a working fix available.
> 
I was able to extract the archieve and it is useless, it is based on 10.35.x Gentoo and a few others are the only ones using advanced releases as far as I can tell.
Comment 2 SpanKY gentoo-dev 2011-02-22 22:24:32 UTC
Created attachment 263569 [details, diff]
partial-netpbm-libpng-1.5.patch

needs a little more love and updating in pnmtopng ...
Comment 3 Samuli Suominen gentoo-dev 2011-04-23 18:56:20 UTC
*** Bug 364591 has been marked as a duplicate of this bug. ***
Comment 4 Samuli Suominen gentoo-dev 2011-04-23 19:32:16 UTC
(In reply to comment #2)
> Created attachment 263569 [details, diff]
> partial-netpbm-libpng-1.5.patch
> 
> needs a little more love and updating in pnmtopng ...

Could you roll a new release tarball perhaps?  The code looks quite different at:

http://netpbm.svn.sourceforge.net/viewvc/netpbm/

"advanced/ 	 1469 	 2 weeks 	 giraffedata 	 Release 10.54.03"
Comment 5 SpanKY gentoo-dev 2011-04-29 22:17:47 UTC
it wouldnt help as he hasnt updated all the utils yet:
pnmtopng.c:2195:21: error: dereferencing pointer to incomplete type
Comment 6 renato gallo 2011-05-06 13:13:29 UTC
x86_64-pc-linux-gnu-gcc -Wall -c -I.  -I"/var/tmp/portage/media-libs/netpbm-10.51.00-r1/work/netpbm-10.51.00"/importinc -I"/var/tmp/portage/media-libs/netpbm-10.51.00-r1/work/netpbm-10.51.00"/importinc/netpbm -I/var/tmp/portage/media-libs/netpbm-10.51.00-r1/work/netpbm-10.51.00/converter/other -I/usr/include/libpng15 -I/usr/include/libxml2 -DNDEBUG \
             -O2 -pipe -march=native   -o pnmtopng.o pnmtopng.c
pnmtopng.c: In function 'parseCommandLine':
pnmtopng.c:468: error: 'Z_DEFLATED' undeclared (first use in this function)
pnmtopng.c:468: error: (Each undeclared identifier is reported only once
pnmtopng.c:468: error: for each function it appears in.)
pnmtopng.c:476: error: 'Z_HUFFMAN_ONLY' undeclared (first use in this function)
pnmtopng.c:478: error: 'Z_FILTERED' undeclared (first use in this function)
pnmtopng.c: In function 'makePngLine':
pnmtopng.c:2195: error: dereferencing pointer to incomplete type
pnmtopng.c:2196: error: dereferencing pointer to incomplete type
pnmtopng.c:2200: error: dereferencing pointer to incomplete type
pnmtopng.c:2207: error: dereferencing pointer to incomplete type
pnmtopng.c:2208: error: dereferencing pointer to incomplete type
pnmtopng.c:2221: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'doHistChunk':
pnmtopng.c:2327: error: dereferencing pointer to incomplete type
pnmtopng.c:2328: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'setColorType':
pnmtopng.c:2346: error: dereferencing pointer to incomplete type
pnmtopng.c:2348: error: dereferencing pointer to incomplete type
pnmtopng.c:2350: error: dereferencing pointer to incomplete type
pnmtopng.c:2352: error: dereferencing pointer to incomplete type
pnmtopng.c:2353: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'doGamaChunk':
pnmtopng.c:2364: error: dereferencing pointer to incomplete type
pnmtopng.c:2365: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'doChrmChunk':
pnmtopng.c:2377: error: dereferencing pointer to incomplete type
pnmtopng.c:2379: error: dereferencing pointer to incomplete type
pnmtopng.c:2380: error: dereferencing pointer to incomplete type
pnmtopng.c:2381: error: dereferencing pointer to incomplete type
pnmtopng.c:2382: error: dereferencing pointer to incomplete type
pnmtopng.c:2383: error: dereferencing pointer to incomplete type
pnmtopng.c:2384: error: dereferencing pointer to incomplete type
pnmtopng.c:2385: error: dereferencing pointer to incomplete type
pnmtopng.c:2386: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'doPhysChunk':
pnmtopng.c:2398: error: dereferencing pointer to incomplete type
pnmtopng.c:2400: error: dereferencing pointer to incomplete type
pnmtopng.c:2401: error: dereferencing pointer to incomplete type
pnmtopng.c:2402: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'doTimeChunk':
pnmtopng.c:2415: error: dereferencing pointer to incomplete type
pnmtopng.c:2417: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'doTrnsChunk':
pnmtopng.c:2454: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'doBkgdChunk':
pnmtopng.c:2494: error: dereferencing pointer to incomplete type
pnmtopng.c:2495: error: dereferencing pointer to incomplete type
pnmtopng.c:2496: error: dereferencing pointer to incomplete type
pnmtopng.c:2498: error: dereferencing pointer to incomplete type
pnmtopng.c:2503: error: dereferencing pointer to incomplete type
pnmtopng.c:2504: error: dereferencing pointer to incomplete type
pnmtopng.c:2505: error: dereferencing pointer to incomplete type
pnmtopng.c:2506: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'doSbitChunk':
pnmtopng.c:2520: error: dereferencing pointer to incomplete type
pnmtopng.c:2539: error: dereferencing pointer to incomplete type
pnmtopng.c:2544: error: dereferencing pointer to incomplete type
pnmtopng.c:2545: error: dereferencing pointer to incomplete type
pnmtopng.c:2546: error: dereferencing pointer to incomplete type
pnmtopng.c:2547: error: dereferencing pointer to incomplete type
pnmtopng.c:2549: error: dereferencing pointer to incomplete type
pnmtopng.c:2554: error: dereferencing pointer to incomplete type
pnmtopng.c:2555: error: dereferencing pointer to incomplete type
pnmtopng.c:2558: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'convertpnm':
pnmtopng.c:2758: error: dereferencing pointer to incomplete type
pnmtopng.c:2759: error: dereferencing pointer to incomplete type
pnmtopng.c:2760: error: dereferencing pointer to incomplete type
pnmtopng.c:2764: error: dereferencing pointer to incomplete type
pnmtopng.c:2772: error: dereferencing pointer to incomplete type
pnmtopng.c:2779: error: dereferencing pointer to incomplete type
pnmtopng.c:2780: error: dereferencing pointer to incomplete type
pnmtopng.c:2781: error: dereferencing pointer to incomplete type
pnmtopng.c:2815: error: dereferencing pointer to incomplete type
pnmtopng.c:2819: error: dereferencing pointer to incomplete type
pnmtopng.c: In function 'displayVersion':
pnmtopng.c:2865: error: 'ZLIB_VERSION' undeclared (first use in this function)
pnmtopng.c:2865: error: 'zlib_version' undeclared (first use in this function)
make[2]: *** [pnmtopng.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-libs/netpbm-10.51.00-r1/work/netpbm-10.51.00/converter/other'
make[1]: *** [other/all] Error 2
make[1]: Leaving directory `/var/tmp/portage/media-libs/netpbm-10.51.00-r1/work/netpbm-10.51.00/converter'
make: *** [converter/all] Error 2
emake failed
Comment 7 renato gallo 2011-05-29 09:57:00 UTC
news ?
Comment 8 Stuart Longland (RETIRED) gentoo-dev 2011-07-18 15:06:14 UTC
Created attachment 280307 [details, diff]
NetPBM 10.51.00 patch for libpng-1.5

I tried attachment 236569 [details] and found it wouldn't apply to netpbm-10.51.00.

Fed up with not having netpbm, I've just spent the last few hours hacking to get it to compile.  I haven't tried this patch as yet, but it at least builds.

At 1:05AM I really have other things on my mind, I shall see if it actually works or goes kaboom later in the morning. :-)

Feedback is appreciated however.
Comment 9 Stuart Longland (RETIRED) gentoo-dev 2011-07-18 23:58:07 UTC
A quick test suggests this patch works.  Sent upstream.  If people could give it a try, that will greatly assist the fixing of this bug.
Comment 10 Stuart Longland (RETIRED) gentoo-dev 2011-07-19 01:36:07 UTC
Created attachment 280335 [details, diff]
NetPBM 10.51.00 patch for libpng-1.5, with *ALL* the fixes this time

Serves me right for doing this at 1:00AM… this patch has the missed files, which I've had to re-patch (and hopefully done a better job of in the process).
Comment 11 renato gallo 2011-07-20 01:06:30 UTC
i can confirm that it compiles now :D
Comment 12 SpanKY gentoo-dev 2011-08-15 03:39:36 UTC
ive uploaded your patch for 10.51.00.  once upstream does a new release, we can drop it then.  but who knows when that happens.
Comment 13 Mike Gilbert gentoo-dev 2011-09-20 04:10:08 UTC
*** Bug 383715 has been marked as a duplicate of this bug. ***