Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 354965 - media-video/mplayer fails to compile against media-libs/libpng-1.5.x
Summary: media-video/mplayer fails to compile against media-libs/libpng-1.5.x
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL: http://lists.mplayerhq.hu/pipermail/m...
Whiteboard:
Keywords:
: 385737 (view as bug list)
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-02-15 07:48 UTC by Lars Wendler (Polynomial-C)
Modified: 2011-10-05 15:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mplayer-libpng15.diff (mplayer-libpng15.diff,1.43 KB, patch)
2011-02-15 07:50 UTC, Lars Wendler (Polynomial-C)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2011-02-15 07:48:54 UTC
i686-pc-linux-gnu-gcc -MD -MP -march=barcelona -O2 -pipe -fomit-frame-pointer -W
undef  -Wstrict-prototypes -Wmissing-prototypes -Wdisabled-optimization -Wno-poi
nter-sign -Wdeclaration-after-statement -std=gnu99  -march=barcelona -O2 -pipe -
fomit-frame-pointer -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I. -Iffmpeg  -D_
REENTRANT  -I/usr/include/freetype2   -I/usr/include/dirac   -I/usr/include/schr
oedinger-1.0 -I/usr/include/orc-0.4   -c -o libmpcodecs/vd_mpng.o libmpcodecs/vd
_mpng.c
libmpcodecs/vd_mpng.c: In function 'pngReadFN':
libmpcodecs/vd_mpng.c:77:19: error: dereferencing pointer to incomplete type
libmpcodecs/vd_mpng.c: In function 'decode':
libmpcodecs/vd_mpng.c:114:14: error: dereferencing pointer to incomplete type
libmpcodecs/vd_mpng.c:131:87: error: dereferencing pointer to incomplete type
make: *** [libmpcodecs/vd_mpng.o] Error 1
emake failed
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2011-02-15 07:50:21 UTC
Created attachment 262565 [details, diff]
mplayer-libpng15.diff

Fix from upstream mailing list. I tested this patch against mplayer-1.0_rc4_p20101219
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2011-03-11 12:22:02 UTC
This is fixed with >=media-video/mplayer--1.0_rc4_p20110302
Comment 3 Samuli Suominen gentoo-dev 2011-10-05 15:17:49 UTC
*** Bug 385737 has been marked as a duplicate of this bug. ***