Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 385737 - mplayer 1.0_rc4_p20101114 doesn't build with libpng 1.5
Summary: mplayer 1.0_rc4_p20101114 doesn't build with libpng 1.5
Status: RESOLVED DUPLICATE of bug 354965
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-05 14:25 UTC by Cliff Yapp
Modified: 2011-10-05 15:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cliff Yapp 2011-10-05 14:25:30 UTC
libmpcodecs/vd_mpng.c: In function 'pngReadFN':
libmpcodecs/vd_mpng.c:77: error: dereferencing pointer to incomplete type
libmpcodecs/vd_mpng.c: In function 'decode':
libmpcodecs/vd_mpng.c:114: error: dereferencing pointer to incomplete type
libmpcodecs/vd_mpng.c:131: error: dereferencing pointer to incomplete type
make: *** [libmpcodecs/vd_mpng.o] Error 1
make: *** Waiting for unfinished jobs....
emake failed
 * ERROR: media-video/mplayer-1.0_rc4_p20101114 failed (compile phase)

This looks to be a libpng 1.5 specific problem.  There is a patch here:

https://gist.github.com/1105164

applying this fixes the problem.
Comment 1 Ian Stakenvicius gentoo-dev 2011-10-05 14:53:48 UTC
Confirmed; that file is using direct access to the png_struct and png_info_struct pointers, which is no longer permitted in libpng-1.5
Comment 2 Samuli Suominen gentoo-dev 2011-10-05 15:17:49 UTC

*** This bug has been marked as a duplicate of bug 354965 ***