Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 353816 - sys-libs/glibc-2.13: static linking some apps breaks with missing memcpy_chk_ssse3 symbols
Summary: sys-libs/glibc-2.13: static linking some apps breaks with missing memcpy_chk_...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 353861 353917 354167 354185 354347 354539 354795 354811 354815 354873 354883 354909 355021 356115 357461 (view as bug list)
Depends on:
Blocks: glibc-2.13
  Show dependency tree
 
Reported: 2011-02-06 04:38 UTC by Harris Landgarten
Modified: 2011-03-05 23:39 UTC (History)
38 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (1296966775-install-sys-apps_busybox-1.18.1:0::gentoo.out,44.64 KB, text/plain)
2011-02-06 04:39 UTC, Harris Landgarten
Details
memcpy_chk fix for x86_64 and i686 (0001-memcpy-ssse3-enable-chk-symbols-in-static-builds.patch,3.42 KB, patch)
2011-02-14 03:32 UTC, SpanKY
Details | Diff
glibc-2.13-memset-chk-static-pic.patch (glibc-2.13-memset-chk-static-pic.patch,840 bytes, patch)
2011-02-22 06:32 UTC, SpanKY
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Harris Landgarten 2011-02-06 04:38:25 UTC
networking/lib.a(nslookup.o): In function `print_host':
nslookup.c:(.text.print_host+0x3e): warning: Using 'getaddrinfo' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
libbb/lib.a(inet_common.o): In function `INET_rresolve':
inet_common.c:(.text.INET_rresolve+0xec): warning: Using 'gethostbyaddr' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
util-linux/lib.a(mount.o): In function `nfsmount':
mount.c:(.text.nfsmount+0xc2): warning: Using 'gethostbyname' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
libbb/lib.a(inet_common.o): In function `INET_rresolve':
inet_common.c:(.text.INET_rresolve+0x168): warning: Using 'getnetbyaddr' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
libbb/lib.a(inet_common.o): In function `INET_resolve':
inet_common.c:(.text.INET_resolve+0xdd): warning: Using 'getnetbyname' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
libbb/lib.a(xconnect.o): In function `bb_lookup_port':
xconnect.c:(.text.bb_lookup_port+0x3c): warning: Using 'getservbyname' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
networking/lib.a(netstat.o): In function `ip_port_str':
netstat.c:(.text.ip_port_str+0x6c): warning: Using 'getservbyport' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking


Reproducible: Always
Comment 1 Harris Landgarten 2011-02-06 04:39:36 UTC
Created attachment 261634 [details]
build log
Comment 2 SpanKY gentoo-dev 2011-02-06 10:00:39 UTC
the snippets you posted are simple warnings.  the actual error:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../lib64/libc.a(memmove_chk.o): In function `__memmove_chk':
memmove_chk.c:(.text+0x1b4): undefined reference to `__memmove_chk_ssse3_back'
memmove_chk.c:(.text+0x1b9): undefined reference to `__memmove_chk_ssse3'
Comment 3 tman 2011-02-06 11:46:47 UTC
i can confirm that busybox does now emerge successfull after upgrade to sys-libs/glibc-2.13.

Comment 4 tman 2011-02-06 11:50:19 UTC
i can confirm that busybox does NOT emerge successfull after upgrade to
sys-libs/glibc-2.13.
Comment 5 Samuli Suominen gentoo-dev 2011-02-06 15:16:27 UTC
*** Bug 353861 has been marked as a duplicate of this bug. ***
Comment 6 SpanKY gentoo-dev 2011-02-06 18:28:55 UTC
ive sent this patch upstream to fix the issue:
http://sources.gentoo.org/gentoo/src/patchsets/glibc/2.13/0060_all_glibc-2.13-static-memmove-ssse3.patch?rev=1.1
Comment 7 David Carlos Manuelda 2011-02-08 05:31:58 UTC
Will be a rev bump with that patch before upstream releases it?
Comment 8 Rion 2011-02-08 05:59:01 UTC
patch works for me.
at least I successfully compiled kernel only when recompiled glibc with this patch.
Comment 9 Lars Wendler (Polynomial-C) gentoo-dev 2011-02-08 22:56:27 UTC
*** Bug 354167 has been marked as a duplicate of this bug. ***
Comment 10 Billy DeVincentis 2011-02-09 01:54:44 UTC
This revision of glibc should not have been released into the ~arch, it should have been added to the tree masked. I have successfully downgraded glibc without issue (only because I have buildpkg in my features that allows me a safety net). I think if you have the ability to downgrade and are not afraid of the slight possibility of hosing your system, downgrading is the best option until some of the bugs are resolved.
Comment 11 Lars Wendler (Polynomial-C) gentoo-dev 2011-02-10 13:51:53 UTC
*** Bug 354347 has been marked as a duplicate of this bug. ***
Comment 12 Jeroen Roovers gentoo-dev 2011-02-10 17:55:29 UTC
*** Bug 354185 has been marked as a duplicate of this bug. ***
Comment 13 DarkNRG 2011-02-11 17:38:13 UTC
I have a very similar error (which isn't fixed by the above patch):

networking/lib.a(arping.o): In function `arping_main':
arping.c:(.text.arping_main+0x447): undefined reference to `__memset_chk' 
archival/lib.a(tar.o): In function `writeLongname':
tar.c:(.text.writeLongname+0x11e): undefined reference to `__memset_chk' 
archival/lib.a(tar.o): In function `writeFileToTarball':
tar.c:(.text.writeFileToTarball+0x21d): undefined reference to `__memset_chk' 
collect2: ld returned 1 exit status
make: *** [busybox_unstripped] Error 1
Comment 14 SpanKY gentoo-dev 2011-02-11 18:57:42 UTC
if you arent showing the exact same error, you need to post full info.  file a new bug with all the relevant details.
Comment 15 Donald R. Gray Jr 2011-02-12 01:31:24 UTC
(In reply to comment #14)
> if you arent showing the exact same error, you need to post full info.  file a
> new bug with all the relevant details.
> 

On hardened nomultilib ~amd64 the 0060 patch changes:



the snippets you posted are simple warnings.  the actual error:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../lib64/libc.a(memmove_chk.o):
In function `__memmove_chk':
memmove_chk.c:(.text+0x1b4): undefined reference to `__memmove_chk_ssse3_back'
memmove_chk.c:(.text+0x1b9): undefined reference to `__memmove_chk_ssse3'

To:

networking/lib.a(arping.o): In function `arping_main':
arping.c:(.text.arping_main+0x447): undefined reference to `__memset_chk' 
archival/lib.a(tar.o): In function `writeLongname':
tar.c:(.text.writeLongname+0x11e): undefined reference to `__memset_chk' 
archival/lib.a(tar.o): In function `writeFileToTarball':
tar.c:(.text.writeFileToTarball+0x21d): undefined reference to `__memset_chk' 
collect2: ld returned 1 exit status
make: *** [busybox_unstripped] Error 1

"Failed: -Wl,--start-group -lcrypt -lm -Wl,--end-group"

Am I wrong in assuming that ${LDFLAGS} is not being honored here? Or is this normal for busybox?
Comment 16 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2011-02-12 15:16:11 UTC
(In reply to comment #15)
> "Failed: -Wl,--start-group -lcrypt -lm -Wl,--end-group"
> 
> Am I wrong in assuming that ${LDFLAGS} is not being honored here? Or is this
> normal for busybox?

Busybox currently filters out any LDFLAGS which begin with -Wl. Thus, if the flags you escape via -Wl are necessary for successful compilation, then your build will break. See bug 346953 which includes a patch which fixes this.
Comment 17 David Carlos Manuelda 2011-02-12 15:20:25 UTC
Can anyone post a modified ebuild including the patch from #6 in order to test it further?
Comment 18 Samuli Suominen gentoo-dev 2011-02-13 09:34:18 UTC
*** Bug 354539 has been marked as a duplicate of this bug. ***
Comment 19 Jon Gerdes 2011-02-13 13:44:42 UTC
(In reply to comment #17)
> Can anyone post a modified ebuild including the patch from #6 in order to test
> it further?
> 

Make sure you really want to do this!

Make a quickpkg of your existing glibc
Make sure you have a bootcd available so that you can put glibc back again if necessary

Edit the patch and change the a/ and b/ in the diff lines to glibc-2.13/, then put the patch into a file called something like: /etc/portage/patches/sys-libs/glibc-2.13/patch-from-bug-353816.patch 

You may have to create those directories if you have not used this nifty Portage feature before, remember permissions (portage:portage eg).  You do not have to amend the existing ebuild or mess with overlays

Now when you emerge glibc you should see a userland patching section near the start after it applies the existing Portage patches to the source which mentions applying your new patch.

After doing this I was then able to compile Busybox and hence my kernel again.
Comment 20 Charles Pence 2011-02-13 17:48:48 UTC
I wanted to confirm that the patch from #6, installed as mentioned in #19, does in fact fix this bug -- when will we see this pushed into the tree?
Comment 21 SpanKY gentoo-dev 2011-02-13 19:10:58 UTC
that is a lot of unnecessary effort.  simply use /etc/portage/patches/ and then you dont have to edit the ebuild at all.
Comment 22 Lars Wendler (Polynomial-C) gentoo-dev 2011-02-13 22:46:34 UTC
*** Bug 354795 has been marked as a duplicate of this bug. ***
Comment 23 SpanKY gentoo-dev 2011-02-14 03:32:43 UTC
Created attachment 262405 [details, diff]
memcpy_chk fix for x86_64 and i686

seems the i686 multiarch code has a similar bug.  this patch should fix both (and thus should also fix Comment #13 now).
Comment 24 Lars Wendler (Polynomial-C) gentoo-dev 2011-02-14 05:58:07 UTC
*** Bug 354811 has been marked as a duplicate of this bug. ***
Comment 25 Lars Wendler (Polynomial-C) gentoo-dev 2011-02-14 08:22:38 UTC
*** Bug 354815 has been marked as a duplicate of this bug. ***
Comment 26 Guillaume Castagnino 2011-02-14 10:13:27 UTC
(In reply to comment #23)
> Created an attachment (id=262405) [details]
> memcpy_chk fix for x86_64 and i686
> 
> seems the i686 multiarch code has a similar bug.  this patch should fix both
> (and thus should also fix Comment #13 now).
> 

This one works great, build of busybox-1.18.3 went fine with it
Thanks !
Comment 27 Lars Wendler (Polynomial-C) gentoo-dev 2011-02-14 14:40:45 UTC
*** Bug 354873 has been marked as a duplicate of this bug. ***
Comment 28 Oschtan 2011-02-14 15:08:29 UTC
Thanks for the patch. Everything compiles and runs.
Comment 29 SpanKY gentoo-dev 2011-02-14 17:04:39 UTC
*** Bug 354883 has been marked as a duplicate of this bug. ***
Comment 30 SpanKY gentoo-dev 2011-02-14 18:03:35 UTC
fixed with glibc-2.13-r1
Comment 31 Samuli Suominen gentoo-dev 2011-02-14 20:25:37 UTC
*** Bug 354909 has been marked as a duplicate of this bug. ***
Comment 32 Donald R. Gray Jr 2011-02-14 20:53:15 UTC
(In reply to comment #30)
> fixed with glibc-2.13-r1
> 

Still broken on ~amd64 hardened+nomultilib.

networking/lib.a(arping.o): In function `arping_main':
arping.c:(.text.arping_main+0x3be): undefined reference to `__memset_chk' 
archival/lib.a(tar.o): In function `writeLongname':
tar.c:(.text.writeLongname+0xd6): undefined reference to `__memset_chk' 
archival/lib.a(tar.o): In function `writeFileToTarball':
tar.c:(.text.writeFileToTarball+0x21e): undefined reference to `__memset_chk' 
collect2: ld returned 1 exit status
make: *** [busybox_unstripped] Error 1
Comment 33 Charles Pence 2011-02-14 20:56:07 UTC
What package produces this error?  I can compile busybox +static just fine on a current ~amd64 +nomultilib box.
Comment 34 Guillaume Castagnino 2011-02-14 20:59:42 UTC
(In reply to comment #32)
> (In reply to comment #30)
> > fixed with glibc-2.13-r1
> > 
> 
> Still broken on ~amd64 hardened+nomultilib.
> 
> networking/lib.a(arping.o): In function `arping_main':
> arping.c:(.text.arping_main+0x3be): undefined reference to `__memset_chk' 
> archival/lib.a(tar.o): In function `writeLongname':
> tar.c:(.text.writeLongname+0xd6): undefined reference to `__memset_chk' 
> archival/lib.a(tar.o): In function `writeFileToTarball':
> tar.c:(.text.writeFileToTarball+0x21e): undefined reference to `__memset_chk' 
> collect2: ld returned 1 exit status
> make: *** [busybox_unstripped] Error 1
> 


Sadly I confirm this.
The patch fixes amd64+multilib, but amd64+hardened+nomultilib is still broken.
Same error here on my gateway.

Anyway, the patch is a great step over for most of desktop systems :)


Juste for reference, the emerge --info of the system that remains broken :
Portage 2.2.0_alpha23 (hardened/linux/amd64/no-multilib, gcc-4.5.2, glibc-2.13-r1, 2.6.37-hardened-r1 x86_64)
=================================================================
System uname: Linux-2.6.37-hardened-r1-x86_64-Intel-R-_Atom-TM-_CPU_D510_@_1.66GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 14 Feb 2011 20:00:02 +0000
app-shells/bash:     4.1_p9
dev-lang/python:     2.7.1, 3.1.3
dev-util/cmake:      2.8.3-r1
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.68
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
Repositories: gentoo gcpan xwing local_portage
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -mtune=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/openvpn/easy-rsa /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -mtune=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="assume-digests binpkg-logs buildsyspkg collision-protect distlocks fixlafiles fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS=""
GENTOO_MIRRORS="http://dagobah.xwing.info/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/     http://mirror.ovh.net/gentoo-distfiles/ http://gentoo.tiscali.nl/"
LANG="fr_FR.utf8"
LC_ALL="fr_FR.utf8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,--sort-common"
LINGUAS="fr"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/gcpan-portage /usr/local/portage/portage /usr/local/portage/local-portage"
SYNC="rsync://dagobah.xwing.info/gentoo-portage"
USE="acl acpi amd64 bash-completion bashlogger bzip2 cli cracklib crypt cups cxx dri enscript fontconfig hardened iconv idled idn iproute2 ipv6 ithreads jpeg justify mmx mudflap ncurses nls nptl nptlonly openmp pam pcre perl pic png pppd readline sasl session sse sse2 ssl sysfs syslog tcpd threads tiff truetype udev unicode urandom usb vim-pager vim-syntax xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi gzip limit_req limit_zone map memcached proxy realip referer rewrite upstream_ip_hash userid stub_status" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 35 Charles Pence 2011-02-14 21:02:19 UTC
Sorry, didn't see the +hardened there.  Disregard that, &c.
Comment 36 SpanKY gentoo-dev 2011-02-14 23:47:57 UTC
glibc-2.13-r1 has __memcpy_chk symbols in libc.a on my hardened system.  which isnt to say there arent suspicious PIC checks in the relevant .S files, just that it doesnt seem to be a problem for me.
Comment 37 Harris Landgarten 2011-02-15 12:30:19 UTC
All packages now compile for me with the new glibc and I haven't seen any runtime errors.
Comment 38 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2011-02-15 13:35:49 UTC
*** Bug 355021 has been marked as a duplicate of this bug. ***
Comment 39 Srdjan Rakic 2011-02-15 15:08:47 UTC
I can confirm that everything is fine with new glibc.
Comment 40 ruckc 2011-02-15 15:22:12 UTC
With glibc-2.13-r1 i am still getting undefined reference to '__memset_chk' in busybox-1.18.3.

amd64+hardened+multilib
Comment 41 Jeroen Roovers gentoo-dev 2011-02-15 22:44:34 UTC
*** Bug 353917 has been marked as a duplicate of this bug. ***
Comment 42 Oleg Valenko 2011-02-16 09:33:21 UTC
Confirm,glibc-2.13-r1 is no problem.
amd64,multilib
Comment 43 Donald R. Gray Jr 2011-02-16 21:49:55 UTC
Compiling initrd with genekrnel fails on e2fsprogs, undefined reference to `__memset_chk'
Comment 44 DarkNRG 2011-02-17 10:17:13 UTC
(In reply to comment #43)
> Compiling initrd with genekrnel fails on e2fsprogs, undefined reference to
> `__memset_chk'
> 

May be the same as bug #355021.
Comment 45 Donald R. Gray Jr 2011-02-17 12:42:38 UTC
(In reply to comment #44)
> (In reply to comment #43)
> > Compiling initrd with genekrnel fails on e2fsprogs, undefined reference to
> > `__memset_chk'
> > 
> 
> May be the same as bug #355021.
> 

Seems to be yet another duplicate of this bug. The common ground I have seen is trying to compile something statically. If I edit the busybox ebuild and change CONFIG_STATIC=y to CONFIG_PIE=y busybox compiles fine, but I am suspicious that the rescue shell would be useless.
Comment 46 Sergei Trofimovich gentoo-dev 2011-02-21 09:42:47 UTC
Should I treat #355021 as the same bug?
It is not fixed yet for hardened toolchain.
Comment 47 SpanKY gentoo-dev 2011-02-21 16:11:57 UTC
*** Bug 355021 has been marked as a duplicate of this bug. ***
Comment 48 SpanKY gentoo-dev 2011-02-22 06:32:03 UTC
Created attachment 263413 [details, diff]
glibc-2.13-memset-chk-static-pic.patch

this should fix missing __memset_chk on hardened systems
Comment 49 Guillaume Castagnino 2011-02-22 08:49:34 UTC
(In reply to comment #48)
> Created an attachment (id=263413) [details]
> glibc-2.13-memset-chk-static-pic.patch
> 
> this should fix missing __memset_chk on hardened systems
> 


Great, confirmed the fix. With this patch on top of glibc-2.13-r1 busybox now build fine on hardened

Thanks !
Comment 50 DarkNRG 2011-02-22 10:22:34 UTC
(In reply to comment #49)
> (In reply to comment #48)
> > Created an attachment (id=263413) [details] [details]
> > glibc-2.13-memset-chk-static-pic.patch
> > 
> > this should fix missing __memset_chk on hardened systems
> > 
> 
> 
> Great, confirmed the fix. With this patch on top of glibc-2.13-r1 busybox now
> build fine on hardened
> 
> Thanks !
> 

Worked for me, too :)

Solved the same problem in both busybox and cryptsetup.
Comment 51 SpanKY gentoo-dev 2011-02-22 18:54:55 UTC
ive queued the patch in the glibc 2.13 patchset
Comment 52 SpanKY gentoo-dev 2011-02-23 04:14:13 UTC
*** Bug 356115 has been marked as a duplicate of this bug. ***
Comment 53 Billy DeVincentis 2011-02-26 15:21:36 UTC
Can someone confirm that the version now in portage works with busybox and genkernel?
Comment 54 Matt 2011-02-26 15:29:14 UTC
(In reply to comment #53)
> Can someone confirm that the version now in portage works with busybox and
> genkernel?
> 

not really - if there hasn't been a silent version-bump / update

in the meantime:


Fri Feb 18 18:31:50 2011 >>> sys-libs/glibc-2.13-r1
       merge time: 9 minutes and 44 seconds.


I attempted to update busybox from

sys-apps/busybox-1.18.1

to 

sys-apps/busybox-1.18.2

and still got that error
Comment 55 Matt 2011-02-26 16:07:19 UTC
(In reply to comment #54)
> (In reply to comment #53)
> > Can someone confirm that the version now in portage works with busybox and
> > genkernel?
> > 
> 
> not really - if there hasn't been a silent version-bump / update
> 
> in the meantime:
> 
> 
> Fri Feb 18 18:31:50 2011 >>> sys-libs/glibc-2.13-r1
>        merge time: 9 minutes and 44 seconds.
> 
> 
> I attempted to update busybox from
> 
> sys-apps/busybox-1.18.1
> 
> to 
> 
> sys-apps/busybox-1.18.2
> 
> and still got that error
> 

sorry,

I'm talking about hardened + multilib + x86_64

the non-hardened should work fine,

currently testing the patch from  #48
Comment 56 Matt 2011-02-26 16:56:59 UTC
(In reply to comment #51)
> ive queued the patch in the glibc 2.13 patchset
> 

yes, please

include that patch for hardened in the next version bump

that worked for me

busybox built fine

*solved*

thanks !
Comment 57 Donald R. Gray Jr 2011-02-26 22:33:42 UTC
(In reply to comment #55)
> (In reply to comment #54)
> > (In reply to comment #53)
> > > Can someone confirm that the version now in portage works with busybox and
> > > genkernel?
> > > 
> > 
> > not really - if there hasn't been a silent version-bump / update
> > 
> > in the meantime:
> > 
> > 
> > Fri Feb 18 18:31:50 2011 >>> sys-libs/glibc-2.13-r1
> >        merge time: 9 minutes and 44 seconds.
> > 
> > 
> > I attempted to update busybox from
> > 
> > sys-apps/busybox-1.18.1
> > 
> > to 
> > 
> > sys-apps/busybox-1.18.2
> > 
> > and still got that error
> > 
> 
> sorry,
> 
> I'm talking about hardened + multilib + x86_64
> 
> the non-hardened should work fine,
> 
> currently testing the patch from  #48
> 

busybox-1.18.3 genkernel-3.4.13 initramfs compiles fine on my machine.

Portage 2.1.9.41 (hardened/linux/amd64/no-multilib, gcc-4.5.2, glibc-2.13-r1, 2.6.26-2-amd64 x86_64)
Comment 58 Billy DeVincentis 2011-02-27 17:32:14 UTC
Yes, I can also now confirm. I have updated glibc, emerged busybox, compiled a kernel with genkernel and am at about 800 of 1800 packages being recompiled.
All good!!!
Comment 59 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-03-05 23:39:48 UTC
*** Bug 357461 has been marked as a duplicate of this bug. ***