Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 351931 - dev-util/systemtap keyword request
Summary: dev-util/systemtap keyword request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 384647 (view as bug list)
Depends on:
Blocks: 349627
  Show dependency tree
 
Reported: 2011-01-17 17:46 UTC by Pacho Ramos
Modified: 2013-09-11 14:35 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2011-01-17 17:46:38 UTC
More keywords are needed to allow us depend on this for fixing bug #349627

The following keywords would be needed:
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"

Also, systemtap should be ready to go stable in the near future (~next month or so...)

Thanks a lot

Reproducible: Always
Comment 1 Agostino Sarubbo gentoo-dev 2011-01-18 09:18:50 UTC
amd64 and x86 have already keyword for all version of this package
Comment 2 Naohiro Aota gentoo-dev 2011-02-04 23:25:48 UTC
systemtap never work for *-fbsd
Comment 3 Pacho Ramos gentoo-dev 2011-09-27 12:22:22 UTC
*** Bug 384647 has been marked as a duplicate of this bug. ***
Comment 4 Matt Turner gentoo-dev 2011-10-11 21:04:15 UTC
Looks like alpha@ was missed. Adding to CC.
Comment 5 Matt Turner gentoo-dev 2011-10-11 21:37:26 UTC
Added ~mips.
Comment 6 Tobias Klausmann gentoo-dev 2012-01-16 14:59:05 UTC
Keyworded on alpha.
Comment 7 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2012-02-13 20:38:22 UTC
Marked ~ppc/~ppc64
Comment 8 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2012-11-01 23:37:20 UTC
This package is now an optional dependency for MySQL 5.5.
Can the lagging arches please keyword?

Adding ~hppa.
Comment 9 Jeroen Roovers (RETIRED) gentoo-dev 2012-11-02 17:54:20 UTC
The HPPA kernel doesn't appear to implement KPROBES support. Also, someone appears to have masked this as a dev-db/mysql dependency. Nothing to do here.
Comment 10 Pacho Ramos gentoo-dev 2012-11-05 19:50:19 UTC
Looks like remaining arches are ok with use.masking of systemtap USE flag for glib
Comment 11 Anthony Basile gentoo-dev 2012-11-13 14:07:58 UTC
Sorry for the delay.  I've keyworded systemtap-2.0 for arm.  Look at profiles/arch/arm, there are only two maskings of the keyword:

package.use.mask:>=dev-db/mysql-5.5 systemtap tcmalloc
package.use.mask:>=dev-db/mariadb-5.5 systemtap tcmalloc

Can these now be removed?

(Reopening the bug until we've cleaned this one up)
Comment 12 Agostino Sarubbo gentoo-dev 2012-12-19 17:01:28 UTC
ia64 done
Comment 13 SpanKY gentoo-dev 2013-01-28 20:31:53 UTC
Commit message: Add ~s390 love -- it compiles
http://sources.gentoo.org/dev-util/systemtap/systemtap-2.0.ebuild?r1=1.5&r2=1.6
Comment 14 Pacho Ramos gentoo-dev 2013-08-21 10:23:00 UTC
Arch teams, ping!
Comment 15 Markus Meier gentoo-dev 2013-08-24 09:18:05 UTC
> Sorry for the delay.  I've keyworded systemtap-2.0 for arm.  Look at
> profiles/arch/arm, there are only two maskings of the keyword:
> 
> package.use.mask:>=dev-db/mysql-5.5 systemtap tcmalloc
> package.use.mask:>=dev-db/mariadb-5.5 systemtap tcmalloc
> 
> Can these now be removed?

I've removed the two entries, I guess it's okay as is.
Comment 16 Pacho Ramos gentoo-dev 2013-08-24 09:22:39 UTC
What will sh and sparc do? If they will live with the use.mask, we can close this finally
Comment 17 Pacho Ramos gentoo-dev 2013-09-11 14:35:53 UTC
(In reply to Pacho Ramos from comment #16)
> What will sh and sparc do? If they will live with the use.mask, we can close
> this finally

Closing then