Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 349627 - >=dev-libs/glib-2.26: automagic DTrace/SystemTap options check
Summary: >=dev-libs/glib-2.26: automagic DTrace/SystemTap options check
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on: 351931
  Show dependency tree
Reported: 2010-12-24 16:15 UTC by Naohiro Aota
Modified: 2011-10-16 10:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

proposed patch for the ebuild (glib-2.26.1-r1.ebuild.patch,960 bytes, patch)
2011-01-25 18:01 UTC, Naohiro Aota
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Naohiro Aota gentoo-dev 2010-12-24 16:15:17 UTC
glib-2.26.1 doesn't set enable/disalbe dtrace and systemtap. It would be better to set manually in the ebuild.

Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2011-01-17 16:29:36 UTC
I vote for passing them when setting USE=debug since they are useful for debugging purposes:
Comment 2 Naohiro Aota gentoo-dev 2011-01-25 18:01:41 UTC
Created attachment 260703 [details, diff]
proposed patch for the ebuild
Comment 3 Naohiro Aota gentoo-dev 2011-02-03 03:51:14 UTC
The above patch worked for both USE='fam static-libs debug' and USE='fam static-libs -debug' on Linux.

Actually, what I really want is to disable DTrace feature on Gentoo/FreeBSD by default or add additional check to the ebuild. Gentoo/FreeBSD install DTrace userland by default, but some kernel features, which are off by default, are also needed to build glib with DTrace supported. Glib configure script only check the userland tools, so without passing "--disbale-dtrace" cause build failure.

Please consider disabling DTrace support explicitly.
Comment 4 Pacho Ramos gentoo-dev 2011-02-03 10:16:32 UTC
+  03 Feb 2011; Pacho Ramos <> glib-2.26.1-r1.ebuild:
+  Disable dtrace and systemtap supports until bug #351931 is solved instead of
+  letting them be automagic.
Comment 5 Pacho Ramos gentoo-dev 2011-10-16 10:52:25 UTC
This is already solved in 2.30