Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 350230 - sys-apps/portage: emerge silently ignores packages with conflicting use settings
Summary: sys-apps/portage: emerge silently ignores packages with conflicting use settings
Status: CONFIRMED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
: 453826 528092 (view as bug list)
Depends on:
Blocks: 300071
  Show dependency tree
 
Reported: 2010-12-31 14:30 UTC by Martin Walch
Modified: 2015-08-03 17:53 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
complete output of the command that lead to the output, including the command in the first line (emerge_-eptv_portage,14.50 KB, text/plain)
2010-12-31 14:33 UTC, Martin Walch
Details
emerge --debug -eptv portage --color n (emerge_--debug_-eptv_portage,123.87 KB, text/plain)
2011-01-01 17:06 UTC, Martin Walch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Walch 2010-12-31 14:30:07 UTC
As I do not know what exactly is going wrong, it is hard to describe. However, this looks very bad to me:

[nomerge      ] sys-apps/portage-2.1.9.25  USE="(ipc) -build -doc* -epydoc -python3 (-selinux)" LINGUAS="-pl" 
[nomerge      ]  dev-lang/python-3.1.2-r4  USE="threads (wide-unicode) -build -doc* -examples -gdbm* -ipv6* -ncurses* -readline* -sqlite -ssl* -tk* -wininst -xml*" 
[nomerge      ]   dev-lang/python-2.6.6-r1  USE="berkdb doc gdbm ipv6 ncurses readline ssl threads tk (wide-unicode) xml -build -examples -sqlite -wininst" 
[nomerge      ]    dev-lang/tk-8.5.8-r1  USE="threads (-aqua) -debug -truetype* -xscreensaver*" 
[nomerge      ]     x11-libs/libX11-1.4.0  USE="-doc* -ipv6* -static-libs -test" 
[..]

Especially because python-3.1.2-r4.ebuild contains:

PDEPEND=">=app-admin/python-updater-0.8
|| ( dev-lang/python:2.7[gdbm?,ipv6?,ncurses?,readline?,sqlite?,ssl?,threads?,tk?,xml?]
 dev-lang/python:2.6[gdbm?,ipv6?,ncurses?,readline?,sqlite?,ssl?,threads?,tk?,xml?] )"
Comment 1 Martin Walch 2010-12-31 14:33:57 UTC
Created attachment 258527 [details]
complete output of the command that lead to the output, including the command in the first line

And here goes emerge --info portage:

Portage 2.1.9.25 (default/linux/amd64/10.0/desktop/kde, gcc-4.4.5, glibc-2.11.2-r3, 2.6.36-gentoo-r5 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.36-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q8400_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Thu, 30 Dec 2010 10:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11-r1
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/ccache:     2.4-r9
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.8
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE bea.ri.jsr173 dom4j GPL-2-with-MySQL-FLOSS-exception icu JasPer2.0 jaxen JDOM NCSA-HDF Radiance saxpath wxWinFDL-3 GPL freedist MOTIF Allegro unRAR MSttfEULA UCAR-Unidata GDLS ISOC-rfc"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -fgcse-after-reload -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -fgcse-after-reload -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache collision-protect distlocks fixlafiles fixpackages metadata-transfer mirror multilib-strict news nostrip parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=native -O2 -fgcse-after-reload -pipe"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://gentoo.mneisen.org/ http://mirror.ovh.net/gentoo-distfiles/ http://mirror.netcologne.de/gentoo/ http://mirrors.linuxant.fr/distfiles.gentoo.org/"
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/unknown-horizons /usr/local/portage /usr/local/portage/worldforge"
SYNC="rsync://rsync3.de.gentoo.org/gentoo-portage"
USE="64bit X Xaw3d a52 aac aalib accessibility acl acpi agg akode allegro alsa amarok amd64 amr apache2 autoipd avahi bash-completion bazaar berkdb bittorrent blender blender-game branding bzip2 cairo captury cdaudio cdr cdrom cegui cjk cli clucene consolekit cracklib crypt cups curl cviewer cvs cxx daap dbus default-font designer-plugin desktopglobe devil dga dirac djvu doc dri dts dvd dvdnav dvdr dxr3 emacs embedded emboss encode exif fam fbcon ffmpeg fftw firefox fits flac fltk fortran gcj gdbm gdu ggi git glitz gmm gmp gopher gpg gpm gpu grub gstreamer guile gzip hdri htmlhandbook i18n iceweasel icons iconv icq icu idn imagemagick insecure-savers intel ipv6 jabber jack java java6 javascript jingle jpeg kde kde4 kdebuild kdecards kdehiddenvisibility kdepim kdm kontact ktts latex lcms ldap libcaca libnotify libssh2 libwww lm_sensors logitech-mouse lua lzma lzo matroska mdnsresponder-compat mercurial mikmod mmx mng modules mpeg mpeg2 mpfr mpi mudflap mule multilib musepack mysql ncurses neon nepomuk networkmanager nio2 nls noamazon nova nptl nptlonly nsplugin offensive ogg ogg123 openal openexr opengl openmp openssl opensslcrypt openstreetmap openxml oscar oss otr oxygen pae pam pango pcre pdf perl phonon plasma player png policykit posix povray ppds pppd private-headers python qt3support qt4 readline redland reiser4 reiserfs rss schroedinger sdl sdl-image semantic-desktop sensord session shm shmvideo sndfile solver songs sound speex spell sse sse2 ssl ssse3 startup-notification subversion svg sysfs systemtap tcpd tetex theora threads tidy tiff tk tools truetype type1 udev unicode usb v4l2 vhook videos visualization vorbis vpx wav wavpack wikipedia wmf wxwindows x264 xcb xcomposite xemacs xerces-c xhtml xine xml xorg xosd xprint xrandr xscreensaver xulrunner xv xvid xvmc zeroconf zfs zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="i965 intel vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-apps/portage-2.1.9.25 was built with the following:
USE="doc (ipc) (multilib) -build -epydoc -python3 (-selinux)" LINGUAS="-pl"
Comment 2 Zac Medico gentoo-dev 2010-12-31 19:58:38 UTC
What's the problem? Aren't the dependencies satisfied? If not, which ones?
Comment 3 Martin Walch 2011-01-01 11:57:32 UTC
(In reply to comment #2)
> What's the problem? Aren't the dependencies satisfied? If not, which ones?

Sorry, I just saw that I accidently did not copy the full command into the file. Without that, the problem can not be clear. Also I should have pointed the problem out more clearly:

The command was

emerge -eptv portage

with the explicit USE flag settings from the first line of the file from comment #1.

As you can see in comment #0, dev-lang/python-3.1.2-r4 is pulled in as a dependency of sys-apps/portage-2.1.9.25. Note that USE flags are changing, as highlighted by a *. Now dev-lang/python-3.1.2-r4 PDEPENDS on dev-lang/python-2.6.6-r1. This is also denoted by the tree output in comment #0. However, although the --emptytree option is passed to portage, dev-lang/python-2.6.6-r1
will *not* be emerged (appears only as "nomerge") and its use flags will not be changed. What makes things worse: all dependencies of dev-lang/python-2.6.6-r1 *are* pulled in, also the ones that are pulled in by use flags that should not be set any more. There are even more bad implications, but those all seem to be expectable consequences.
Comment 4 Sebastian Luther (few) 2011-01-01 16:01:11 UTC
What happens if you add --backtrack=0 to your command?

If this doesn't change anything, attach emerge's output with --debug added to your command.
Comment 5 Martin Walch 2011-01-01 17:06:52 UTC
Created attachment 258576 [details]
emerge --debug -eptv portage --color n

(In reply to comment #4)
> What happens if you add --backtrack=0 to your command?

This does not change the result.

> If this doesn't change anything, attach emerge's output with --debug added to
> your command.

Here it is, with stdout and stderr together in one file.
Comment 6 Sebastian Luther (few) 2011-01-01 17:37:20 UTC
The problem is that there are packages that depend on python-2.6[xml] and your new settings have xml disabled. You probably have a lot more of such conflicts.

For a start, try emerge -uDN world --backtrack=0. But be aware that this will result in a lot of conflicts that need to be solved one by one, but I don't see another way to apply all those changes.
Comment 7 Martin Walch 2011-01-01 18:10:29 UTC
(In reply to comment #6)
> For a start, try emerge -uDN world --backtrack=0. But be aware that this will
> result in a lot of conflicts that need to be solved one by one, but I don't see
> another way to apply all those changes.

Thank you for your hint. However, I do not want to actually apply those changes. I was only considering some "what if" scenarios when I came across this. And as it looks like a bug in portage to me, I wrote this report. So there is no need for a workaround in my case. :)
Comment 8 Zac Medico gentoo-dev 2014-11-30 16:53:53 UTC
*** Bug 528092 has been marked as a duplicate of this bug. ***
Comment 9 Zac Medico gentoo-dev 2014-12-28 23:23:39 UTC
*** Bug 453826 has been marked as a duplicate of this bug. ***