Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 347940 - xorg-server-1.9 needs newer doxygen stabilized on x86
Summary: xorg-server-1.9 needs newer doxygen stabilized on x86
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Steve Arnold
URL:
Whiteboard:
Keywords:
Depends on: 338632
Blocks:
  Show dependency tree
 
Reported: 2010-12-06 20:42 UTC by Myckel Habets
Modified: 2011-04-09 16:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Myckel Habets archtester 2010-12-06 20:42:01 UTC
x86 needs a newer doxygen stabilized:

USE='doc' emerge -1 =x11-base/xorg-server-1.9.2
Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=app-doc/doxygen-1.6.1" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-doc/doxygen-1.7.2 (masked by: ~x86 keyword)
- app-doc/doxygen-1.7.1 (masked by: ~x86 keyword)
- app-doc/doxygen-1.6.3 (masked by: ~x86 keyword)
- app-doc/doxygen-1.6.2 (masked by: ~x86 keyword)
- app-doc/doxygen-1.6.1 (masked by: ~x86 keyword)

(dependency required by "x11-base/xorg-server-1.9.2" [ebuild])
(dependency required by "=x11-base/xorg-server-1.9.2" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

There are currently 2 bugs (bug 338632 and bug 323647) for a newer, suitable
doxygen, but none has gone through stabilization.


Reproducible: Always

Steps to Reproduce:
1. emerge =x11-base/xorg-server-1.9.2 with 'doc' USE flag on x86.




emerge --info
Portage 2.1.9.24 (default/linux/x86/10.0, gcc-4.4.4, glibc-2.11.2-r3, 2.6.36
i686)
=================================================================
System uname:
Linux-2.6.36-i686-Mobile_AMD_Sempron-tm-_Processor_2800+-with-gentoo-1.12.14
Timestamp of tree: Sat, 04 Dec 2010 14:25:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11-r1
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.30-r1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/
/etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/
/etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild
/etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d
/etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon-xp -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks fixlafiles
fixpackages news nostrip parallel-fetch protect-owned sandbox sfperms strict
test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="nl_NL.UTF-8"
LDFLAGS="-Wl,-O1,--as-needed"
LINGUAS="nl en uk"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
--force --whole-file --delete --stats --timeout=180 --exclude=/distfiles
--exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X acl acpi alsa autoipd avahi bash-completion berkdb bzip2 cairo cli
cracklib crypt cxx dbus dri encode fam ffmpeg flac fontconfig fortran fts3 gdbm
gif gmp gnutls gpm gtk hal iconv icu imap ipv6 ithreads java5 jpeg libnotify
mikmod mmx modules mp3 mudflap ncurses networking nls nptl nptlonly ogg openexr
opengl openmp openssl pam pcre perl pic player png pppd python qt3support qt4
rdesktop readline sdl session smime sockets spell sqlite sqlite3 sse sse2 ssl
startup-notification svg sysfs tcpd theora threads thunar timidity truetype
udev unicode vnc vorbis x86 xcb xcomposite xft xorg zlib" ALSA_CARDS="ali5451
als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370
ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident
usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy
dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear
meter mmap_emul mulaw multi null plug rate route share shm softvol"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm
authn_default authn_file authz_dbm authz_default authz_groupfile authz_host
authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir
disk_cache env expires ext_filter file_cache filter headers include info
log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling
status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface
irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech
aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea
ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2
timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev"
KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001
mtxorb ncurses text" LINGUAS="nl en uk" PHP_TARGETS="php5-2"
RUBY_TARGETS="ree18" USERLAND="GNU" VIDEO_CARDS="radeonhd radeon intel nouveau
vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p
iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark
dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL,
PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS,
PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-12-07 12:00:00 UTC
x11-base/xorg-server-1.9.2 has the doc flag already masked.
Comment 2 Steve Arnold gentoo-dev 2010-12-13 03:18:47 UTC
Doxygen 1.7.2 has no bugs since it debuted, so the stable-ize 1.7.1 bug has been updated.
Comment 3 Steve Arnold gentoo-dev 2011-03-26 06:25:50 UTC
Okay, Doxygen 1.7.3 is stable for all but hppa - can xorg unmask the doc flag now, or do you need to wait for hppa?  Just checking...
Comment 4 Jeroen Roovers gentoo-dev 2011-03-29 12:46:50 UTC
Stable for HPPA (bug #356813).
Comment 5 Steve Arnold gentoo-dev 2011-04-09 16:28:04 UTC
Closing, and another doxygen bump is coming..