Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 342157 - sys-apps/portage: wrong "skipped update" message
Summary: sys-apps/portage: wrong "skipped update" message
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
Depends on:
Blocks: 335925
  Show dependency tree
Reported: 2010-10-22 08:18 UTC by Sven Schwyn (svoop)
Modified: 2010-10-25 08:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sven Schwyn (svoop) 2010-10-22 08:18:42 UTC
Since a few days, Portage nags as follows:

!!! One or more updates have been skipped due to a dependency conflict:


 (dev-lang/php-5.3.3-r1, ebuild scheduled for merge) conflicts with
   =dev-lang/php-5* required by (dev-php/awl-0.43, installed)
 (dev-lang/php-5.3.3-r1, ebuild scheduled for merge) conflicts with
   dev-lang/php required by @selected

The forum yielded no responses and as it looks like a bug to me, I'll give it a shot here. Sorry if it's a local issue only.

Reproducible: Always

Steps to Reproduce:
Comment 1 Sebastian Luther (few) 2010-10-22 09:01:27 UTC
Which portage version is that? There was a similar bug lately.
Comment 2 Sven Schwyn (svoop) 2010-10-22 09:20:17 UTC
I'm currently on portage-
Comment 3 Zac Medico gentoo-dev 2010-10-22 09:56:34 UTC
The problem is here:;a=commit;h=8f91b6615617af839a31e51bd3bb2048ea81ea56

We an improve it by optimizing the atom sort order so that =* operators have less priority than < or <= operators.
Comment 4 Zac Medico gentoo-dev 2010-10-22 09:58:32 UTC
Even better would be to compare the version parts of the atoms.
Comment 5 Zac Medico gentoo-dev 2010-10-22 10:03:59 UTC
(In reply to comment #0)
>  (dev-lang/php-5.3.3-r1, ebuild scheduled for merge) conflicts with
>    =dev-lang/php-5* required by (dev-php/awl-0.43, installed)

Note: If you want a quick workaround, check the dev-lang/php atoms in /var/db/pkg/dev-php/awl-0.43/*DEPEND files.
Comment 6 Zac Medico gentoo-dev 2010-10-22 11:34:50 UTC
This fixes it to do a more rigorous check for atoms that trigger conflicts:;a=commit;h=073a9c885ceb7be164b9287b2e0cb3f4b5584367
Comment 7 Zac Medico gentoo-dev 2010-10-23 11:45:07 UTC
This is fixed in and 2.2.0_alpha1.
Comment 8 Sven Schwyn (svoop) 2010-10-25 07:05:45 UTC
On portage- I now get the following:

!!! One or more updates have been skipped due to a dependency conflict:


  (dev-lang/php-5.3.3-r1, ebuild scheduled for merge) conflicts with
    dev-lang/php[pcre,pdo,postgres,xml] required by (dev-php/awl-0.43, installed)
Comment 9 Sebastian Luther (few) 2010-10-25 07:09:44 UTC
What's the output of "emerge -pvq dev-lang/php"? You probably don't have the use flags for dev-lang/php set in a way that satisfies the dependency emerge prints there.
Comment 10 Sven Schwyn (svoop) 2010-10-25 07:13:02 UTC
Here it is...

[ebuild  N    ] dev-libs/oniguruma-5.9.2 
[ebuild     U ] dev-lang/php-5.3.3-r1 [5.2.14] USE="apache2 berkdb bzip2 cli crypt ctype fileinfo%* filter gd gdbm hash iconv json nls pdo phar%* posix postgres readline session simplexml ssl threads tokenizer unicode xml xmlreader xmlwriter zlib (-adabas) -bcmath (-birdstep) -calendar -cdb -cgi -cjk -concurrentmodphp -curl -curlwrappers -db2 (-dbmaker) -debug -doc -embed (-empress) (-empress-bcs) -enchant% (-esoob) -exif (-firebird) -flatfile -fpm% (-frontbase) -ftp -gd-external -gmp -imap -inifile -interbase -intl% -iodbc -ipv6 -kerberos -kolab -ldap -ldap-sasl -libedit -mssql -mysql -mysqli -mysqlnd% -oci8 -oci8-instant-client -odbc -pcntl -pic -qdbm -recode -sapdb -sharedext -sharedmem -snmp -soap -sockets (-solid) -spell -sqlite -sqlite3% -suhosin (-sybase-ct) -sysvipc -tidy -truetype -wddx -xmlrpc -xpm -xsl -zip (-dbase%) (-discard-path%) (-fdftk%) (-force-cgi-redirect%) (-mcve%) (-mhash%) (-msql%) (-ncurses%*) (-pcre%*) (-reflection%*) (-spl%*) (-yaz%)" 
Comment 11 Sebastian Luther (few) 2010-10-25 07:17:55 UTC
The newer php version doesn't have a pcre use flag. File a bug for dev-php/awl.

Marking this bug as fixed again, as emerge prints the correct conflict atom.
Comment 12 Sven Schwyn (svoop) 2010-10-25 08:22:27 UTC
I see, thanks for the hint. The bug is submitted as: