Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 341943 - <=sys-kernel/genkernel-3.4.10.907 fails to build busybox 1.7.4 with sys-devel/make-3.82
Summary: <=sys-kernel/genkernel-3.4.10.907 fails to build busybox 1.7.4 with sys-devel...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Genkernel Maintainers
URL:
Whiteboard:
Keywords:
: 342699 342987 371298 (view as bug list)
Depends on:
Blocks: gmake-3.82
  Show dependency tree
 
Reported: 2010-10-21 00:08 UTC by jeremy
Modified: 2011-11-26 16:47 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Genkernel fail log (make-3.82) (genkernel.log,249.73 KB, text/plain)
2010-10-21 00:09 UTC, jeremy
Details
emerge info from failed build (emerge-info-failed-build,4.52 KB, text/plain)
2010-10-21 00:11 UTC, jeremy
Details
emerge info after successful build (emerge-info-successful-build,4.53 KB, text/plain)
2010-10-21 00:13 UTC, jeremy
Details
Broken busybox makefile from genkernel`s cache (Makefile,40.48 KB, text/plain)
2010-10-23 11:37 UTC, Artemii
Details
/usr/share/genkernel/patches/busybox/1.7.4/1.7.4-make-3.82.diff (1.7.4-make-3.82.diff,731 bytes, patch)
2010-10-26 16:57 UTC, Denis Kaganovich
Details | Diff
Allow compilation of busybox 1.7.4 with make 3.82 (1.7.4-make-3.82.diff,1.26 KB, patch)
2010-11-29 09:14 UTC, Sebastian Pipping
Details | Diff
Genkernel crash log (genkernel.log,514.61 KB, text/plain)
2011-05-30 22:23 UTC, Carter Young
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jeremy 2010-10-21 00:08:30 UTC
During my normal update last night a few updates were brought through. Among them were gentoo-sources-2.6.35-r11. So i fired up genkernel and decided to build this newer kernel.However once it got to the "busybox" portion of the build it failed. The last error in the log was "Makefile:405: *** mixed implicit and normal rules.  Stop." Then i see "make: getcwd: No such file or directory
make: *** No rule to make target `all'.  Stop.". And it stops there. This was with make-3.82 installed. I had a few people look at the log and they all said it looked like a problem with make. Then i remembered make had been updated a few days ago. So i figured i would downgrade make to my previous version. Well long story short after downgrading to make-3.81-r2 the kernel was able to build successfully. Im not sure where the incompatability is. If it actually with make or if its in genkernel i just know that downgrading make fixes it. Maybe genkernel needs patch to work with the new make or maybe its make that needs patching.

Infos from failed build

deadly-soundz ~ # emerge --info
Portage 2.2_rc98 (default/linux/amd64/10.0/desktop/gnome, gcc-4.4.4, glibc-2.12.1-r1, 2.6.35-gentoo-r10 x86_64)
=================================================================
System uname: Linux-2.6.35-gentoo-r10-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.0.1
Timestamp of tree: Wed, 20 Oct 2010 22:45:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.82
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/conf.d/fbcondecor /etc/conf.d/splash /usr/share/genkernel/arch/x86_64 /usr/share/genkernel/defaults"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--ask"
FEATURES="assume-digests binpkg-logs distlocks fakeroot fixlafiles fixpackages multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync21.us.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 bash-completion berkdb branding bzip2 cairo caps cdr consolekit cracklib crypt cups curl cxx dbus djvu dri dts dvd dvdr eds emboss encode evo exceptions exif extras fam firefox flac fontforge fortran gconf gdbm gdu gif gmp gnome gnome-keyring gpm gstreamer gtk hal iconv java javascript jpeg jpeg2k lcms ldap libnotify libssh2 lzo mad mikmod mmx mmxext mng modules motif mp3 mp4 mpeg mudflap multilib multiuser nautilus ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp oss pam pango pcre pdf perl plugins png policykit ppds python readline sdl slang sound spell sqlite sse sse2 sse3 ssh ssl startup-notification svg sysfs syslog system-sqlite tcl tcpd threads tiff tk tools truetype unicode usb utils vorbis x264 xattr xcb xft xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel ice1724" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest authn_dbd dbd imagemap" APACHE2_MPMS="worker" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" PHP_TARGETS="php-5.2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa fbdev nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

[ebuild   R   ] sys-kernel/gentoo-sources-2.6.35-r11  USE="-build -deblob -symlink" 0 kB

[ebuild   R   ] sys-kernel/genkernel-3.4.10.907  USE="bash-completion (-ibm) (-selinux)" 0 kB

[ebuild   R   ] sys-devel/make-3.82  USE="nls -static" 0 kB

Infos from successful build:

deadly-soundz ~ # emerge --info
Portage 2.2_rc98 (default/linux/amd64/10.0/desktop/gnome, gcc-4.4.4, glibc-2.12.1-r1, 2.6.35-gentoo-r11 x86_64)
=================================================================
System uname: Linux-2.6.35-gentoo-r11-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.0.1
Timestamp of tree: Wed, 20 Oct 2010 22:45:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/conf.d/fbcondecor /etc/conf.d/splash /usr/share/genkernel/arch/x86_64 /usr/share/genkernel/defaults"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--ask"
FEATURES="assume-digests binpkg-logs distlocks fakeroot fixlafiles fixpackages multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync21.us.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 bash-completion berkdb branding bzip2 cairo caps cdr consolekit cracklib crypt cups curl cxx dbus djvu dri dts dvd dvdr eds emboss encode evo exceptions exif extras fam firefox flac fontforge fortran gconf gdbm gdu gif gmp gnome gnome-keyring gpm gstreamer gtk hal iconv java javascript jpeg jpeg2k lcms ldap libnotify libssh2 lzo mad mikmod mmx mmxext mng modules motif mp3 mp4 mpeg mudflap multilib multiuser nautilus ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp oss pam pango pcre pdf perl plugins png policykit ppds python readline sdl slang sound spell sqlite sse sse2 sse3 ssh ssl startup-notification svg sysfs syslog system-sqlite tcl tcpd threads tiff tk tools truetype unicode usb utils vorbis x264 xattr xcb xft xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel ice1724" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest authn_dbd dbd imagemap" APACHE2_MPMS="worker" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" PHP_TARGETS="php-5.2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="vesa fbdev nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

[ebuild   R   ] sys-kernel/gentoo-sources-2.6.35-r11  USE="-build -deblob -symlink" 0 kB

[ebuild   R   ] sys-kernel/genkernel-3.4.10.907  USE="bash-completion (-ibm) (-selinux)" 0 kB

[ebuild   R   ] sys-devel/make-3.81-r2  USE="nls -static" 0 kB

If you need more info please ask and ill be happy to provide anything needed.
Comment 1 jeremy 2010-10-21 00:09:21 UTC
Created attachment 251375 [details]
Genkernel fail log (make-3.82)
Comment 2 jeremy 2010-10-21 00:11:47 UTC
Created attachment 251377 [details]
emerge info from failed build
Comment 3 jeremy 2010-10-21 00:13:17 UTC
Created attachment 251379 [details]
emerge info after successful build
Comment 4 Samuli Suominen gentoo-dev 2010-10-23 09:43:57 UTC
(In reply to comment #1)
> Created an attachment (id=251375) [details]
> Genkernel fail log (make-3.82)
> 
> Makefile:405: *** mixed implicit and normal rules.  Stop.

What's in line 405, can you attach the broken Makefile here?
Comment 5 Artemii 2010-10-23 11:37:43 UTC
Created attachment 251681 [details]
Broken busybox makefile from genkernel`s cache

I have same problem. 

>What's in line 405, can you attach the broken Makefile here?

This is Makefile from busybox, from genkernel`s cache.
Comment 6 Denis Kaganovich 2010-10-26 15:20:30 UTC
First look: this is glibc static linking problem. I breaking on e2fsck, on LD static libs.

In directory: [...]/e2fsprogs-1.40.9/e2fsck

Command:

x86_64-pc-linux-gnu-ld -static -o e2fsck dict.o unix.o e2fsck.o super.o pass1.o pass1b.o pass2.o pass3.o pass4.o pass5.o journal.o swapfs.o badblocks.o util.o dirinfo.o dx_dirinfo.o ehandler.o problem.o message.o recovery.o region.o revoke.o ea_refcount.o rehash.o profile.o prof_err.o  ../lib/libext2fs.a ../lib/libcom_err.a ../lib/libblkid.a  ../lib/libuuid.a   ../lib/libe2p.a

First output lines:

x86_64-pc-linux-gnu-ld: warning: cannot find entry symbol _start; defaulting to
0000000000400190
dict.o: In function `dnode_create':
/var/tmp/portage/sys-kernel/gentoo-sources-2.6.36/temp/genkernel/1526.25314.27460.8304/e2fsprogs-1.40.9/e2fsck/dict.c:984: undefined reference to `malloc'

[etc]

PS Now I am a bit drunk to go deeper, sorry. May be.
Comment 7 Denis Kaganovich 2010-10-26 15:42:09 UTC
e2fsprogs solved: emerge -1q glibc
Still busybox...
Comment 8 Samuli Suominen gentoo-dev 2010-10-26 16:55:00 UTC
This might be related:

http://bugs.gentoo.org/show_bug.cgi?id=331995#c3
Comment 9 Samuli Suominen gentoo-dev 2010-10-26 16:55:55 UTC
(In reply to comment #7)
> e2fsprogs solved: emerge -1q glibc
> Still busybox...
> 

Stop spamming this bug, this is nothing to do with your issue.
Comment 10 Denis Kaganovich 2010-10-26 16:57:50 UTC
Created attachment 252043 [details, diff]
/usr/share/genkernel/patches/busybox/1.7.4/1.7.4-make-3.82.diff

This is no bug, but removed unsupported undocumented hole in make.
Patch (mine - looks work, not mind) for busybox 1.7.4 attached.

About bug: http://comments.gmane.org/gmane.comp.gnu.make.bugs/4912
Paul Smith:
"The previous behavior of mixing implicit and pattern rules in one line
like that was never supported or documented, but due to a "hole" in the
parser it worked for certain specific cases (for example, reversing that
line so the pattern comes first would not work, nor would adding extra
explicit targets after the pattern target)."
Comment 11 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2010-10-27 20:23:31 UTC
*** Bug 342987 has been marked as a duplicate of this bug. ***
Comment 12 Emmanuel Pelado 2010-10-27 20:38:07 UTC
(In reply to comment #10)
> Created an attachment (id=252043) [details]
> /usr/share/genkernel/patches/busybox/1.7.4/1.7.4-make-3.82.diff
> 
> This is no bug, but removed unsupported undocumented hole in make.
> Patch (mine - looks work, not mind) for busybox 1.7.4 attached.
> 
> About bug: http://comments.gmane.org/gmane.comp.gnu.make.bugs/4912
> Paul Smith:
> "The previous behavior of mixing implicit and pattern rules in one line
> like that was never supported or documented, but due to a "hole" in the
> parser it worked for certain specific cases (for example, reversing that
> line so the pattern comes first would not work, nor would adding extra
> explicit targets after the pattern target)."
> 

that patch works for me. thank you so much
Comment 13 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2010-10-28 20:44:19 UTC
*** Bug 342699 has been marked as a duplicate of this bug. ***
Comment 14 Travis Hansen 2010-11-12 00:07:59 UTC
patch worked for me too.
Comment 15 Kai Blaschke 2010-11-21 18:49:57 UTC
Patch working for me too, x86_64, kernel 2.6.36-gentoo-r1 and genkernel 3.4.10.907
Comment 16 Sylvain BERTRAND 2010-11-24 14:58:27 UTC
patch worked for me: sys-kernel/genkernel-3.4.10.907 and vanilla-sources-2.6.37-rc3
Comment 17 Sylvain BERTRAND 2010-11-24 14:59:11 UTC
patch worked for me:genkernel-3.4.10.907 and vanilla-sources-2.6.37-rc3
Comment 18 Sebastian Pipping gentoo-dev 2010-11-28 20:09:18 UTC
Time for a new genkernel release?
Comment 19 Sebastian Pipping gentoo-dev 2010-11-29 09:14:27 UTC
Created attachment 255809 [details, diff]
Allow compilation of busybox 1.7.4 with make 3.82 

It seems in the Makefile of the Kernel they choose a different approach to patching the make rules.  Instead of removing the config target, they split into two rules:

config: scripts_basic outputmakefile FORCE
        [..]

%config: scripts_basic outputmakefile FORCE
        [..]

I have copied their approach and update the patch accordingly.

I have integrated that patch into genkernel-3.4.10.907-r1.  Please give it a try. I hope I didn't break anything.

+*genkernel-3.4.10.907-r1 (29 Nov 2010)
+
+  29 Nov 2010; <sping@gentoo.org> +files/busybox-1.7.4-make-3.82.patch,
+  +genkernel-3.4.10.907-r1.ebuild:
+  Integrate patch allowing compilation of busybox 1.7.4 with make 3.82 (bug
+  #341943)
+
Comment 20 Sebastian Pipping gentoo-dev 2010-11-29 09:40:21 UTC
Patch now added to master in the Git repo:
http://git.overlays.gentoo.org/gitweb/?p=proj/genkernel.git;a=commitdiff;h=e9768b0b2b025da6bafe7a667f791dcdf4a11656

Therefore genkernel-9999 installs this patch, too.

Closing, please re-open as needed.
Comment 21 Carter Young 2011-05-30 22:12:29 UTC
Please reopen, as bug is reappearing when trying to compile 2.6.38-gentoo-r6
Comment 22 Sebastian Pipping gentoo-dev 2011-05-30 22:14:51 UTC
(In reply to comment #21)
> Please reopen, as bug is reappearing when trying to compile 2.6.38-gentoo-r6

I don#t object re-opening, but please explain how 2.6.38-gentoo-r6 relates to this bug on busybox and make.  I don't see a relation, yet.  Thanks!
Comment 23 Carter Young 2011-05-30 22:23:27 UTC
Created attachment 275237 [details]
Genkernel crash log
Comment 24 Carter Young 2011-05-30 22:23:59 UTC
(In reply to comment #22)
> (In reply to comment #21)
> > Please reopen, as bug is reappearing when trying to compile 2.6.38-gentoo-r6
> 
> I don#t object re-opening, but please explain how 2.6.38-gentoo-r6 relates to
> this bug on busybox and make.  I don't see a relation, yet.  Thanks!

See Attached log
Comment 25 Carter Young 2011-05-30 23:05:45 UTC
(In reply to comment #24)
> (In reply to comment #22)
> > (In reply to comment #21)
> > > Please reopen, as bug is reappearing when trying to compile 2.6.38-gentoo-r6
> > 
> > I don#t object re-opening, but please explain how 2.6.38-gentoo-r6 relates to
> > this bug on busybox and make.  I don't see a relation, yet.  Thanks!
> 
> See Attached log

I added sys-kernel/genkernel * to package.keywords, emerged, and re-ran.  Issue fixed, but as you can see from log it is occurring in the stable version...
Comment 26 Sebastian Pipping gentoo-dev 2011-05-31 00:21:37 UTC
(In reply to comment #25)
> I added sys-kernel/genkernel * to package.keywords, emerged, and re-ran.  Issue
> fixed, but as you can see from log it is occurring in the stable version...

Correct: It's included since 3.4.10.907-r1, not before.
Comment 27 Sebastian Pipping gentoo-dev 2011-06-14 22:06:28 UTC
*** Bug 371298 has been marked as a duplicate of this bug. ***
Comment 28 Sebastian Pipping gentoo-dev 2011-06-22 16:07:08 UTC
+  22 Jun 2011; Sebastian Pipping <sping@gentoo.org>
+  genkernel-3.4.10.907-r1.ebuild:
+  Stabilize 3.4.10.907-r1 on all arches. I dare doing that because 3.4.10.907
+  is stable, the only addition is a patch for make 3.82, make 3.82 is stable
+  already, users keep reporting the make 3.82 bug, the patch has been reported
+  to solve the problem. So I believe there is good reason for an exception
+  here.
+
Comment 29 Andreas K. Hüttel gentoo-dev 2011-11-26 16:47:02 UTC
*** Bug 391971 has been marked as a duplicate of this bug. ***