Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 341105 - fingerprint-gui (new package)
Summary: fingerprint-gui (new package)
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Michael Weber (RETIRED)
URL: http://www.n-view.net/Appliance/finge...
Whiteboard:
Keywords: EBUILD
: 341583 (view as bug list)
Depends on: 341107
Blocks:
  Show dependency tree
 
Reported: 2010-10-15 11:13 UTC by Jan Buecken
Modified: 2012-05-21 01:55 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
simple fingerprint-gui ebuild (fingerprint-gui-0.15.ebuild,694 bytes, text/plain)
2010-10-15 11:15 UTC, Jan Buecken
Details
improved ebuild (fingerprint-gui-0.15.ebuild,1.12 KB, text/plain)
2010-10-17 23:52 UTC, Jan Buecken
Details
version bump and some improvements (fingerprint-gui-1.00_rc1.ebuild,2.18 KB, text/plain)
2010-10-19 14:16 UTC, Jan Buecken
Details
files/... (Install-step-by-step.html,34.57 KB, text/plain)
2010-10-19 14:17 UTC, Jan Buecken
Details
sys-auth/upekbsapi-bin ebuild (upekbsapi-bin-3.5.2.ebuild,1.09 KB, text/plain)
2010-10-19 14:21 UTC, Jan Buecken
Details
sys-auth/fingerprint-gui-1.00 stable release ebuild (fingerprint-gui-1.00.ebuild,1.75 KB, text/plain)
2011-01-14 00:15 UTC, Jan Buecken
Details
Fixes a library that fails to install. (fingerprint-gui-1.00-suid-local.patch,368 bytes, patch)
2011-01-29 10:40 UTC, vekin
Details | Diff
fixed ebuild: apply patch fingerprint-gui-1.00-suid-pathfix.patch (fingerprint-gui-1.00.ebuild,1.81 KB, text/plain)
2011-02-01 09:43 UTC, Jan Buecken
Details
fixes path for fingerprint-suid (fingerprint-gui-1.00-suid-pathfix.patch,325 bytes, patch)
2011-02-01 09:45 UTC, Jan Buecken
Details | Diff
Fix build with >=polkit-qt-0.99.0 (fingerprint-gui-1.00.ebuild,1.93 KB, text/plain)
2011-05-23 11:33 UTC, Jan Buecken
Details
Fix build and useflag handling (fingerprint-gui-1.00.ebuild,1.94 KB, text/plain)
2011-05-23 12:10 UTC, Jan Buecken
Details
ebuild for version 1.03 (fingerprint-gui-1.03.ebuild,1.90 KB, text/plain)
2012-01-29 16:26 UTC, Jan Buecken
Details
fix segfault in version 1.03 (fingerprint-gui-1.03-segfaultfix.patch,404 bytes, patch)
2012-01-30 22:02 UTC, Jan Buecken
Details | Diff
ebuild for version 1.03 (r1) (fingerprint-gui-1.03.ebuild,2.00 KB, text/plain)
2012-01-30 22:10 UTC, Jan Buecken
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Buecken 2010-10-15 11:13:01 UTC
The fingerprint software in portage is rare. Thus I write an ebuild for the fingerprint-gui (depending on libfprint and co, see ebuild).
This ebuild can be improved: The "upek" useflag should install the proritary driver libbsapi.so and the udev-rules which are in the package. This time the useflag does nothing since the upek chips works with the upekonly kernel driver and I don't know if there are GPL Problems installing the library.

Reproducible: Always
Comment 1 Jan Buecken 2010-10-15 11:15:17 UTC
Created attachment 250683 [details]
simple fingerprint-gui ebuild

I recommend app-crypt/fingerprint-gui/ as portage location. The upek USE-flag does nothing.
Comment 2 Jan Buecken 2010-10-17 21:11:03 UTC
Since bug #341107 is fixed, but the package makes it in sys-auth/libfprint you have to replace media-libs/libfprint in the DEPEND section with the new path.
Comment 3 Jan Buecken 2010-10-17 23:52:54 UTC
Created attachment 251075 [details]
improved ebuild

Improved ebuild installing upeks libbsapi.so. and some docs.
I got 
 * QA Notice: Pre-stripped files found:
 * /usr/lib64/libbsapi.so
and
 * QA Notice: The following shared libraries lack a SONAME
 * /usr/lib64/libbsapi.so
but I hope thats not a problem.

The libbsapi.so could be installed as a stand-alone package in future if other programs use this lib.
Comment 4 Jan Buecken 2010-10-17 23:55:33 UTC
I should say that I prefer sys-auth/fingerprint-gui now, because this is a pam based software similar to pam_fprint and thus should be in the same location...
Comment 5 Jan Buecken 2010-10-18 09:39:05 UTC
For the users of my ebuild:
You may want to replace 
>=../qt-core-4.0.0
by the slot
../qt-core:4
(don't use >=..)

by the way: bug #341583 is a dublicate of this bug
Comment 6 Michael Weber (RETIRED) gentoo-dev 2010-10-18 12:26:39 UTC
*** Bug 341583 has been marked as a duplicate of this bug. ***
Comment 7 Jan Buecken 2010-10-18 12:39:09 UTC
Oh, there just exist an ebuild:

http://github.com/casparant/caspar-gentoo/blob/master/sys-auth/fingerprint-gui/fingerprint-gui-0.14.ebuild

One may merge my ebuild with this one to a better ebuild? But I have to say, I like my ebuild... :-)
Comment 8 Jan Buecken 2010-10-18 12:50:46 UTC
> The libbsapi.so could be installed as a stand-alone package in future if other
> programs use this lib.

The ebuild I mentioned above follows this idea: You'll need 
http://github.com/casparant/caspar-gentoo/blob/master/sys-auth/upek-bin/upek-bin-3.5.2.ebuild

and it the ebuild for fingerprint-gui follows ../qt:4 in the dependencies like I mentioned in comment #5.
Comment 9 bartoz 2010-10-19 01:30:01 UTC
Tried to emerge the ``improved ebuild''; it looks like it's working fine.

(In reply to comment #8)
> > The libbsapi.so could be installed as a stand-alone package in future if other
> > programs use this lib.
> 
> The ebuild I mentioned above follows this idea: You'll need 
> http://github.com/casparant/caspar-gentoo/blob/master/sys-auth/upek-bin/upek-bin-3.5.2.ebuild
> 
> and it the ebuild for fingerprint-gui follows ../qt:4 in the dependencies like
> I mentioned in comment #5.
> 
Comment 10 Jan Buecken 2010-10-19 14:16:24 UTC
Created attachment 251257 [details]
version bump and some improvements

new ebuild
changes:
+ domenu with the .desktop file
+ !fprint dependecy added
+ upeks bsapi is a new package
+ compared with the ebuild by caspar (it had other install pathes, see comments in ebuild)

+ version bump, you need to install upeks bsapi headers now, otherwise compilation fails. If you revert this (MY_PN, dependency) this ebuild works with 0.15.
Comment 11 Jan Buecken 2010-10-19 14:17:51 UTC
Created attachment 251259 [details]
files/...

Add this to the files directory since the installation guide is not in the 1.00-rc1 tarball.
Comment 12 Jan Buecken 2010-10-19 14:21:28 UTC
Created attachment 251261 [details]
sys-auth/upekbsapi-bin ebuild

very the same as that of caspar, but I renamed upek-bin to upekbsapi-bin to make a difference to other upek products. (for example their authentication modul you can find get from there webside)
Comment 13 Oliver Deppert 2010-10-26 12:30:49 UTC
Thanks to Jan for the two ebuilds! It runs quiet very well out-of the box. I've installed your two ebuilds and changed pam.d/system-auth according the official manual.

login, su and gksu etc. works very well. But I've got some problems setting up fingerprint-reader-gui with gdm. I thought, that changing system-auth is enough, but gdm doesn't show the GUI.

Do you know a workaround for GDM?

Thanks, Olli

Comment 14 Jan Buecken 2010-10-28 07:29:18 UTC
> 
> Do you know a workaround for GDM?
> 

I use gdm, too, but I have no solution. We can discuss this in a gentoo forum or the fingerprint-gui forum, not in this bugzilla. If you file a post there, link please :-)

Comment 15 Ken Rice 2010-11-02 22:46:24 UTC
Fingerprint GUI 1.00-rc2 has been released:
http://darkblue.homeip.net/fingerprint/Forum/topic.php?TopicId=75

Note that the last posts on that page are in reference to issues with kdm, and
W.U. makes reference: "This is an issue of KDM. The same was reported for earlier GDM versions (see post from Jean-Pierre Flori). I can  activate the workaround for it in the next version again. Please wait for 1.00-rc3 coming soon."
Comment 16 Jan Buecken 2010-11-03 11:23:30 UTC
(In reply to comment #15)
> Fingerprint GUI 1.00-rc2 has been released:
> http://darkblue.homeip.net/fingerprint/Forum/topic.php?TopicId=75

Renaming my ebuild ...rc1... to ...rc2... works for me, so I dont write a new one. 
I have to mention a hint for your security: Adding
auth sufficient pam_fingerprint-gui.so --debug
to /etc/pam.d/system-auth enables fingerprint authetication FOR ALL PAM services using system-auth.
Following "Install-step-by-step.html" instead of the einfo in the ebuild let you enable fingerprint authentication for the PAM service you want only 

(copy system-auth to "whatyouwont-auth", e.g. fingerprint-auth, add the line
auth sufficient pam_fingerprint-gui.so --debug
there and replace the
auth ? system-auth
lines with 
auth ? fingerprint-auth
in your PAM service file)

Is it common in gentoo that ebuilds does such changes (e.g. with useflags for every PAM service, etc-update for PAM service) or should a user follow the manual himself, like now? 
Comment 17 Oliver Deppert 2010-12-03 21:54:32 UTC
(In reply to comment #14)
> > 
> > Do you know a workaround for GDM?
> > 
> 
> I use gdm, too, but I have no solution. We can discuss this in a gentoo forum
> or the fingerprint-gui forum, not in this bugzilla. If you file a post there,
> link please :-)
> 
He Jan,

I've seen rc3 is out now, but this time just changing the ebuild from rc2 to rc3 isn't enough...I had succes with emerging qt-polkit before emerging rc3....build was fine, but only login and console su works...with graphical environment rc3 didn't show the gui...

nevertheles, I've postet in the fingerprint-gui forum in order to discuss a workaround for rc2 concerning the gdm problem talked before. Link is:
http://darkblue.homeip.net/fingerprint/Forum/topic.php?TopicId=79&Posts=8

best regards,
Olli
Comment 18 Jan Buecken 2010-12-07 07:54:14 UTC
(In reply to comment #17)


> 
> I've seen rc3 is out now, but this time just changing the ebuild from rc2 to
> rc3 isn't enough...I had succes with emerging qt-polkit before emerging
> rc3....build was fine, 

I'm busy in those days to test this, but it seems to me that it makes sence because a fingerprint-polkit-agent is a new fetaure (see website).

>but only login and console su works...with graphical
> environment rc3 didn't show the gui...

I'm too busy to test...

> 
> nevertheles, I've postet in the fingerprint-gui forum in order to discuss a
> workaround for rc2 concerning the gdm problem talked before. Link is:
> http://darkblue.homeip.net/fingerprint/Forum/topic.php?TopicId=79&Posts=8

You posted this rc2 question in the threat with rc3 topic, not common... 
But you got an answer. I have not the time to test, as mentioned.

Comment 19 Alexey Shvetsov gentoo-dev 2010-12-09 20:01:27 UTC
I'll import it in my overlay and them may be will move to tree
Comment 20 Jan Buecken 2011-01-14 00:15:58 UTC
Created attachment 259752 [details]
sys-auth/fingerprint-gui-1.00 stable release ebuild

The stable version fingerprint-gui-1.00 is out. It works now with the gdm greeter (I think we have to thank Oliver for that. He contacted Wolfgang Ullrich.)
I don't now what to do with the new variable LIBPOLKIT_QT (see changelog or this forum entry: http://darkblue.homeip.net/fingerprint/Forum/topic.php?TopicId=84&Posts=2) For me it builds fine with polkit-qt-0.96.1.

Thus I think (as it is a stable release) fingerprint-gui can go into portage now.

ebuild changelog:
+ version bump
+ code cleanup (deleted unessecary stuff and changed the elog messages at the end)
+ You don't need files/Install-step-by-step.html. This file is shared with the package and thus installed from that location with some other docs.
Comment 21 vekin 2011-01-29 09:22:46 UTC
It won't save fingerprints for me.


Jan 29 01:21:45 [fingerprint-gui] Started.
Jan 29 01:21:45 [fingerprint-gui] Proprietary lib "libbsapi.so" loaded.
Jan 29 01:21:45 [fingerprint-gui] Devices initialized.
Jan 29 01:21:46 [fingerprint-gui] initializing libbsapi device (vend/prod) 0x147e/0x1000
Jan 29 01:21:46 [fingerprint-gui] initializing libfprint device (vend/prod) 0x147e/0x1000, driver: upeksonly
Jan 29 01:21:48 [fingerprint-gui] ERROR: Could not find /usr/local/lib/fingerprint-gui/fingerprint-suid.
                - Last output repeated 12 times -
Jan 29 01:21:58 [fingerprint-gui] Stopping device...
Jan 29 01:21:58 [fingerprint-gui] ABSEnroll() failed.
Jan 29 01:21:58 [fingerprint-gui] Stopped.
Jan 29 01:21:58 [fingerprint-gui] Devices released.
Comment 22 vekin 2011-01-29 10:40:44 UTC
Created attachment 260981 [details, diff]
Fixes a library that fails to install.

Sorry if I made the patch wrong its my first time.
The fingerprint-suid fails to install without this change and the program will not be able to save fingerprints.
Comment 23 Jan Buecken 2011-01-31 23:13:35 UTC
(In reply to comment #21)

> Jan 29 01:21:48 [fingerprint-gui] ERROR: Could not find
> /usr/local/lib/fingerprint-gui/fingerprint-suid.

Thats interesting: I have not this problem after upgrading from the 1.00-rc3. (even if the fingerprint-suid goes to /usr/lib64/... instead of /usr/local/lib64/...). But this bug is known
http://darkblue.homeip.net/fingerprint/Forum/topic.php?TopicId=87&Posts=4

I will try a clean reinstall to reproduce this problem.

(In reply to comment #22)
> Created an attachment (id=260981) [details]
> Fixes a library that fails to install.
> 
> Sorry if I made the patch wrong its my first time.
> The fingerprint-suid fails to install without this change and the program will
> not be able to save fingerprints.
> 

You deleted the request
-isEmpty(PREFIX) {
-	PREFIX = /usr
-}
in your patch. This could make a problem if somebody wants to change the default path (e.g. with a parameter). Wolfgang Ulrich recommends:

>>Sorry. This is a bug in the "fingerprint-suid.pro" file.
Please change line 7 in "./bin/fingerprint-suid/fingerprint-suid.pro" to
"PREFIX=/usr/local".

Then remove all Makefiles and build it all again.

W.U.<<


Comment 24 Jan Buecken 2011-02-01 09:43:16 UTC
Created attachment 261226 [details]
fixed ebuild: apply patch fingerprint-gui-1.00-suid-pathfix.patch

Copy this ebuild to your sys-auth/fingerprint-gui/ directory in your overlay and the following patch to your "sys-auth/fingerprint-gui/files" directory (create it, if necessary). This fixes the bug mentioned by venkin in comment #21.

Notice that this package is bundled with a new version of libbsapi (BSAPI_4.0.0218Lite_RC_for_Linux), but I will not write a new ebuid for a release cadidate. Try to change 0.15 to 1.00 in the upekbsapi-bin ebuild (not tested). 

Can anyone confirm that it is legal to steal the direct link to the upek libbsapi from their website? (Then I can write a ebuild with the real source).
Comment 25 Jan Buecken 2011-02-01 09:45:52 UTC
Created attachment 261228 [details, diff]
fixes path for fingerprint-suid

Use this with the ebuild from 2011-02-01.
Comment 26 Jan Buecken 2011-05-23 11:33:02 UTC
Created attachment 274389 [details]
Fix build with >=polkit-qt-0.99.0

The new ebuild uses has_version to determine if >=polkit-qt-0.99.0 is installed. Then qmake needs LIBPOLKIT_QT=LIBPOLKIT_QT_1_1 as argument.
See http://www.n-view.net/Appliance/fingerprint/ .

By the way, if a gentoo documentation author looks into this bug:
The example at
http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=1
for has_version in the description is wrong:
has_version >=... 
does not work, it needs quote signs ' , for instance
has_version '>=...'.

I'm too lazy to open a own bug for it.
Comment 27 Jan Buecken 2011-05-23 12:02:48 UTC
I just saw that Alexey provides an updated ebuild in his overlay. But it depends on >=sys-auth-polkit-qt-0.99.0 (the ebuild uses LIBPOLKIT_QT=LIBPOLKIT_QT_1_1 always, and I can't see this dependecy in the DEPEND variable... oO. I believe it won't work with 0.96.1)

And even there is the upekbsapi useflag, the ebuild does not care: It installs the blob always. I think this is not a good idea: fingerprint-gui works with other chipsets, too. And the blob is a runtime dependency (RDEPEND), as far as I can see. And not all people with a upek chipset wants to use the blob, maybe, because they need to accept the UPEK_EULA. (By the way: This should be handled by the upekbsapi-bin ebuild, maybe. There exists the ACCEPT_LICENSE variable, if necessary. With this one can use the original source for the blob, maybe.)

And I found a typo in the elog messages:
"followingline" instead of "following line".
Comment 28 Jan Buecken 2011-05-23 12:10:08 UTC
Created attachment 274395 [details]
Fix build and useflag handling

I fixed the upekbsapi useflag usage in my own ebuild. Here it is.
Comment 29 Jason Lamb 2012-01-21 17:50:13 UTC
Thanks for providing this ebuild since fingerprint-gui and upek's binary blob seem to be the only combo that supports my laptop's Upek 147e:1001 reader.

I initially used alexxy's overlay to install fingerprint-gui-1.00 and the upekbsapi-bin blob, and it worked well. I needed to rebuild my system from scratch, only to discover that the ebuilds were removed from the overlay. I installed this bugzilla version in my local overlay and upon attempting to emerge it, it always fails with;

"chmod: cannot access `/tmp/portage/sys-auth/fingerprint-gui-1.00/image//usr/local/lib/fingerprint-gui/fingerprint-suid': No such file or directory"

Build log is at;

http://pastebin.com/DkFVGt2K

I then copied the last copy of alexxy's overlay ebuilds for both fingerprint-gui and upekbsapi-bin to my local overlay and tried installing fingerprint-gui from there, and fails with a similar error;

"chmod: cannot access `/tmp/portage/sys-auth/fingerprint-gui-1.00/image///usr/libexec/fingerprint-gui/fingerprint-suid': No such file or directory"

Build log is at;

http://pastebin.com/73itJvFK

Any pointers are appreciated. Lastly, fingerprint-gui has been updated to 1.03, and it would be great if the ebuild could be updated accordingly. Thanks again..
Comment 30 Jan Buecken 2012-01-29 16:26:06 UTC
Created attachment 300287 [details]
ebuild for version 1.03

Ebuild for version 1.03. Added some dependecies refering to the README. This version does not need the fingerprint-suid fix. It is the default now.

It works for me. I cannot reproduce the "chmod" error above.
Comment 31 Jason Lamb 2012-01-29 19:40:48 UTC
I cannot get this fingerprint-gui-1.0.3 to build either. See similar errors as previously reported in the build log at;

http://pastebin.com/zqANkaMf

I'm not sure if there's an error in my system configuration anywhere, or I have something left over from previous installs that's causing my problem here, or what. I'm going to try and clean out my system of any previous fingerprint-gui related files, (including fingerprint scan), and see if I can succeed in installing this cleanly.

(P.S. thanks for the 1.0.3 ebuild..)
Comment 32 Jan Buecken 2012-01-29 21:58:33 UTC
Maybe it is a problem with parallel build.

Does it work with MAKEOPTS="-j1" in /etc/make.conf?

Or you can test
MAKEOPTS="${MAKEOPTS} -j1"
in the ebuild itself. (I don't know if this is the usual way to disallow parallel build for one package).
Comment 33 Jason Lamb 2012-01-29 23:01:19 UTC
[facepalm] My bad.. I should have tried that first before even commenting. The command;

MAKEOPTS="-j1" emerge -v fingerprint-gui

did finally allow me to install the package correctly. Thank you.

BTW, the step by step documentation filename has apparently changed so the following line from the ebuild;

elog "1) Please see /usr/share/doc/${P}/Install-step-by-step.html to configure your device."

can be changed to;

elog "1) Please see /usr/share/doc/${P}/Step-by-step-manual.html to configure your device."

Thanks again..
Comment 34 Jason Lamb 2012-01-30 14:12:23 UTC
After being able to emerge fingerprint-gui-1.03 into my system, I experienced a segfault when attempting to run fingerprint-gui -d. At the developer's forums there has been reported a bug, (possibly related to a newer glibc), that can be fixed by making a small edit to one of the source files.

The two relevant bug reports and fix are posted at;

http://darkblue.homeip.net/fingerprint/Forum/topic.php?TopicId=197&Posts=1
http://darkblue.homeip.net/fingerprint/Forum/topic.php?TopicId=194&Posts=3

I performed the manual ebuild steps of first ebuild [path/to/ebuild] unpack. Then I edited the src/DeviceHandler.cpp file referenced in the bug report. I then ran ebuild [path/to/ebuild] compile, install and then qmerge. Now fingerprint-gui -d works correctly.

I was less capable when trying to create a patch for this ebuild for this issue. Perhaps a more experienced dev can create the patch necessary and attach it to this bug report.

Thanks..
Comment 35 Jan Buecken 2012-01-30 22:02:18 UTC
Created attachment 300475 [details, diff]
fix segfault in version 1.03

Put this in the files/ directory in the overlay. use it with the following ebuild.
Comment 36 Jan Buecken 2012-01-30 22:10:02 UTC
Created attachment 300479 [details]
ebuild for version 1.03 (r1)

This ebuild fixes the segfault bug and force MAKEOPTS="${MAKEOPTS} -j1" to forbid parallel build (see bug above).

BTW: To create patches, "diff -Naur ..." is a friend. You can apply patches with "patch" manually.
Comment 37 Michael Weber (RETIRED) gentoo-dev 2012-05-19 14:49:41 UTC
Please don't refer to build.logs on pastebins, all the links are dead now.

Is there any reason to DEPEND on 
	!sys-auth/pam_fprint
	!sys-auth/fprintd
	!sys-auth/thinkfinger
not beeing installed? 
I see the point in not having them configured in the pam system, but are there any file collisions?
Comment 38 Michael Weber (RETIRED) gentoo-dev 2012-05-20 16:09:35 UTC
Whats the point of installing the same tarball as 
upeksbapi-bin package? 

Were did you fetch that UPEK_EULA license file? I'd add it to portage/licenses.
LICENSE="GPL-2 upeksbapi? ( UPEK_EULA )" should work.
Comment 39 Jan Buecken 2012-05-20 21:30:26 UTC
(In reply to comment #37)

> Is there any reason to DEPEND on 
> 	!sys-auth/pam_fprint
> 	!sys-auth/fprintd
> 	!sys-auth/thinkfinger
> not beeing installed? 
> I see the point in not having them configured in the pam system, but are
> there any file collisions?

I have this dependency from the step-by-step manual that is shipped with the tarball. 

See
http://www.n-view.net/Appliance/fingerprint/doc/Step-by-step-manual.html#id319198
(Section: Conflicting Software)

By the way: In 1.04 the above fix is not needed anymore.
Comment 40 Jan Buecken 2012-05-20 21:52:41 UTC
(In reply to comment #38)
> Whats the point of installing the same tarball as 
> upeksbapi-bin package? 
> 
> Were did you fetch that UPEK_EULA license file? I'd add it to
> portage/licenses.
> LICENSE="GPL-2 upeksbapi? ( UPEK_EULA )" should work.

The problem is, that the developer of fingerprint-gui ship the upekbsapi with his tarball, but I don't know if he is allowd to do this.

Some time ago, you could find upekbsapi at 
http://www.upek.com/solutions/pc_and_networking/sdks/linux/ 
(see http://www.n-view.net/Appliance/fingerprint/about.php, too) 
and you need a registration to download the upekbsapi sdk (similar to vmware). But it seems this link is not correct anymore and I did not find a up-to-date one.
Comment 41 Jan Buecken 2012-05-20 22:05:22 UTC
(In reply to comment #38)
> Were did you fetch that UPEK_EULA license file?

It was shipped with fingerprint-gui-0.15 tarball. 
It seems that it has been removed anywhere between 0.16 and fingerprint-gui-1.04.
Comment 42 Michael Weber (RETIRED) gentoo-dev 2012-05-21 01:55:57 UTC
+*fingerprint-gui-1.04 (21 May 2012)
+
+  21 May 2012; Michael Weber <xmw@gentoo.org> +fingerprint-gui-1.04.ebuild,
+  +metadata.xml:
+  Initial import (bug 341105, big thanks to Jan Buecken, Jason Lamb, Oliver
+  Deppert)
+