Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 340725 - gnome-base/gnome-applets-2.32.0: QA Notice: invalid .la file found: usr/share/xmodmap/xmodmap.la
Summary: gnome-base/gnome-applets-2.32.0: QA Notice: invalid .la file found: usr/share...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS, REGRESSION
Depends on:
Blocks: 335925 gnome2.32
  Show dependency tree
 
Reported: 2010-10-12 17:41 UTC by Pacho Ramos
Modified: 2010-10-21 18:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2010-10-12 17:41:10 UTC
I don't know how to handle this since xmodmap.la is not a libtool file, but a latinoamerican keyboard

Any ideas?

Reproducible: Always
Comment 1 Gilles Dartiguelongue gentoo-dev 2010-10-20 22:26:49 UTC
didn't get this message but in anycase it is wrong. The package manager needs to be told not to check for random la files.
Comment 2 Zac Medico gentoo-dev 2010-10-21 02:07:38 UTC
We need to fix portage to skip files that don't have "a libtool library file" on the first line.
Comment 4 Gilles Dartiguelongue gentoo-dev 2010-10-21 11:55:05 UTC
Thanks very much zac.
Comment 5 Zac Medico gentoo-dev 2010-10-21 17:18:29 UTC
This is fixed in 2.1.9.21 and 2.2_rc99.
Comment 6 Robert Bradbury 2010-10-21 17:59:20 UTC
I don't know whether this falls under gnome-applets or not but until "gvfs-gdu-volume-monitor" is fixed so it does not core dump every time one logs in and until non-root users can access both volume controls and sound-player activity there is no way that gnome-2.32 is fit for release.

There has been a serious decline in the quality of gnome sound management (in short it doesn't work for non-root users). over the last upgrade cycle.  Fix it or witness people downgrading to releases that work or migrating to Ubuntu.

Sound and volume control work or they do not.  You can either assert that they do or they don't.
Comment 7 Zac Medico gentoo-dev 2010-10-21 18:13:01 UTC
(In reply to comment #6)
I guess you meant to comment on bug 339225, the current bug is only tangentially related to gnome.