Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 340064 - portage fails to resolve trivial blocker
Summary: portage fails to resolve trivial blocker
Status: RESOLVED DUPLICATE of bug 250286
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-07 12:54 UTC by Victor Mataré
Modified: 2010-10-08 13:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Mataré 2010-10-07 12:54:38 UTC
When updating, I get this:

[ebuild     U ] media-video/vlc-1.1.4 [1.0.6] USE="kde%* -libv4l% -projectm% -sqlite% -vaapi%" 
[blocks B     ] <=media-video/vlc-1.0.99999 ("<=media-video/vlc-1.0.99999" is blocking media-video/vlc-1.1.4)                                                                                 

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-video/vlc-1.1.4, ebuild scheduled for merge) pulled in by
    media-video/vlc required by (virtual/matare-desktop-0.5.3, installed)

Now the virtual doesn't care if vlc is 1.1.4 or 0.9 or whatever. So portage should just install and then reinstall vlc like it does in many other scenarios. Actually I don't see why it shouldn't work in this situation. BTW, what's the matter with these vlc blockers, anyway? They're not slotted, thus can't be installed simulateously, so why block at all?
Comment 1 Victor Mataré 2010-10-07 12:55:58 UTC
sorry, I meant to say "portage should UNinstall and then reinstall"
Comment 2 Samuli Suominen gentoo-dev 2010-10-07 13:17:42 UTC
vlc has a hard blocker !! to itself on purpose, to avoid old vlc being installed when new one is compiling (so it won't use the installed parts for the new compilation from system)



*** This bug has been marked as a duplicate of bug 277430 ***
Comment 3 Victor Mataré 2010-10-08 12:51:07 UTC
Thanks for that info. However the reason for the blocker was only a side question. This bug is actually about portage's depency conflict resolver, which I think should automatically decide to uninstall and then reinstall vlc. So I'll reopen it if you don't mind.
Comment 4 Zac Medico gentoo-dev 2010-10-08 13:05:43 UTC

*** This bug has been marked as a duplicate of bug 250286 ***