Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 277430 - media-video/vlc-1.0.0 should block previous versions BEFORE build-time
Summary: media-video/vlc-1.0.0 should block previous versions BEFORE build-time
Status: RESOLVED DUPLICATE of bug 270953
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-11 12:19 UTC by Allen Brooker (AllenJB)
Modified: 2010-10-07 13:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Allen Brooker (AllenJB) 2009-07-11 12:19:00 UTC
>>> Emerging (17 of 19) media-video/vlc-1.0.0
 * vlc-m4-1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                         [ ok ]
 * vlc-1.0.0.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                        [ ok ]
 * vlc-patches-63.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                   [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                        [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                       [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                      [ ok ]
 * Please unmerge vlc-0.9.x first before installing vlc-1.0.0
 * If you don't do that, some plugins will get linked against
 * the old vlc version and will not work.
 *
 * ERROR: media-video/vlc-1.0.0 failed.

media-video/vlc-1.0.0 should block previous versions in the dependencies rather than at build-time. Even if emerge isn't able to automatically resolve the blocker, this would enable the block to be manually resolved before build-time, preventing a world update from only partially completing.
Comment 1 Samuli Suominen gentoo-dev 2009-07-12 14:29:14 UTC
vlc links at build time to the libraries of installed vlc and 2.2_rc33 of portage tries to handle it automatically leading the end result of vlc broken..

don't think it can be done
Comment 2 Samuli Suominen gentoo-dev 2009-07-12 22:52:09 UTC

*** This bug has been marked as a duplicate of bug 270953 ***
Comment 3 Samuli Suominen gentoo-dev 2010-10-07 13:17:42 UTC
*** Bug 340064 has been marked as a duplicate of this bug. ***