Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 339725 - media-sound/lmms fails to build remote_vst_plugin: winebuild: as --32 failed with status 1
Summary: media-sound/lmms fails to build remote_vst_plugin: winebuild: as --32 failed ...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-04 16:58 UTC by Michael
Modified: 2017-10-13 21:08 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,81.46 KB, text/plain)
2010-10-04 16:58 UTC, Michael
Details
emerge --info (emerge.info,4.51 KB, text/plain)
2010-10-08 18:47 UTC, Michael
Details
Build log for lmms-0.4.10 (build.log,45.93 KB, text/plain)
2011-04-08 17:14 UTC, Marc Joliet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2010-10-04 16:58:28 UTC
lmms does not build without fltk installed yet it does not have fltk as a dependency.

Reproducible: Always
Comment 1 Michael 2010-10-04 16:58:57 UTC
Created attachment 249555 [details]
build.log
Comment 2 Michael 2010-10-04 17:01:01 UTC
Incase someone wants to test it: Current masked wine-version together with lmms +vst also seems to cause problems. Lmms uses wine to implement a vst-plugin. I was not really able to nail down the constallation it fails, thus I did not create a new bugreport.
Comment 3 Jeroen Roovers gentoo-dev 2010-10-05 19:07:00 UTC
Please post your `emerge --info' too.

By the way, it's not fltk that's failing, but it does show us a different problem, namely that lmms ships its own version of fltk:

jer@astrid /var/tmp/portage/media-sound/lmms-0.4.7/work/lmms-0.4.7/plugins/zynaddsubfx/
fltk $ grep FLTK_VERSION_ CMakeLists.txt                                               
set(FLTK_VERSION_MAJOR "1")
set(FLTK_VERSION_MINOR "3")
set(FLTK_VERSION_PATCH "0")
set(FLTK_VERSION "${FLTK_VERSION_MAJOR}.${FLTK_VERSION_MINOR}")
set(FLTK_VERSION_FULL "${FLTK_VERSION}.${FLTK_VERSION_PATCH}")

In fact it fails much earlier on in the build process:

[0m-- Check for working C compiler: /usr/lib64/ccache/bin/gcc
[31m[1mLinking CXX shared module libtripleoscillator.so
[0m[ 27%] Built target stereomatrix
winebuild: as --32 failed with status 1
winegcc: winebuild failed
make[2]: *** [plugins/vst_base/remote_vst_plugin] Fehler 2
make[1]: *** [plugins/vst_base/CMakeFiles/vstbase.dir/all] Fehler 2
make[1]: *** Warte auf noch nicht beendete Prozesse...

It looks like it's trying to use a 64-bit compiler as winegcc. Also, you're using ccache - please try again with ccache off for good measure.

Assigning now because there's enough issues to act on already.
Comment 4 Michael 2010-10-08 18:47:35 UTC
Created attachment 249969 [details]
emerge --info

I based my assumption on the fact that the moment I installed fltk myself, it compiled correctly.

With ccache disabled I unmereged fltk-2.0_pre6970-r1 (emerge -avC fltk) and tried to reinstall lmms-0.4.7 which strangely worked... =( This is rather confusing... since it would mean that the fltk package left something behind except configs that causes lmms to compile.

Maybe in a few days I will backup my lmms config and unmerege fltk, lmms with noconfmem and clear all caches and such, trying to disect this more propperly. Sorry, am a bit short on time currently.
Comment 5 Jeroen Roovers gentoo-dev 2010-10-11 19:20:56 UTC
(In reply to comment #4)
> Created an attachment (id=249969) [details]
> emerge --info
> 
> I based my assumption on the fact that the moment I installed fltk myself, it
> compiled correctly.
> 
> With ccache disabled I unmereged fltk-2.0_pre6970-r1 (emerge -avC fltk) and
> tried to reinstall lmms-0.4.7 which strangely worked... =( This is rather
> confusing... since it would mean that the fltk package left something behind
> except configs that causes lmms to compile.

See bug #339882: The system fltk isn't used at all (when it really should). That you had fltk remnants in your ccache may however have triggered something in the lmms build system, though.
Comment 6 Alexis Ballier gentoo-dev 2011-01-02 13:12:20 UTC
Summary for version 0.4.9:
==========================

...

* VstBase: fixed winelib build on x86_64


please reopen if this still fails for you
Comment 7 Marc Joliet 2011-04-08 17:13:23 UTC
I still get failures with lmms-0.4.9, 0.4.9-r3 and 0.4.10 (so I would say all versions are problematic). I am not sure whether it is the same bug, but it is still in RemoteVstPlugin. The error seems to be the same for all versions (see also build.log):

Scanning dependencies of target zynaddsubfx_synth
[ 18%] Generating embedded_resources.h
[ 19%] Generating moc_vibed.cxx
[ 19%] Building CXX object plugins/zynaddsubfx/src/Synth/CMakeFiles/zynaddsubfx_synth.dir/ADnote.o
Scanning dependencies of target vibedstrings
/usr/bin/ld: Relocatable linking with relocations from format elf64-x86-64 (/usr/lib64/wine/libwinecrt0.a(exe_entry.o)) to format elf32-i386 (RemoteVstPlugin.IbdaUi.o) is not supported
winebuild: /usr/bin/ld -m elf_i386 -r failed with status 256
winegcc: winebuild failed
make[2]: *** [plugins/vst_base/RemoteVstPlugin] Error 2
make[1]: *** [plugins/vst_base/CMakeFiles/vstbase.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

--------------------------------------------------------------------

# emerge --info lmms
Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.11.3-r0, 2.6.38-gentoo-r1 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.38-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-gentoo-2.0.2
Timestamp of tree: Thu, 07 Apr 2011 20:15:01 +0000
app-shells/bash:     4.1_p9
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.0
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/share/config/kdm /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect distlocks fixlafiles fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://mirror.muntinternet.net/pub/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en en_GB de"
MAKEOPTS="-s -j3"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-9"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/pcsx2 /usr/local/portage/layman/science /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib accessibility acl acpi alsa amd64 audiofile avahi bash-completion berkdb blas branding bzip2 cairo caps cdda cdinstall cdr chipcard cjk cli consolekit cracklib crypt css cups cxx dbus dga djvu dri dssi dts dvd dvdnav dvdr dvi encode exif fbcon ffmpeg fftw flac fortran ftp fuse gdbm gif gimp glitz glut gmp gnuplot gnutls gpm gtk hbci iconv idn imlib inotify ipv6 jack jpeg jpeg2k kipi ladspa lapack lash latex lcms libcaca libnotify libsamplerate lm_sensors logrotate lzma mad matroska mikmod mjpeg mmx mmxext mng modplug modules mp3 mp4 mpeg mudflap multilib musepack musicbrainz ncurses nfs nls nntp nptl nptlonly nsplugin ntp offensive ogg openal openexr opengl openmp pam pango pcre pdf plotutils png policykit ppds pppd pulseaudio python qt4 quicktime rar readline rtsp samba sasl schroedinger sdl session sid slang slp smp sndfile speex spell sse sse2 sse3 ssl startup-notification svg sysfs taglib tcpd theora threads tiff timidity truetype unicode usb vaapi vcd vim-syntax vorbis vpx webkit wma x264 xattr xcb xcomposite xface xft xml xmp xorg xpm xscreensaver xulrunner xv xvid xvmc zeroconf zlib zsh-completion" ALSA_CARDS="ice1724 hda-intel usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en en_GB de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-sound/lmms-0.4.9 was built with the following:
USE="alsa fftw fluidsynth jack (multilib) ogg pulseaudio sdl vst -debug -stk"
Comment 8 Marc Joliet 2011-04-08 17:14:25 UTC
Created attachment 269053 [details]
Build log for lmms-0.4.10
Comment 9 Marc Joliet 2011-04-08 17:31:09 UTC
Oh, and since the emerge output requested it, here:

# emerge -pqv \=media-sound/lmms-0.4.10 
[ebuild     U ] media-sound/lmms-0.4.10 [0.4.9] USE="alsa fftw fluidsynth jack ogg pulseaudio sdl vst -debug -portaudio% -stk"

Note that at one point, I could install lmms-0.4.9. That was in January:

# genlop -t lmms
     [...]
     Wed Jan  5 15:16:09 2011 >>> media-sound/lmms-0.4.9
       merge time: 6 minutes and 36 seconds
Comment 10 Marc Joliet 2011-04-19 16:10:52 UTC
Since the OP hasn't reopened, I'll do so.
Comment 11 Jonathan Aquilina 2014-04-23 07:08:35 UTC
Please note that as of lmms 1.0 VST's on 64bit systems have been disabled.
Comment 12 Jonathan Aquilina 2014-04-23 07:23:32 UTC
(In reply to Jonathan Aquilina from comment #11)
> Please note that as of lmms 1.0 VST's on 64bit systems have been disabled.

The above is incorrect. VST support does get built on 64bit systems, but there is a catch 22 of needing a 32bit version of wine.