Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 339347 - dev-python/m2crypto-0.20.2: non-prefixed /usr/include path used
Summary: dev-python/m2crypto-0.20.2: non-prefixed /usr/include path used
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
: 376715 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-01 12:37 UTC by Marc Hulsman
Modified: 2014-01-14 19:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fixes build problems under gentoo prefix (fix_prefix_m2crypto.patch,341 bytes, patch)
2010-10-20 17:02 UTC, Marc Hulsman
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Hulsman 2010-10-01 12:37:38 UTC
m2crypto fails due to wrong include path:

swig -python -I/data/home/mhulsman/gentoo/usr/include/python2.6 -I/usr/include -includeall -o SWIG/_m2crypto_wrap.c SWIG/_m2crypto.i
SWIG/_m2crypto.i:31: Error: Unable to find 'openssl/opensslv.h'


This path is set in setup.py using:

self.openssl = '/usr'
opensslIncludeDir = os.path.join(self.openssl, 'include')


Reproducible: Always
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-10-20 14:54:57 UTC
Do you happen to have a patch ready?
Comment 2 Marc Hulsman 2010-10-20 17:02:11 UTC
Created attachment 251349 [details, diff]
Fixes build problems under gentoo prefix

Sorry for not preparing a patch earlier, I was a bit busy at the time. The attached patch fixes the problem for me.
Comment 3 Marc Hulsman 2010-10-20 18:27:59 UTC
I just realized that using _ in sed could cause problems for those with _ in ${EPREFIX}. Better choices are probably : or |, which will normally not be used as part of a directory name.

Comment 4 Michael Yang 2011-04-27 14:34:55 UTC
this bug is also happening on m2crypto-0.21.1
Comment 5 Michael Yang 2011-04-27 14:36:19 UTC
(for reference)

$ emerge =m2crypto-0.21.1
...
SWIG/_ec.i:7: Error: Unable to find 'openssl/opensslconf.h'
error: command 'swig' failed with exit status 1
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-04-27 14:49:21 UTC
Well, this one clearly slipped through the cracks....

"sed patch" is fine, but it would be great if it wasn't hardcoded to begin with. Anyone interested in taking this issue upstream? http://chandlerproject.org/Projects/MeTooCrypto#Contributing
Comment 7 yegle 2011-07-29 01:07:25 UTC
https://bugzilla.osafoundation.org/show_bug.cgi?id=12634

This is in upstream's bugzilla.
Comment 8 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-07-29 01:33:54 UTC
*** Bug 376715 has been marked as a duplicate of this bug. ***
Comment 9 Fabian Groffen gentoo-dev 2014-01-14 19:36:25 UTC
the ebuild deals with this by manually running swig now