Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 331287 - www-apache/passenger fails to respect CC, CXX and LDFLAGS (patch provided)
Summary: www-apache/passenger fails to respect CC, CXX and LDFLAGS (patch provided)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Apache Team - Bugzilla Reports
URL:
Whiteboard:
Keywords:
: 410673 (view as bug list)
Depends on:
Blocks: ldflags
  Show dependency tree
 
Reported: 2010-08-05 08:58 UTC by Olivier Huber
Modified: 2012-04-03 17:09 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch (passenger.patch,1.02 KB, patch)
2010-08-05 09:03 UTC, Olivier Huber
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Huber 2010-08-05 08:58:19 UTC
from build.log
QA Notice: Files built without respecting LDFLAGS have been detected
 Please include the following list of files in your report:
/usr/lib/phusion_passenger/ApplicationPoolServerExecutable
/usr/lib64/apache2/modules/mod_passenger.so

emerge --info www-apache/passenger
Portage 2.2_rc67 (hardened/linux/amd64/10.0, gcc-4.3.4, glibc-2.11.2-r0, 2.6.32-hardened-r9 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.32-hardened-r9-x86_64-Intel-R-_Celeron-R-_CPU_220_@_1.20GHz-with-gentoo-2.0.1
Timestamp of tree: Thu, 05 Aug 2010 01:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.7.9-r2, 1.8.5-r4, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fforce-addr"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -fforce-addr"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict test test-fail-continue unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles ftp://mirror.ovh.net/gentoo-distfiles"
LANG="fr_FR.utf-8"
LC_ALL="fr_FR.utf-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common -Wl,--hash-style=gnu"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/local"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl amd64 apache2 bash-completion berkdb bzip2 caps cli courier cracklib crypt cups curl cxx dkim dovecot-sasl dri gd-external gdbm geoip gnutls gpgme hardened iconv icu idn imap ipv6 jpeg jpeg2k justify ldap ldap-sasl logrotate maildir managesieve mbox milter mmx modules mudflap multilib mysql ncurses nls nptl nptlonly openmp openssl pam pcre perl pic png pop pppd python razor readline reflection ruby sasl session sieve smime smtp soap spamassassin spell spl sqlite sqlite3 sse sse2 ssl suhosin svg sysfs syslog tcpd tiff tools unicode urandom vhosts vim-syntax xattr xml xorg xtended zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa via vmware voodoo" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

www-apache/passenger-2.2.15 was built with the following:
USE="(multilib) test -debug -doc" 
CFLAGS="-O2 -pipe -fforce-addr -fno-strict-aliasing"
CXXFLAGS="-O2 -pipe -fforce-addr -fno-strict-aliasing"
Comment 1 Olivier Huber 2010-08-05 09:03:09 UTC
Created attachment 241479 [details, diff]
patch

There're multiple ways to make it respect LDFLAGS, and I've picked this one because it's the shortest.
Comment 2 Hans de Graaff gentoo-dev 2011-12-26 11:51:36 UTC
I just bumped passenger to 3.0.11 and also fixed the CC and CXX settings similar to your patch. LDFLAGS was already fixed in passenger 3.0.0.

Apologies for the delay in fixing this!
Comment 3 Hans de Graaff gentoo-dev 2012-04-03 17:09:42 UTC
*** Bug 410673 has been marked as a duplicate of this bug. ***