Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 323373 - Stabilize =app-text/xdvik-22.84.16 (was: 22.84.14-r1 doesn't compile with gcc-4.4)
Summary: Stabilize =app-text/xdvik-22.84.16 (was: 22.84.14-r1 doesn't compile with gcc...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: TeX project
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 302468
  Show dependency tree
 
Reported: 2010-06-09 20:56 UTC by Alexander Bezrukov
Modified: 2010-07-10 13:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bezrukov 2010-06-09 20:56:16 UTC
After upgrading to sys-devel/gcc-4.4.3-r2, app-text/xdvik-22.84.14 (the latest
stable) isn't compile anymore.

app-text/xdvik-22.84.14-r1, which is ~arch-masked, also suffer from this
problem, but app-text/xdvik-22.84.16 doesn't.

Please stabilize app-text/xdvik-22.84.16


Reproducible: Always

Steps to Reproduce:
1. emerge =app-text/xdvik-22.84.14

Actual Results:  
In file included from /usr/include/fcntl.h:217,
                 from /usr/include/sys/file.h:25,
                 from util.c:33:
In function ‘open’,
    inlined from ‘xdvi_temp_fd’ at util.c:276:
/usr/include/bits/fcntl2.h:51: error: call to ‘__open_missing_mode’ declared with attribute error: open with O_CREAT in second argument needs 3 arguments
make: *** [util.o] Error 1
make: *** Waiting for unfinished jobs....
 * ERROR: app-text/xdvik-22.84.14 failed:
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  54:  Called src_compile
 *   environment, line 2770:  Called die
 * The specific snippet of code:
 *       emake kpathsea_dir="/usr/include/kpathsea" texmf="${TEXMF_PATH}" || die;
 * 
 * If you need support, post the output of 'emerge --info =app-text/xdvik-22.84.14',
 * the complete build log and the output of 'emerge -pqv =app-text/xdvik-22.84.14'.
 * The complete build log is located at '/tmp/portage/app-text/xdvik-22.84.14/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/app-text/xdvik-22.84.14/temp/environment'.
 * S: '/tmp/portage/app-text/xdvik-22.84.14/work/xdvik-22.84.14'


Expected Results:  
The package is built ok.

Portage 2.1.8.3 (default/linux/x86/10.0/desktop, gcc-4.4.3, glibc-2.10.1-r1, 2.6.32.14-x86-alb i686)
=================================================================
System uname: Linux-2.6.32.14-x86-alb-i686-Intel-R-_Core-TM-2_Duo_CPU_T5670_@_1.80GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 07 Jun 2010 04:15:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.2-r3
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.32
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA sun-bcla-java-vm dlj-1.1 skype-eula googleearth"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-combine -march=native -O3 -pipe -fomit-frame-pointer -finline-functions-called-once -ftree-vectorize -funroll-loops"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-combine -march=native -O3 -pipe -fomit-frame-pointer -finline-functions-called-once -ftree-vectorize -funroll-loops"
DISTDIR="/usr/share/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv usersync"
FFLAGS="-combine -march=native -msse -msse2 -msse3 -mmmx -m3dnow -O2 -pipe -fomit-frame-pointer -finline-functions-called-once -ftree-vectorize -fprefetch-loop-arrays"
GENTOO_MIRRORS="http://ftp.iij.ad.jp/pub/linux/gentoo/ http://gentoo.wetzlmayr.com/ http://gentoo.aditsu.net/ http://ftp.lecl.net/pub/gentoo/ http://gentoo.osuosl.org/"
LANG="en_US.utf8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="en ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.asia.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa bash-completion berkdb bidi bluetooth branding bzip2 cairo caps cdr cjk cli consolekit cracklib crypt cscope cxx dbus djvu dri dts dvd dvdr dvdread emboss encode eselect exif fam firefox flac fortran gdbm gif gmp gpm gtk hal hardened iconv ieee1394 jpeg jpeg2k laptop lcms ldap libnotify lm_sensors lock mad mikmod mmap mmx mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl pmu png ppds pppd python qt3support readline reflection samba sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd threads thunar tiff truetype unicode usb vorbis x264 x86 xcb xcomposite xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="*" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michael Weber (RETIRED) gentoo-dev 2010-06-09 21:04:52 UTC
Hello Alexander,

can you please attach the build.log of the failing compile, thanks.

Michael
Comment 2 Samuli Suominen gentoo-dev 2010-06-09 21:28:31 UTC
(In reply to comment #1)
> Hello Alexander,
> 
> can you please attach the build.log of the failing compile, thanks.
> 
> Michael
> 

No need, the problem is obviously same as in bug 283556. Please mark 22.84.16 stable that applies the required -open-mode.patch to fix this.
Comment 3 Alexander Bezrukov 2010-06-10 01:19:37 UTC
(In reply to comment #1)

Yes, the problem is exactly the same as in the Bug #283556
Comment 4 Pacho Ramos gentoo-dev 2010-06-24 21:45:29 UTC
amd64 stable
Comment 5 Samuli Suominen gentoo-dev 2010-07-03 23:49:40 UTC
ppc64 stable
Comment 6 Thomas Kahle (RETIRED) gentoo-dev 2010-07-04 08:20:31 UTC
Archtested on x86: Everything fine (YEAH MOTIF!)
Comment 7 Samuli Suominen gentoo-dev 2010-07-10 13:27:10 UTC
stabilized for everyone, enough noise about the broken versions