Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 323213 - portage doesnt clean up non-standard INFOPATHs (like sys-devel/binutils)
Summary: portage doesnt clean up non-standard INFOPATHs (like sys-devel/binutils)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 377153 (view as bug list)
Depends on:
Blocks: 373933
  Show dependency tree
 
Reported: 2010-06-08 16:03 UTC by Toralf Förster
Modified: 2018-12-05 00:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2010-06-08 16:03:02 UTC
While upgrading the package today I realized that of the older version one directory till remains :
tfoerste@n22 ~ $ ls -ld /usr/share/binutils-data/i686-pc-linux-gnu/*/info/dir 
-rw-r--r-- 1 root root 1908 Nov 23  2005 /usr/share/binutils-data/i686-pc-linux-gnu/2.16.1/info/dir
-rw-r--r-- 1 root root 1908 Jun 25  2007 /usr/share/binutils-data/i686-pc-linux-gnu/2.17/info/dir
-rw-r--r-- 1 root root 1991 Jan 28 09:01 /usr/share/binutils-data/i686-pc-linux-gnu/2.18/info/dir
-rw-r--r-- 1 root root 2884 Jun  8 17:25 /usr/share/binutils-data/i686-pc-linux-gnu/2.20.1/info/dir


Reproducible: Always
Comment 1 Michael Weber (RETIRED) gentoo-dev 2010-06-09 01:12:11 UTC
Hi,

can you please run `equery belongs ...` or `qfile ...` on these files and post the output, maybe they belong to some other ...

I can confirm this with /usr/share/binutils-data/x86_64-pc-linux-gnu/2.20/info/dir etc. And they don't belong to anything.

Reso/Wont?
Comment 2 Toralf Förster gentoo-dev 2010-06-09 07:34:39 UTC
This gives nothing :
tfoerste@n22 ~ $ ls /usr/share/binutils-data/i686-pc-linux-gnu/*/info/dir  | xargs -n 1 qfile

althought at least this is installed:

tfoerste@n22 ~ $ equery l binutils
 * Searching for binutils ...
[IP-] [  ] sys-devel/binutils-2.20.1-r1:0
Comment 3 SpanKY gentoo-dev 2010-06-10 03:55:36 UTC
binutils has nothing to do with the creation/management of that file
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2011-08-04 04:30:54 UTC
*** Bug 377153 has been marked as a duplicate of this bug. ***
Comment 5 Zac Medico gentoo-dev 2011-08-04 05:40:26 UTC
The INFOPATH settings come from /etc/env.d/05bintils, which is probably generated by binutils-config. When we're unmerging directories, we can check if they are in INFOPATH and if the "dir" file is the only remaining contents, and in that case we can remove it so that the parent will be unmerged.
Comment 7 SpanKY gentoo-dev 2011-08-06 10:15:01 UTC
i'm not sure about that.  sounds a bit sketchy.  since binutils-config already has an --uninstall option to clean up the stuff it generated, seems like it'd make sense to just add this to the list.
Comment 8 Zac Medico gentoo-dev 2011-08-06 11:11:08 UTC
I've made it tread any directory named "info" as a candidate:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=2c92ae3c7ddb903bcffe96046cebe8106439e86b
Comment 9 SpanKY gentoo-dev 2011-08-06 11:27:51 UTC
that i can live with ;)
Comment 10 Zac Medico gentoo-dev 2011-08-12 12:55:00 UTC
This is fixed in 2.1.10.11 and 2.2.0_alpha51.