Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 318985 - korganizer-4.3.5 terminates on startup with dbus error
Summary: korganizer-4.3.5 terminates on startup with dbus error
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Blocks: 313999
  Show dependency tree
Reported: 2010-05-08 19:00 UTC by Robert W.
Modified: 2010-07-09 20:50 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Robert W. 2010-05-08 19:00:45 UTC
When launching korgnizer it waits for 1:40min and than terminates with:

mary@belle-gunness ~ $ korganizer
<unknown program name>(16414)/: Communication problem with  "korganizer" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." "

I already looked into #296412 and #296506 and both do not resolve the problem here. I also tried launching with korganizerrc, remerged korganizer and remerged dbus.

Versions: kde-4.3.5, qt-4.6.1

Reproducible: Always

Steps to Reproduce:
1. launch korganizer

Expected Results:  
korganizer should start

Portage 2.2_rc67 (default/linux/powerpc/ppc32/10.0/desktop, gcc-4.4.3, glibc-2.10.1-r1, ppc)
System uname: Linux-,_altivec_supported-with-gentoo-1.12.13
Timestamp of tree: Sat, 08 May 2010 09:15:02 +0000
distcc 3.1 powerpc-unknown-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.6.3, 1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/gcc:       4.3.4, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
CFLAGS="-pipe -O2 -mtune=G4 -mcpu=G4 -mpowerpc-gfxopt -fno-strict-aliasing     -maltivec -mabi=altivec"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -mtune=G4 -mcpu=G4 -mpowerpc-gfxopt -fno-strict-aliasing     -maltivec -mabi=altivec"
FEATURES="assume-digests autoaddcvs ccache distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LINGUAS="de en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/gentopia /var/lib/layman/powerpc /var/lib/layman/sunrise /usr/local/portage"
USE="X a52 aac acl alsa altivec apm avahi bash-completion berkdb bluetooth bzip2 cairo caps cddb cdr cli consolekit cracklib crypt cscope cups cxx dbus doc dri dts dvd emacs emboss encode exif faac faad fam ffmpeg fftw firefox flac fortran gdbm gif gimp gpg gpm graphviz gtk hal htmlhandbook iconv id3tag idn ieee1394 imap ipod ipv6 java java5 jpeg jpg kde laptop latex lcms ldap libnotify logitech-mouse mad mikmod mng modules mp3 mp4 mpeg mudflap musicbrainz ncurses networkmanager nls nptl nptlonly ogg opengl openmp pam pango pbbuttonsd pcre pda pdf perl phonon plotutils png policykit postgres ppc ppds pppd python qt3 qt3support qt4 readline reflection samba sasl sdl semantic-desktop session slp socks5 speex spell spl sql sqlite ssl startup-notification svg sysfs tcpd theora threads tiff truetype twolame udev unicode usb vcd vim-syntax vorbis wifi x264 xattr xcb xcomposite xine xml xorg xrandr xscreensaver xulrunner xv xvid zeroconf zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="synaptics mouse evdev keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Andreas K. Hüttel archtester gentoo-dev 2010-06-13 17:38:54 UTC
OK this may be a stupid question, but is the dbus service in your runlevel and running? :)

Other question, have you tried later kde versions, e.g. 4.4.4 (current stable candidate)?
Comment 2 Robert W. 2010-06-14 05:16:24 UTC
(In reply to comment #1)
> OK this may be a stupid question, but is the dbus service in your runlevel and
> running? :)

DBus is running for the user's session and system-wide.
> Other question, have you tried later kde versions, e.g. 4.4.4 (current stable
> candidate)?

No, not yet. This may take some days for unmasking and compiling all the stuff.
Comment 3 Vicente Olivert Riera (RETIRED) gentoo-dev 2010-06-24 09:36:38 UTC
(In reply to comment #1)
> Other question, have you tried later kde versions, e.g. 4.4.4 (current stable
> candidate)?

peratu@fujitsu ~ $ qlist -Iev korganizer
peratu@fujitsu ~ $ korganizer 
korganizer(3174)/kio (KDirWatch) KDirWatchPrivate::removeEntry: doesn't know "" 
korganizer(3174)/kio (KDirWatch) KDirWatchPrivate::removeEntry: doesn't know "/home/peratu/.kde4/share/apps/korganizer" 
korganizer(3174)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
peratu@fujitsu ~ $

It works :-)
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2010-07-09 20:50:53 UTC
(In reply to comment #3)
> It works :-)

OK nuking the bug then. :)