Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 311935 - Version bump: media-gfx/digikam-1.5.0
Summary: Version bump: media-gfx/digikam-1.5.0
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 334509 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-29 14:34 UTC by Samuli Suominen
Modified: 2010-10-12 18:10 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
ebuild (digikam-1.2.0.ebuild,1.98 KB, text/plain)
2010-03-30 07:31 UTC, Andreas K. Hüttel
Details
updated libpgf patch (digikam-1.2.0-libpgf.patch,8.19 KB, patch)
2010-03-30 07:32 UTC, Andreas K. Hüttel
Details | Diff
build log showing failure to build digikam 1.3.0 (build.log.bz2,3.77 KB, application/octet-stream)
2010-08-13 23:40 UTC, Zeev Tarantov
Details
build.log from failed build attempt (build.log,41.55 KB, text/plain)
2010-08-29 14:15 UTC, Jakob Kummerow
Details
digikam-1.4.0 build log compressed as zip (build.log.zip,47.23 KB, application/octet-stream)
2010-08-31 18:13 UTC, Benjamin Schulz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2010-03-29 14:34:33 UTC
have fun, make sure you don't drop the libpng14 patch if it's still required.
Comment 1 Andreas K. Hüttel gentoo-dev 2010-03-30 07:30:59 UTC
Minimally tested ebuild follows as attachment. JPEG and PNG patches are obsolete. 

Will submit this for the kde overlay after a few more checks. 

Bug 206934 and bug 306679 still need fixing though.
Comment 2 Andreas K. Hüttel gentoo-dev 2010-03-30 07:31:33 UTC
Created attachment 225791 [details]
ebuild
Comment 3 Andreas K. Hüttel gentoo-dev 2010-03-30 07:32:03 UTC
Created attachment 225793 [details, diff]
updated libpgf patch
Comment 4 Ronan Arraes Jardim Chagas 2010-03-31 00:59:06 UTC
Sorry, I haven't seen this bug and I created ebuilds for digikam 1.2.0 and kipi-plugins 1.2.0 from my previous work for 1.1.0.

Since upstream continues to bundle libpgf, my ebuild contains a patch to correct it also. I have already committed to kde-overlay, so can you test it please?
Comment 5 Vasilis Lourdas 2010-03-31 20:02:51 UTC
I've installed both digikam-1.2.0 and kipi-plugins-1.2.0 from the kde overlay, but digikam is way unstable. Something's badly broken and I cannot create a pattern of how to reproduce the problem. Try to access a menu (eg. configuration), go through some photos and digikam crashes.

I'm going back to 1.1.0 until this issue is resolved.
Comment 6 Ronan Arraes Jardim Chagas 2010-03-31 23:32:12 UTC
Vasileios P. Lourdas,
I can access configuration menu, and I couldn't reproduce any crashes by going through photos.
Have you already seen a pattern?
Comment 7 Samuli Suominen gentoo-dev 2010-04-02 19:01:05 UTC
Should likely add this:

http://repos.archlinux.org/wsvn/packages/digikam/trunk/digikam-1.2.0-kde232628.patch

Comment 8 Kanstantsin Shautsou 2010-04-02 22:57:53 UTC
Settings menu is workings for me. 
Please add ~x86 keyword to digikam-1.2.0.ebuild (kde overlay) (kipi-plugins has it).
Comment 9 Dror Levin (RETIRED) gentoo-dev 2010-04-02 23:02:53 UTC
Added ~x86 keyword in the overlay, thanks for testing.
Comment 10 Ronan Arraes Jardim Chagas 2010-04-05 15:41:55 UTC
(In reply to comment #7)
> Should likely add this:
> 
> http://repos.archlinux.org/wsvn/packages/digikam/trunk/digikam-1.2.0-kde232628.patch
> 

I committed digikam-1.2.0-r1.ebuild to overlay with the patch that Samuli Suominen ask to add.
Comment 11 Vasilis Lourdas 2010-04-06 13:17:00 UTC
(In reply to comment #10)
> I committed digikam-1.2.0-r1.ebuild to overlay with the patch that Samuli
> Suominen ask to add.

Where is the -r1 ebuild? I've just synced and only the plain 1.2.0 appears.
Comment 12 Ronan Arraes Jardim Chagas 2010-04-08 18:28:43 UTC
We decided to do not revbump packages at overlay. So, the 1.2.0-r1 is 1.2.0 now.
Comment 13 Jochen 2010-06-08 12:35:03 UTC
So will this bug be closed since digikam 1.3.0 is out?
Comment 14 Samuli Suominen gentoo-dev 2010-06-08 12:59:09 UTC
(In reply to comment #13)
> So will this bug be closed since digikam 1.3.0 is out?
> 

No, this bug is for 1.3.0 now.
Comment 15 Andreas K. Hüttel gentoo-dev 2010-07-06 20:38:06 UTC
In the KDE overlay now, please test!
Comment 16 Ai Locke Shinseiko (Wizzleby) 2010-07-07 02:11:28 UTC
(In reply to comment #15)
> In the KDE overlay now, please test!
> 

Fails to build, due to not being satisfied that libkexiv2 and libkdcraw are installed at proper versions (both are installed at 4.4.5). Will attach build.log.
Comment 17 Ai Locke Shinseiko (Wizzleby) 2010-07-07 02:33:49 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > In the KDE overlay now, please test!
> > 
> 
> Fails to build, due to not being satisfied that libkexiv2 and libkdcraw are
> installed at proper versions (both are installed at 4.4.5). Will attach
> build.log.
> 

I filed this as its own bug, #327245 so as hopefully not to end up with dupes.
Comment 18 Andreas K. Hüttel gentoo-dev 2010-07-07 14:22:21 UTC
> > Fails to build, due to not being satisfied that libkexiv2 and libkdcraw are
> > installed at proper versions (both are installed at 4.4.5). Will attach
> > build.log.

Unavoidable at the moment since digikam-1.3 requires kde-4.5 (!).
Dependencies have been bumped and digikam-1.2 is back in the overlay, too.
Comment 19 Vasilis Lourdas 2010-07-07 19:20:59 UTC
(In reply to comment #18)
> Unavoidable at the moment since digikam-1.3 requires kde-4.5 (!).
> Dependencies have been bumped and digikam-1.2 is back in the overlay, too.

Pardon my asking, but digikam 1.3.0 was released a month ago and it has KDE 4.5 as a dependency? It seems odd, doesn't it? Why have dependencies been bumped?
Comment 20 Vasilis Lourdas 2010-07-07 19:23:57 UTC
(In reply to comment #19)
> Pardon my asking, but digikam 1.3.0 was released a month ago and it has KDE 4.5
> as a dependency? It seems odd, doesn't it? Why have dependencies been bumped?

Here's the answer: http://www.digikam.org/drupal/node/522#comment-19224
Comment 21 Tomas Papan 2010-07-08 07:51:52 UTC
(In reply to comment #18)
> > > Fails to build, due to not being satisfied that libkexiv2 and libkdcraw are
> > > installed at proper versions (both are installed at 4.4.5). Will attach
> > > build.log.
> 
> Unavoidable at the moment since digikam-1.3 requires kde-4.5 (!).
> Dependencies have been bumped and digikam-1.2 is back in the overlay, too.
> 

digikam-1.3 is just working fine with kde-4.4.90 from kde overlay, please set KDE_MINIMAL to that version (imho 4.4.85 would be sufficient, but I didn't test it). 

KDE_MINIMAL="4.4.90"



Comment 22 Andreas K. Hüttel gentoo-dev 2010-07-08 08:50:00 UTC
> digikam-1.3 is just working fine with kde-4.4.90 from kde overlay

Yes I know (that's how I tested it).

>, please set
> KDE_MINIMAL to that version (imho 4.4.85 would be sufficient, but I didn't test
> it). 
> 
> KDE_MINIMAL="4.4.90"
> 

That does not work unfortunately (since KDE_MINIMAL accepts only values that are also valid kde SLOTs).

Comment 23 Tomas Papan 2010-07-08 09:06:53 UTC
(In reply to comment #22)
> > digikam-1.3 is just working fine with kde-4.4.90 from kde overlay
> 
> Yes I know (that's how I tested it).
> 
> >, please set
> > KDE_MINIMAL to that version (imho 4.4.85 would be sufficient, but I didn't test
> > it). 
> > 
> > KDE_MINIMAL="4.4.90"
> > 
> 
> That does not work unfortunately (since KDE_MINIMAL accepts only values that
> are also valid kde SLOTs).
> 

yes, you are right (mea culpa), I didn't notice the QA warning... 
Comment 24 Zeev Tarantov 2010-08-13 23:39:56 UTC
I've upgraded to KDE 4.5 and digikam stopped working. Portage didn't upgrade it. I unmasked digikam 1.3.0 and tried building it. It failed without telling me what's wrong. I'm attaching the build log.
Comment 25 Zeev Tarantov 2010-08-13 23:40:41 UTC
Created attachment 242871 [details]
build log showing failure to build digikam 1.3.0
Comment 26 Tomas Papan 2010-08-14 06:47:56 UTC
(In reply to comment #25)
> Created an attachment (id=242871) [details]
> build log showing failure to build digikam 1.3.0
> 

Check lines 133:147, configurator is complaining about missing mysql, try to install that before digikam.
Comment 27 Zeev Tarantov 2010-08-14 07:30:20 UTC
I guessed, but it still said "digiKam will be compiled................. YES", and the ebuild does not have a dependency on mysql (that's definitely a bug), and I would really prefer to use sqlite anyway. I don't want to install a separate RDBMS to run showfoto. Should I complain upstream?
Comment 28 Benjamin Schulz 2010-08-17 03:36:01 UTC
emerge digikam-1.3.0 results in this here for my machine:

In »»/Files/distfiles/digikam-1.3.0.tar.bz2«« speichern.

100%[===================================================================>] 14.990.462  9,33M/s   in 1,5s    

2010-08-17 05:33:03 (9,33 MB/s) - »»/Files/distfiles/digikam-1.3.0.tar.bz2«« gespeichert [14990462/14990462]

 * digikam-1.3.0.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                              [ ok ]
 * checking ebuild checksums ;-) ...                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                [ ok ]
 * CPV:  media-gfx/digikam-1.3.0
 * REPO: kde
 * USE:  addressbook amd64 elibc_glibc gphoto2 kernel_linux lensfun linguas_de multilib semantic-desktop thumbnails userland_GNU video
>>> Unpacking source...
>>> Unpacking digikam-1.3.0.tar.bz2 to /tmp/portage/media-gfx/digikam-1.3.0/work
>>> Source unpacked in /tmp/portage/media-gfx/digikam-1.3.0/work
>>> Preparing source in /tmp/portage/media-gfx/digikam-1.3.0/work/digikam-1.3.0 ...
 * Applying digikam-1.3.0-libpgf.patch ...                                                             [ ok ]
 * Applying digikam-1.3.0-lapack.patch ...                                                             [ ok ]
 * Enabling languages:  de
>>> Source prepared.
>>> Configuring source in /tmp/portage/media-gfx/digikam-1.3.0/work/digikam-1.3.0 ...
>>> Working in BUILD_DIR: "/tmp/portage/media-gfx/digikam-1.3.0/work/digikam-1.3.0_build"
cmake -C /tmp/portage/media-gfx/digikam-1.3.0/temp/gentoo_common_config.cmake -DCMAKE_INSTALL_PREFIX=/usr -DKDE4_BUILD_TESTS=OFF -DCMAKE_INSTALL_PREFIX=/usr -DSYSCONF_INSTALL_DIR=/etc -DWITH_LQR=ON -DGWENVIEW_SEMANTICINFO_BACKEND=Nepomuk -DWITH_KdepimLibs=ON -DBUILD_doc=OFF -DBUILD_DOC=OFF -DBUILD_Doc=OFF -DWITH_MarbleWidget=OFF -DENABLE_GPHOTO2=ON -DWITH_gphoto2=ON -DWITH_GPHOTO2=ON -DWITH_Gphoto2=ON -DWITH_LensFun=ON -DWITH_Soprano=ON -DENABLE_themedesigner=OFF -DENABLE_THEMEDESIGNER=OFF -DENABLE_Themedesigner=OFF -DENABLE_THUMBS_DB=ON -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/tmp/portage/media-gfx/digikam-1.3.0/temp/gentoo_rules.cmake  /tmp/portage/media-gfx/digikam-1.3.0/work/digikam-1.3.0
loading initial cache file /tmp/portage/media-gfx/digikam-1.3.0/temp/gentoo_common_config.cmake
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- The Fortran compiler identification is GNU
-- Check for working Fortran compiler: /usr/bin/gfortran
-- Check for working Fortran compiler: /usr/bin/gfortran  -- works
-- Detecting Fortran compiler ABI info
-- Detecting Fortran compiler ABI info - done
-- Checking whether /usr/bin/gfortran supports Fortran 90
-- Checking whether /usr/bin/gfortran supports Fortran 90 -- yes
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.6.3 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE 
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
-- Found Automoc4: /usr/bin/automoc4 
-- Found Perl: /usr/bin/perl 
-- Found Phonon: /usr/include  (found version "4.4.2", required is "4.3.80")
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found KDE 4.5 include dir: /usr/include
-- Found KDE 4.5 library dir: /usr/lib64
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- checking for module 'lcms'
--   found lcms, version 1.19
-- Found lcms version 1.19, /usr/lib64/liblcms.so
-- Found JPEG: /usr/lib64/libjpeg.so 
-- Found ZLIB: /usr/lib64/libz.so 
-- Found PNG: /usr/lib64/libpng.so 
-- Found TIFF: /usr/lib64/libtiff.so 
-- checking for module 'libpgf'
--   found libpgf, version 6.09.44
-- Looking for Fortran sgemm
-- Looking for Fortran sgemm - found
-- A library with BLAS API found.
-- Looking for Fortran cheev
-- Looking for Fortran cheev - not found
-- A library with LAPACK API not found. Please specify library location.
-- Found Jasper: /usr/lib64/libjasper.so 
-- Check Kdcraw library in local sub-folder...
-- Check Kdcraw library using pkg-config...
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found libkdcraw release >= 0.2.0
-- Found libkdcraw: /usr/lib64/libkdcraw.so
-- Check Kexiv2 library in local sub-folder...
-- Check Kexiv2 library using pkg-config...
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found libkexiv2 release >= 0.2.0
-- Found libkexiv2: /usr/lib64/libkexiv2.so
-- Check Kipi library in local sub-folder...
-- Check Kipi library using pkg-config...
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found libkipi release >= 0.2.0
-- Found libkipi: /usr/lib64/libkipi.so
-- Identified libjpeg version: 80
-- checking for module 'libkdcraw>=1.1.0'
--   found libkdcraw, version 1.1.0
-- checking for module 'libkexiv2>=1.1.0'
--   found libkexiv2, version 1.1.0
-- Found MySQL server executable at: /usr/sbin/mysqld
-- Found MySQL install_db executable at: /usr/bin/mysql_install_db
-- Found gphoto2: -L/usr/lib64 -lgphoto2_port;-L/usr/lib64 -lgphoto2 -lgphoto2_port -lm
-- Found KdepimLibs: /usr/lib64/cmake/KdepimLibs/KdepimLibsConfig.cmake 
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found LensFun: /usr/include 
-- Found GLIB2: /usr/lib64/libglib-2.0.so 
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Performing Test HAVE_LQR_0_4
-- Performing Test HAVE_LQR_0_4 - Success
-- Found Lqr-1: /usr/include/lqr-1 
-- Found Soprano: /usr/include 
-- Found SharedDesktopOntologies: /usr/share/ontology 
-- Found Nepomuk: /usr/lib64/libnepomuk.so 
-- Could NOT find Doxygen  (missing:  DOXYGEN_EXECUTABLE) 
-- 
-- ----------------------------------------------------------------------------------
--  digiKam 1.3.0 dependencies results   <http://www.digikam.org>
-- 
--  Qt4 SQL module found..................... YES
--  MySQL Server found....................... YES
--  MySQL install_db tool found.............. YES
--  libtiff library found.................... YES
--  libpgf library found..................... YES
--  libpng library found..................... YES
--  libjasper library found.................. YES
--  liblcms library found.................... YES
--  libkipi library found.................... YES
--  libkexiv2 library found.................. YES
--  libkdcraw library found.................. YES
--  libgphoto2 library found................. YES (optional)
--  libkdepimlibs library found.............. YES (optional)
--  libmarblewidget library found............ NO  (optional)
-- 
--  digiKam will be compiled without geolocation using Marble widget support.
-- 
--  Nepomuk libraries found.................. YES (optional)
--  liblensfun library found................. YES (optional)
--  libglib2 library found................... YES (optional)
--  liblqr-1 library found................... YES (optional)
--  Doxygen found............................ NO  (optional)
-- 
--  You will not be able to to generate the API documentation.
--  This does not affect building digiKam in any way.
-- 
CMake Error at CMakeLists.txt:383 (MESSAGE):
   digiKam will be compiled................. NO  (Look README file for more details about dependencies)

-- Configuring incomplete, errors occurred!
 * ERROR: media-gfx/digikam-1.3.0 failed:
 *   cmake failed
 * 
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 3919:  Called kde4-base_src_configure
 *   environment, line 3040:  Called cmake-utils_src_configure
 *   environment, line 1155:  Called _execute_optionaly 'src_configure'
 *   environment, line  554:  Called enable_cmake-utils_src_configure
 *   environment, line 1588:  Called die
 * The specific snippet of code:
 *       cmake "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
 * 

Comment 29 Zeev Tarantov 2010-08-17 11:36:34 UTC
I have successfully built digikam 1.3.0 after I've installed mysql, but I have all its USE flags turned off. showfoto works, but running digikam it says: "Run-time Qt4 SQLite or MySQL database plugin is not available - please install it.
Database plugins installed on your computer are listed" and lists "QSQLITE". Clicking "Ok" does not launch the application. I have x11-libs/qt-sql-4.6.3-r2 with sqlite but not mysql USE flags.
Comment 30 konstantinos metaxas 2010-08-25 21:21:12 UTC
(In reply to comment #28)
> emerge digikam-1.3.0 results in this here for my machine:
> 
> In »»/Files/distfiles/digikam-1.3.0.tar.bz2«« speichern.
> 
> 100%[===================================================================>]
> 14.990.462  9,33M/s   in 1,5s    
> 
> 2010-08-17 05:33:03 (9,33 MB/s) -
> »»/Files/distfiles/digikam-1.3.0.tar.bz2«« gespeichert [14990462/14990462]
> 
>  * digikam-1.3.0.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                       
>                       [ ok ]
>  * checking ebuild checksums ;-) ...                                           
>                       [ ok ]
>  * checking auxfile checksums ;-) ...                                          
>                       [ ok ]
>  * checking miscfile checksums ;-) ...                                         
>                       [ ok ]
>  * CPV:  media-gfx/digikam-1.3.0
>  * REPO: kde
>  * USE:  addressbook amd64 elibc_glibc gphoto2 kernel_linux lensfun linguas_de
> multilib semantic-desktop thumbnails userland_GNU video
> >>> Unpacking source...
> >>> Unpacking digikam-1.3.0.tar.bz2 to /tmp/portage/media-gfx/digikam-1.3.0/work
> >>> Source unpacked in /tmp/portage/media-gfx/digikam-1.3.0/work
> >>> Preparing source in /tmp/portage/media-gfx/digikam-1.3.0/work/digikam-1.3.0 ...
>  * Applying digikam-1.3.0-libpgf.patch ...                                     
>                        [ ok ]
>  * Applying digikam-1.3.0-lapack.patch ...                                     
>                        [ ok ]
>  * Enabling languages:  de
> >>> Source prepared.
> >>> Configuring source in /tmp/portage/media-gfx/digikam-1.3.0/work/digikam-1.3.0 ...
> >>> Working in BUILD_DIR: "/tmp/portage/media-gfx/digikam-1.3.0/work/digikam-1.3.0_build"
> cmake -C /tmp/portage/media-gfx/digikam-1.3.0/temp/gentoo_common_config.cmake
> -DCMAKE_INSTALL_PREFIX=/usr -DKDE4_BUILD_TESTS=OFF -DCMAKE_INSTALL_PREFIX=/usr
> -DSYSCONF_INSTALL_DIR=/etc -DWITH_LQR=ON
> -DGWENVIEW_SEMANTICINFO_BACKEND=Nepomuk -DWITH_KdepimLibs=ON -DBUILD_doc=OFF
> -DBUILD_DOC=OFF -DBUILD_Doc=OFF -DWITH_MarbleWidget=OFF -DENABLE_GPHOTO2=ON
> -DWITH_gphoto2=ON -DWITH_GPHOTO2=ON -DWITH_Gphoto2=ON -DWITH_LensFun=ON
> -DWITH_Soprano=ON -DENABLE_themedesigner=OFF -DENABLE_THEMEDESIGNER=OFF
> -DENABLE_Themedesigner=OFF -DENABLE_THUMBS_DB=ON -DCMAKE_BUILD_TYPE=Gentoo
> -DCMAKE_INSTALL_DO_STRIP=OFF
> -DCMAKE_USER_MAKE_RULES_OVERRIDE=/tmp/portage/media-gfx/digikam-1.3.0/temp/gentoo_rules.cmake
>  /tmp/portage/media-gfx/digikam-1.3.0/work/digikam-1.3.0
> loading initial cache file
> /tmp/portage/media-gfx/digikam-1.3.0/temp/gentoo_common_config.cmake
> -- The C compiler identification is GNU
> -- The CXX compiler identification is GNU
> -- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc
> -- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works
> -- Detecting C compiler ABI info
> -- Detecting C compiler ABI info - done
> -- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++
> -- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works
> -- Detecting CXX compiler ABI info
> -- Detecting CXX compiler ABI info - done
> -- The Fortran compiler identification is GNU
> -- Check for working Fortran compiler: /usr/bin/gfortran
> -- Check for working Fortran compiler: /usr/bin/gfortran  -- works
> -- Detecting Fortran compiler ABI info
> -- Detecting Fortran compiler ABI info - done
> -- Checking whether /usr/bin/gfortran supports Fortran 90
> -- Checking whether /usr/bin/gfortran supports Fortran 90 -- yes
> -- Looking for Q_WS_X11
> -- Looking for Q_WS_X11 - found
> -- Looking for Q_WS_WIN
> -- Looking for Q_WS_WIN - not found.
> -- Looking for Q_WS_QWS
> -- Looking for Q_WS_QWS - not found.
> -- Looking for Q_WS_MAC
> -- Looking for Q_WS_MAC - not found.
> -- Found Qt-Version 4.6.3 (using /usr/bin/qmake)
> -- Looking for XOpenDisplay in
> /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
> -- Looking for XOpenDisplay in
> /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
> - found
> -- Looking for gethostbyname
> -- Looking for gethostbyname - found
> -- Looking for connect
> -- Looking for connect - found
> -- Looking for remove
> -- Looking for remove - found
> -- Looking for shmat
> -- Looking for shmat - found
> -- Looking for IceConnectionNumber in ICE
> -- Looking for IceConnectionNumber in ICE - found
> -- Found X11: /usr/lib64/libX11.so
> -- Looking for include files CMAKE_HAVE_PTHREAD_H
> -- Looking for include files CMAKE_HAVE_PTHREAD_H - found
> -- Looking for pthread_create in pthreads
> -- Looking for pthread_create in pthreads - not found
> -- Looking for pthread_create in pthread
> -- Looking for pthread_create in pthread - found
> -- Found Threads: TRUE 
> -- Looking for _POSIX_TIMERS
> -- Looking for _POSIX_TIMERS - found
> -- Found Automoc4: /usr/bin/automoc4 
> -- Found Perl: /usr/bin/perl 
> -- Found Phonon: /usr/include  (found version "4.4.2", required is "4.3.80")
> -- Performing Test _OFFT_IS_64BIT
> -- Performing Test _OFFT_IS_64BIT - Success
> -- Performing Test HAVE_FPIE_SUPPORT
> -- Performing Test HAVE_FPIE_SUPPORT - Success
> -- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
> -- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
> -- Performing Test __KDE_HAVE_GCC_VISIBILITY
> -- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
> -- Found KDE 4.5 include dir: /usr/include
> -- Found KDE 4.5 library dir: /usr/lib64
> -- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
> -- Found automoc4: /usr/bin/automoc4
> -- checking for module 'lcms'
> --   found lcms, version 1.19
> -- Found lcms version 1.19, /usr/lib64/liblcms.so
> -- Found JPEG: /usr/lib64/libjpeg.so 
> -- Found ZLIB: /usr/lib64/libz.so 
> -- Found PNG: /usr/lib64/libpng.so 
> -- Found TIFF: /usr/lib64/libtiff.so 
> -- checking for module 'libpgf'
> --   found libpgf, version 6.09.44
> -- Looking for Fortran sgemm
> -- Looking for Fortran sgemm - found
> -- A library with BLAS API found.
> -- Looking for Fortran cheev
> -- Looking for Fortran cheev - not found
> -- A library with LAPACK API not found. Please specify library location.
> -- Found Jasper: /usr/lib64/libjasper.so 
> -- Check Kdcraw library in local sub-folder...
> -- Check Kdcraw library using pkg-config...
> -- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
> -- Found libkdcraw release >= 0.2.0
> -- Found libkdcraw: /usr/lib64/libkdcraw.so
> -- Check Kexiv2 library in local sub-folder...
> -- Check Kexiv2 library using pkg-config...
> -- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
> -- Found libkexiv2 release >= 0.2.0
> -- Found libkexiv2: /usr/lib64/libkexiv2.so
> -- Check Kipi library in local sub-folder...
> -- Check Kipi library using pkg-config...
> -- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
> -- Found libkipi release >= 0.2.0
> -- Found libkipi: /usr/lib64/libkipi.so
> -- Identified libjpeg version: 80
> -- checking for module 'libkdcraw>=1.1.0'
> --   found libkdcraw, version 1.1.0
> -- checking for module 'libkexiv2>=1.1.0'
> --   found libkexiv2, version 1.1.0
> -- Found MySQL server executable at: /usr/sbin/mysqld
> -- Found MySQL install_db executable at: /usr/bin/mysql_install_db
> -- Found gphoto2: -L/usr/lib64 -lgphoto2_port;-L/usr/lib64 -lgphoto2
> -lgphoto2_port -lm
> -- Found KdepimLibs: /usr/lib64/cmake/KdepimLibs/KdepimLibsConfig.cmake 
> -- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
> -- Found LensFun: /usr/include 
> -- Found GLIB2: /usr/lib64/libglib-2.0.so 
> -- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
> -- Performing Test HAVE_LQR_0_4
> -- Performing Test HAVE_LQR_0_4 - Success
> -- Found Lqr-1: /usr/include/lqr-1 
> -- Found Soprano: /usr/include 
> -- Found SharedDesktopOntologies: /usr/share/ontology 
> -- Found Nepomuk: /usr/lib64/libnepomuk.so 
> -- Could NOT find Doxygen  (missing:  DOXYGEN_EXECUTABLE) 
> -- 
> --
> ----------------------------------------------------------------------------------
> --  digiKam 1.3.0 dependencies results   <http://www.digikam.org>
> -- 
> --  Qt4 SQL module found..................... YES
> --  MySQL Server found....................... YES
> --  MySQL install_db tool found.............. YES
> --  libtiff library found.................... YES
> --  libpgf library found..................... YES
> --  libpng library found..................... YES
> --  libjasper library found.................. YES
> --  liblcms library found.................... YES
> --  libkipi library found.................... YES
> --  libkexiv2 library found.................. YES
> --  libkdcraw library found.................. YES
> --  libgphoto2 library found................. YES (optional)
> --  libkdepimlibs library found.............. YES (optional)
> --  libmarblewidget library found............ NO  (optional)
> -- 
> --  digiKam will be compiled without geolocation using Marble widget support.
> -- 
> --  Nepomuk libraries found.................. YES (optional)
> --  liblensfun library found................. YES (optional)
> --  libglib2 library found................... YES (optional)
> --  liblqr-1 library found................... YES (optional)
> --  Doxygen found............................ NO  (optional)
> -- 
> --  You will not be able to to generate the API documentation.
> --  This does not affect building digiKam in any way.
> -- 
> CMake Error at CMakeLists.txt:383 (MESSAGE):
>    digiKam will be compiled................. NO  (Look README file for more
> details about dependencies)
> 
> -- Configuring incomplete, errors occurred!
>  * ERROR: media-gfx/digikam-1.3.0 failed:
>  *   cmake failed
>  * 
>  * Call stack:
>  *     ebuild.sh, line   54:  Called src_configure
>  *   environment, line 3919:  Called kde4-base_src_configure
>  *   environment, line 3040:  Called cmake-utils_src_configure
>  *   environment, line 1155:  Called _execute_optionaly 'src_configure'
>  *   environment, line  554:  Called enable_cmake-utils_src_configure
>  *   environment, line 1588:  Called die
>  * The specific snippet of code:
>  *       cmake "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
>  * 
> 


I had the same problem
- "A library with LAPACK API not found. Please specify library location."
Your problem is most likely a broken lapack installation. I rebuilt lapack-atlas *AND* set it as my implementation using eselect lapack set (do a list to see your implementations).
That solved it for me.

Otherwise look up your implementation using 'eselect lapack list' and then rebuild that.
Comment 31 Andreas K. Hüttel gentoo-dev 2010-08-25 23:25:16 UTC
Man these guys are fast.
Comment 32 Andreas K. Hüttel gentoo-dev 2010-08-25 23:25:31 UTC
*** Bug 334509 has been marked as a duplicate of this bug. ***
Comment 33 Dan Douglas 2010-08-26 10:02:09 UTC
digikam-9999 has been failing for a few months due to the libpgf patch too. I just uninstalled it in the meantime since waiting for it to fail makes updates take longer.
Comment 34 Benjamin Schulz 2010-08-27 23:45:18 UTC
Thank you. rebuilding lapack-atlas and setting it via eselect solved my issues. Digikam-1.3.0 got installed on my system.
Comment 35 Andreas K. Hüttel gentoo-dev 2010-08-28 19:58:07 UTC
Please test the new ebuild (digikam-1.3.0-r2) in the overlay. 1.4 will follow soon-ish...

The lapack dependency is now replaced by clapack, which removes (most of) the Fortran dependency.
Comment 36 Andreas K. Hüttel gentoo-dev 2010-08-28 22:31:31 UTC
Bumped in overlay, please test.
Comment 37 Jakob Kummerow 2010-08-29 14:13:51 UTC
the new digikam-1.4.0 ebuild fails to compile for me. 

installed package versions:
dev-libs/clapack-3.2.1-r3
dev-libs/libf2c-20090407-r1 [+static-libs]
KDE 4.5.0

# emerge --info
Portage 2.2_rc71 (default/linux/amd64/10.0, gcc-4.4.4, glibc-2.12.1-r1, 2.6.35-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.35-gentoo-r4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 29 Aug 2010 10:30:15 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.2
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.4_p6-r1, 1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/portage /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://mirror.cambrium.nl/pub/os/linux/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/kde /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 apache2 apm ass audiofile avahi bash-completion berkdb blas bs2b bzip2 cairo cdinstall cdparanoia cdr cleartype cli clock cracklib crypt cups curl cxx dbus dga dio directfb dns dri dts dv dvd dvdr dvdread encode fat fbcon ffmpeg firefox firefox3 flac flash ftp gcj gd gdbm gif git glitz glut gnuplot gpm graphviz gs gtk gutenprint handbook hddtemp iconv icq imagemagick imap innodb ipv6 jack java java6 jfs jpeg jpeg2k json kde konqueror kpathsea latex ldap libcaca libwww lm_sensors lyx mad matroska mime mmx modules mp3 mp4 mpeg mplayer mudflap multilib musicbrainz mysql mysqli ncurses nls nocd nptl nptlonly nsplugin ntfs ogg openal opengl openmp oscar pam pcre pdf perl php plasma png posix ppds pppd python qt qt3support qt4 quicktime rar readline reflection rtf samba scanner sdl semantic-desktop session simplexml slang smp sndfile snmp speex spell spl sse sse2 sse3 ssl ssse3 subversion suhosin svg symlink sysfs taglib tcpd theora threads tidy tiff truetype udev unicode usb vcd videos vim-pager visualizer vorbis wav webkit wifi wmf wxwindows x264 xcomposite xine xml xorg xosd xpm xscreensaver xspf xv xvid zeroconf zip zlib" ALSA_CARDS="oxygen" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" FOO2ZJS_DEVICES="hp2600n" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 38 Jakob Kummerow 2010-08-29 14:15:08 UTC
Created attachment 245230 [details]
build.log from failed build attempt
Comment 39 Benjamin Schulz 2010-08-29 20:48:31 UTC
digikam 1.4.0 failed with the following:

                                                                                                         
[ 11%] Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/dimg/filters/lc/localcontrastcontainer.o                                                                                                        
[ 12%] Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/dimg/filters/nr/nrfilter.o           
/tmp/portage/media-gfx/digikam-1.4.0/work/digikam-1.4.0/libs/dimg/filters/nr/nrfilter.cpp: In member function »void Digikam::NRFilter::waveletDenoise(float**, unsigned int, unsigned int, float, double)«:
/tmp/portage/media-gfx/digikam-1.4.0/work/digikam-1.4.0/libs/dimg/filters/nr/nrfilter.cpp:189: Warnung: »lpass« may be used uninitialized in this function
[ 12%] Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/dimg/filters/nr/nrsettings.o
[ 12%] Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/dimg/filters/sharp/sharpenfilter.o   
[ 12%] Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/dimg/filters/sharp/unsharpmaskfilter.o                                                                                                          
[ 12%] Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/dimg/filters/sharp/refocusfilter.o   
[ 12%] Building CXX object digikam/CMakeFiles/digikamcore.dir/__/libs/dimg/filters/sharp/matrix.o          
/tmp/portage/media-gfx/digikam-1.4.0/work/digikam-1.4.0/libs/dimg/filters/sharp/matrix.cpp: In static member function »static int Digikam::RefocusMatrix::dgesv(int, int, double*, int, double*, int)«:
/tmp/portage/media-gfx/digikam-1.4.0/work/digikam-1.4.0/libs/dimg/filters/sharp/matrix.cpp:658: Fehler: »dgesv_« wurde in diesem Gültigkeitsbereich nicht definiert
make[2]: *** [digikam/CMakeFiles/digikamcore.dir/__/libs/dimg/filters/sharp/matrix.o] Fehler 1
make[1]: *** [digikam/CMakeFiles/digikamcore.dir/all] Fehler 2
make: *** [all] Fehler 2
 * ERROR: media-gfx/digikam-1.4.0 failed:
 *   Make failed!
 * 
Comment 40 Andreas K. Hüttel gentoo-dev 2010-08-29 21:01:42 UTC
emerge --info please... :)

(In reply to comment #39)
> digikam 1.4.0 failed with the following:
...
> make[1]: *** [digikam/CMakeFiles/digikamcore.dir/all] Fehler 2
> make: *** [all] Fehler 2
>  * ERROR: media-gfx/digikam-1.4.0 failed:
>  *   Make failed!
>  * 
> 

Comment 41 Andreas K. Hüttel gentoo-dev 2010-08-29 22:51:00 UTC
Jakob, Benjamin: could you please run emerge as follows and attach the resulting build log?

CMAKE_VERBOSE=1 emerge -a1 digikam

TIA, Andreas
Comment 42 Benjamin Schulz 2010-08-31 18:04:06 UTC
 emerge --info
Portage 2.1.8.3 (default/linux/amd64/10.0, gcc-4.4.4, glibc-2.12.1-r1, 2.6.35-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.35-gentoo-r4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 31 Aug 2010 14:30:01 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.2
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 ut2003 sun-bcla-java-vm googleearth AdobeFlash-10"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/layman/layman/xwing /usr/layman/layman/kde /usr/layman/layman/sunrise /usr/layman/layman/qting-edge /usr/layman/layman/science /usr/layman/layman/roslin /usr/layman/layman/dottout /usr/layman/layman/anarchy /usr/layman/ownebuilds"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit X Xaw3d a52 aac abiword abyss ace acl acpi activefilter addns addressbook admin adns adplug aften afterimage aim aio akonadi alsa amd64 amr amrnb analogtv animgif archive aspell assistant audacious audio audiofile audioscrobbler auth auto-completion automount autoreplace autotrace bash-completion battery bcmath berkdb binary-drivers binfilter bittorrent blender blender-game bluetooth bonjour boost browser bugzilla bzip2 cairo calendar caps cardbus ccache cdb cddax cddb cdio cdparanoia cdr cdrom cg cgi chroot cli clipboard clucene cluster cmake compat compress connection-sharing consolekit context contrast contrast-control contrib corefonts cpudetection cpulimit cracklib crypt ctype ctypes-python cuda cue cups cvs cxx cyrillic dbus dc1394 dcc dchroot deflate detex devfs-compat device-mapper dga dia dirac disk-partition diskio djvu dmraid dmx docbook dolby-record-switch dolbyinrec dot dpms drawing dri dts dv dvb dvbplayer dvbsetup dvd dvdarchive dvdchapjump dvdnav dvdr dvi dvi2tty dvipdfm dx dxr3 dynamicplugin ebook eclipse emacs emf emovix enca enchant encode ethernet ewf excel exif extensions extra extra-algorithms extras faad facebook fam fame fasttrack fat ffmpeg fftw filter firefox firefox3 fits flac flash flatfile fluidsynth flv fontconfig foomaticdb fortran fortran95 fpx freemail ftp fts3 fuse gadu gallium games gcj gcrypt gd gdbm gfortran ggi gif git github glib glibc-compat20 glibc-omitfp glsl glut glviewer gmm gmp gmtfull gmthigh gmtsuppl gnome-print gnomecanvas gnuplot gnutella gnutls google google-gadgets gphoto2 gpm grace grammar graph graphics graphite graphviz grass groupwise grub gs gsf gsl gsm gstreamer gtk gtk2-perl gtkhotkey gtkspell gzip gzip-el h224 h281 h323 hal hash hdaps hddtemp hdf hdri hepmc hfs highlight highvolume history hotpixels hpn html http httpd httppower humanities hunspell hyperestraier hyphenation i18n ibmvio icc iconv icq icu id3 id3tag idb ieee1394 ifc ilbc image image-cache imagemagick imaging imap imlib indi infowidget inherit-graph inifile inkjar inotify int64 ioctl ipp iproute2 ipsec iptc iptv ipv6 irda iso14755 jabber jack jadetex java java5 java6 javacomm javamail javascript jbig jce jfs joystick jpeg jpeg2k json kate kdcraw kde kde-qt kdevplatform kerberos keyboard kino kipi kmail kolab konqueror kontact kpathsea krb4 l7filter ladspa lame lapack laptop largefile lastfm lastfmradio latex latex3 lcms ldb lensfun libcaca libgig libmms libnl libnotify libproxy libssh2 libsysfs libv4l libv4l2 libwww lightning live lm_sensors logitech-mouse logrotate logviewer lqr lyx lzma lzo m17n-lib mad mail mailbox maildir maildrop maps math mathml matplotlib matroska max-idx-128 mcve md5sum mdb meanwhile mfd-rewrites mjpeg mkl mmx mmxext mng modplug modules mono motif mp2 mp3 mp3tunes mp4 mpeg mpi mplayer mppe-mppc mpqc msn mssql mtp mudflap multilib multimedia musepack music mysql nas nautilus ncurses neXt network networkmanager nfs nfsv3 nfsv4 nis nls nova nptl nptlonly nsplugin ntfs ntp numeric numpy nut nuv nvidia nvram nvtv octave odbc odk ogg ogg123 ogm omega openal opencore-amr openct openexr opengl openmp openssl optimization optimized-qmake oscar otr pam parse-clocks pcmcia pcntl pcre pcsc-lite pdf pdo perl pg-intdatetime phonon php pkcs11 plasma player plotutils pm-utils pmu png pnm policykit portaudio posix postgres postproc postscript ppds pppd preview-latex print ps pstoedit pstricks publishers pulseaudio pvr python qmake qt3support qt4 quicktime quota quotas radio ramfs rar raw rcs readline recording redeyes reflection reiserfs remote remoteosd replytolist resolvconf rle rpc rpm rss rtf rtsp ruby run-as-root samba sasl scanner schroedinger science sdl sdl-image secure-delete semantic-desktop sendmail sensord session sha1 shaders sharedext shine shout simplexml skey skins skype smartcard smbsharemodes smp sms smtp smux sndfile snmp sockets socks socks5 sound soundex sourceview spamassassin spamfilter speex spell spl sql sqlite sqlite3 sse sse2 sse3 sse4 sse4a sse5 ssh ssl ssse3 stream subversion suhosin suid svg swat sysfs syslog sysvipc szip t1lib taglib tcl tcpd templates tex tex4ht texmacs theora thinkpad threads thumbnail thumbnails thunderbird tidy tiff timezone tk tokenizer toolbar toolkit-scroll-bars totem transcode truetype tta tts tv tv_check tv_combiner tv_pick_cgi tvflash tvtime type3 udev udev-acl umfpack unicode unzip upnp usb utils v4l v4l2 vcd vcdinfo vcdx vdpau vga video vlm vorbis wav wavpack wcwidth wddx webcam webdav webdav-neon webdav-serf webinterface webkit webpresence websockets wicd wifi winbind winpopup wma wma-fixed wmf wordperfect wpd wpg wps wv2 wxwidgets x264 x264-static xattr xcomposite xemacs xetex xext xfs xft xhtml xim xine xinerama xinetd xml xmlpatterns xmlreader xmlrpc xmlwriter xmp xorg xpm xrender xsl xterm xterm-color xulrunner xv xvid xvmc yaz youtube yv12 zip zippy zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse joystick synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia svga vesa v4l fbdev vmware virtualbox" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 43 Benjamin Schulz 2010-08-31 18:13:04 UTC
Created attachment 245515 [details]
digikam-1.4.0 build log compressed as zip
Comment 44 Andreas K. Hüttel gentoo-dev 2010-08-31 21:36:16 UTC
(In reply to comment #43)
> Created an attachment (id=245515) [details]
> digikam-1.4.0 build log compressed as zip
> 

OK thank you, we're getting there. Do you have a file /usr/include/clapack.h, and if yes, which package does it belong to?

equery belongs /usr/include/clapack.h
Comment 45 Frank Hellmuth 2010-08-31 22:28:46 UTC
(In reply to comment #44)

I get the same error as in comment #43 (/var/tmp/portage/media-gfx/digikam-1.4.0/work/digikam-1.4.0/libs/dimg/filters/sharp/matrix.cpp:658: error: ‘dgesv_’ was not declared in this scope)

equery belongs /usr/include/clapack.h

gives 

* Searching for /usr/include/clapack.h ... 
sci-libs/lapack-atlas-3.9.23-r3 (/usr/include/clapack.h -> atlas/clapack.h)
sci-libs/lapack-atlas-3.9.23-r3 (/usr/include/atlas/clapack.h)

I also tried switching to acml, with no success (error remains the same)
Comment 46 Andreas K. Hüttel gentoo-dev 2010-09-01 00:14:26 UTC
> equery belongs /usr/include/clapack.h
> 
> gives 
> 
> * Searching for /usr/include/clapack.h ... 
> sci-libs/lapack-atlas-3.9.23-r3 (/usr/include/clapack.h -> atlas/clapack.h)

Can you try just moving away that file (f.ex. "mv /usr/include/clapack.h /root/" ) and then emerging digikam again?

If that fixes the problem, I have the patch ready here... just cannot commit it yet as overlays.gentoo.org is down...
Comment 47 Frank Hellmuth 2010-09-01 07:49:16 UTC
Thanks!

Moving /usr/include/clapack.h out of the include path solved the problem. Digikam-1.4.0 compiled and installed without further problems; digikam starts and works as far as I tried.

Moved clapack.h back into place afterwards.

Thanks again for the quick work around! 
Comment 48 Andreas K. Hüttel gentoo-dev 2010-09-01 21:28:49 UTC
(In reply to comment #47)
> Moving /usr/include/clapack.h out of the include path solved the problem.
> Digikam-1.4.0 compiled and installed without further problems; digikam starts
> and works as far as I tried.

OK, fix is in the overlay. :)
Comment 49 Jochen 2010-09-10 07:42:21 UTC
The digikam-1.4.0 ebuild from overlay compiles fines (~x86,kde 4.5.1). Digikam runs as expected. I suggest adding it to the tree as digikam-1.2.0 is a little bit dated.
Comment 50 josef.95 2010-09-10 10:25:55 UTC
(In reply to comment #49)
> The digikam-1.4.0 ebuild from overlay compiles fines (~x86,kde 4.5.1). Digikam
> runs as expected.
>
confirmed ++
Thanks!
Comment 51 Andreas K. Hüttel gentoo-dev 2010-09-16 20:51:40 UTC
Bumped to the tree.
Comment 52 Vasilis Lourdas 2010-10-12 16:06:28 UTC
digikam-1.5.0 has been released, along with kipi-plugins-1.5.0.
Comment 53 Andreas K. Hüttel gentoo-dev 2010-10-12 18:03:42 UTC
Thus reopening...
Comment 54 Andreas K. Hüttel gentoo-dev 2010-10-12 18:09:40 UTC
Moving this to bug 340733. Add your cc there if you want to be updated.