Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310685 - kde-base/nepomuk-4.3.5 loops on onto2vocabulary: ccache problem
Summary: kde-base/nepomuk-4.3.5 loops on onto2vocabulary: ccache problem
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Blocks: 313999
  Show dependency tree
Reported: 2010-03-22 11:43 UTC by Paul Gover
Modified: 2010-06-14 20:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Paul Gover 2010-03-22 11:43:18 UTC
emerge  --color y --update --deep --reinstall changed-use world system
the emerge hangs when it gets to nepomuk-4.3.5.  "top" shows 5 copies (I'm running with -j5, 'cos it's a Phenom X4) of onto2vocabulary, all eating as much cpu as they can.  This is at 47% through the make.  Removing the "-j5" from make.conf still exhibits the loop, though of course now with just one onto2vocabulary process, and this time it occurred at about 1% or 2% of the make.

emerge --resume doesn't fix it.  I bypassed the problem with emerge --resume --skip-first, but that leaves me with a broken nepomuk.  (as compared with whatever it does when it works :-)

Reproducible: Always

Steps to Reproduce:
emerge =kde-base/nepomuk-4.3.5

Actual Results:  
Time for coffee.  Time for all the coffee in the world.

Expected Results:  
Err, whatever nepomuk does...

The obligatory emerge --info
Portage 2.2_rc67 (default/linux/amd64/10.0/desktop, gcc-4.3.3, glibc-2.10.1-r1, 2.6.31-gentoo-r6 x86_64)
System uname: Linux-2.6.31-gentoo-r6-x86_64-AMD_Phenom-tm-_9150e_Quad-Core_Processor-with-gentoo-1.12.13
Timestamp of tree: Sun, 21 Mar 2010 16:15:02 +0000                                                      
ccache version 2.4 [enabled]                                                                            
app-shells/bash:     4.0_p35                                                                            
dev-java/java-config: 2.1.10                                                                            
dev-lang/python:     2.6.4-r1                                                                           
dev-util/ccache:     2.4-r7                                                                             
dev-util/cmake:      2.6.4-r3                                                                           
sys-apps/baselayout: 1.12.13                                                                            
sys-apps/sandbox:    2.2                                                                                
sys-devel/autoconf:  2.13, 2.63-r1                                                                      
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.3                                               
sys-devel/binutils:  2.18-r3                                                                            
sys-devel/gcc:       4.3.3-r2, 4.4.1                                                                    
sys-devel/gcc-config: 1.4.1                                                                             
sys-devel/libtool:   2.2.6b                                                                             
virtual/os-headers:  2.6.30-r1                                                                          
ACCEPT_LICENSE="* -@EULA IBM-J1.6 dlj-1.1"                                                              
CFLAGS="-march=native -O3 -pipe"                                                                        
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"                              
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"                                                                                                             
CXXFLAGS="-march=native -O3 -pipe"                                                                                                   
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv"
LINGUAS="en_GB en en_US"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode fam ffmpeg firefox flac fortran gdbm gif glibc-omitfp gpm gstreamer gtk hal handbook iconv ipv6 java joystick jpeg kde ldap libnotify mad mikmod mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection sdl semantic-desktop session spell spl sql sse sse2 ssl startup-notification svg sysfs tcpd threads thunar tiff truetype unicode usb vorbis webkit x264 xcomposite xine xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" DVB_CARDS="usb-wt220u" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en en_US" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx"
Comment 1 Andreas K. Hüttel archtester gentoo-dev 2010-03-23 19:11:54 UTC
Can you please try again with FEATURES="-ccache"? 
Comment 2 Paul Gover 2010-03-24 20:23:08 UTC
(In reply to comment #1)
> Can you please try again with FEATURES="-ccache"? 

Good call!  That fixed it.

I've not changed the bug status, as I'm not sure if this is a fix or just a bypass.

Comment 3 Andreas K. Hüttel archtester gentoo-dev 2010-03-28 18:09:50 UTC
So maybe we should RESTRICT that feature?

Don't know enough about ccache to even speculate about the exact origin of the problem...
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2010-05-30 19:24:37 UTC
Anyone tried this with 4.4.2 or 4.4.3?
Comment 5 Andreas K. Hüttel archtester gentoo-dev 2010-06-14 20:42:13 UTC
Works fine here with 4.4.4 (amd64, -j9), so I am resolving the bug. 

If the problem reappears, just reopen please...