Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 307611 - kde-base/mplayerthumbs-4.4.5 and media-video/kffmpegthumbnailer are keeping device busy while umount
Summary: kde-base/mplayerthumbs-4.4.5 and media-video/kffmpegthumbnailer are keeping d...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard:
Keywords:
Depends on:
Blocks: 313999
  Show dependency tree
 
Reported: 2010-03-03 13:12 UTC by shade
Modified: 2011-04-08 19:19 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shade 2010-03-03 13:12:56 UTC
If we will use media-video/kffmpegthumbnailer  or kde-base/mplayerthumbs and point mouse at some video (with dolphin) that is on removable media device state will be set to busy, and umount will be locked. Now if we would like to umount device we will get message that device is busy, even if we will point other file that isnt on device and new thumbnail will be used in dolphin, thumbnailers will still use and block that device. 

Reproducible: Always

Steps to Reproduce:
1. Mount some removable media with video file
2. point video file with mouse
3. try to umout device

Actual Results:  
Device not unmounting if we will point video file on dolphin

Expected Results:  
Device umounting when we want, not when kde will let us to do so.

kde-base/mplayerthumbs should be removed from meta dep of kde to time when this bug will be fixed.
Comment 1 Andreas K. Hüttel gentoo-dev 2010-04-20 21:05:42 UTC
Which kde version do you have?
Comment 2 shade 2010-04-20 21:20:20 UTC
Its problem of all kde versions that are in portage (now i have 4.4.2).(In reply to comment #1)
> Which kde version do you have?
> 

Its problem of all kde versions that are in portage. Answer is 4.4.2 (right now) if you realy need to know.
Comment 3 shade 2010-07-12 12:33:16 UTC
This bug dosn't affect ssd cards from my 
08:06.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)

I tryed them and they are unmounted  on the fly without any problems.
Comment 4 Jeremy Murphy 2010-11-24 02:42:24 UTC
I can confirm this bug, it's very annoying.

Question in my mind is, how do we know where the bug is?  Is it in the actual media thumbnailer, or in KDE's kio_thumbnail process?  My guess is the latter, since when I list running processes, there is no "ffmpegthumbnailer" (in my case), only kio_thumbnail.  My additional guess is that kio_thumbnail is keeping the device open so that it can quickly provide thumbnail images as the user requires, which is fine for a fixed device, but problematic for removable devices.

Could a KDE expert comment?  My last and final guess (really) is that we'll have to take this upstream.  :)
Comment 5 Jeremy Murphy 2010-11-24 04:48:56 UTC
Btw, here is the upstream bug, which was lodged more than two years ago.  :\
https://bugs.kde.org/show_bug.cgi?id=168804
Comment 6 Andreas K. Hüttel gentoo-dev 2010-12-14 16:19:16 UTC
Waiting for upstream... ... ... ...
Comment 7 Andreas K. Hüttel gentoo-dev 2011-02-16 21:24:38 UTC
According to upstream report, affects also 4.4.5
Comment 8 Jeremy Murphy 2011-02-16 23:37:21 UTC
But the important question probably is, does it affect 4.6.0?
Comment 9 Andreas K. Hüttel gentoo-dev 2011-04-08 19:19:17 UTC
(In reply to comment #8)
> But the important question probably is, does it affect 4.6.0?

No upstream duplicates since kde-4.4. So I'll tentatively assume that this is fixed...