Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 306147 - pykde4-4.4.1 fails to run make install for Python-3.* modules
Summary: pykde4-4.4.1 fails to run make install for Python-3.* modules
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Blocks: 313999
  Show dependency tree
Reported: 2010-02-21 09:09 UTC by Markos Chandras (RETIRED)
Modified: 2010-06-06 16:28 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log file (build.log,244.33 KB, text/plain)
2010-02-21 09:09 UTC, Markos Chandras (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Markos Chandras (RETIRED) gentoo-dev 2010-02-21 09:09:05 UTC
* Installation of kde-base/pykde4-4.4.0 with CPython 3.1...
>>> Working in BUILD_DIR: "/var/tmp/portage/kde-base/pykde4-4.4.0/work/pykde4-4.4.0-3.1_build"
make -j4 install DESTDIR=/var/tmp/portage/kde-base/pykde4-4.4.0/image/
make: *** No rule to make target `install'.  Stop.
 * ERROR: kde-base/pykde4-4.4.0 failed:
 *   Make install failed

Full log attached
Comment 1 Markos Chandras (RETIRED) gentoo-dev 2010-02-21 09:09:31 UTC
Created attachment 220575 [details]
build.log file
Comment 2 Franz Trischberger 2010-02-21 09:50:40 UTC
Could it be, you installed python-3.1, then immediately tried to install pykde4?
The Problem is here:

-- Python Include Path: /usr/include/python3.1
-- Build Kross Python... yes
Traceback (most recent call last):
  File "/usr/share/apps/cmake/modules/", line 8, in <module>
    import sipconfig
ImportError: No module named sipconfig
-- Build PyKDE4... no
-- <<< Gentoo configuration >>>

sip seems to be not installed as python-3.1-module. 
After an update to a new python-Slot, you need to run python-updater.
Try that, then install pykde4.
Good luck!
Comment 3 Markos Chandras (RETIRED) gentoo-dev 2010-02-21 10:02:28 UTC
Could be, but I use sip snapshot and it doesn't build modules for Python-3. I will try to use the sip-4.10 version and see how that will go

Comment 4 Markos Chandras (RETIRED) gentoo-dev 2010-02-21 10:30:08 UTC
I modified sip to build python-3 modules but still pykde4 fails to build. 
Comment 5 Franz Trischberger 2010-02-21 10:51:36 UTC
(In reply to comment #4)
> I modified sip to build python-3 modules but still pykde4 fails to build. 
Did you run python-updater yet?
The problem is, that several dependencies need other python-packages installed first.
So pykde4 needs PyQt4, built with dbus-USEFlag. That needs dev-python/dbus-python, which needs dev-python/pyrex and so on. All dependencies need to be built as python3-modules! To achieve this, you need to run python-updater with appropriate parameters.
I think you still didn't. :)
Comment 6 Paul de Vrieze (RETIRED) gentoo-dev 2010-03-11 13:26:24 UTC
Would it be possible/simple to add an explicit check to the package, that puts you in the right direction
Comment 7 Markos Chandras (RETIRED) gentoo-dev 2010-03-14 11:30:37 UTC
I did run python update. Still no luck
Comment 8 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-23 19:17:25 UTC
(In reply to comment #1)

Have you reinstalled dev-python/sip?
Comment 9 Maciej Mrozowski gentoo-dev 2010-06-01 23:04:57 UTC
Like Arfrever suggested - after python3 is installed - python-updater or whatever needs to be run afterwards which means all python packages need to be rebuilt - for pykde4 case:
- sip, PyQt4

That being said following sequence breaks because of unsatisfied dependencies for python3 pykde4 abi:
emerge -1 pykde4 && emerge -1 python:3.1 && emerge -1 pykde4
Comment 10 Andreas K. Hüttel archtester gentoo-dev 2010-06-06 16:28:30 UTC
Resolving since pykde4 is now restricted to python 2.