Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 305169 - KDE 4.4.2 Workspace theme "Air" broken
Summary: KDE 4.4.2 Workspace theme "Air" broken
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo KDE team
: 312091 (view as bug list)
Depends on:
Blocks: 313999
  Show dependency tree
Reported: 2010-02-14 23:44 UTC by Timothy Miller
Modified: 2010-06-16 18:38 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

Screen snapshot (snapshot1.png,931.57 KB, image/png)
2010-02-14 23:45 UTC, Timothy Miller

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Miller 2010-02-14 23:44:25 UTC
I have a strange display corruption problem when I use the Air desktop theme.  I'll attach a screen shot.  Look in the lower left.  The left half taskbar has the wrong background, like some image is being underlayed there.  I have tried blowing away all of ~/.kde4 to no avail.

I've discussed this with KDE devs, and they tell me that it's some kind of upstream distro problem.  Either the files for the Air theme itself are broken, OR I have an X11 driver problem.  

As for X11, I have no xorg.conf (because that's what xorg devs told me to do), so I cannot have a configuration problem.  However, I do find that KDE does not allow me to enable compositing.  I have an ATI X1550 (RV516LE), and I'm (implicitly) using the Free driver.  

When I start up with the Air theme, I get what you see in the screenshot.  If I change the theme to something else and apply it, it fixes the problem, and the fix persists if I log out and back in.  If I then change the theme back to Air, the taskbar will then appear correct, but kwin crashes (consistently).  If I log out and back in, the display corruption problem returns.  (Note that changing themes in general tends to crash things.  Sometimes it's just kwin.  Sometimes, it's the whole desktop manager.  But the apps don't crash.)

Reproducible: Always

Portage (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.11-r1, 2.6.32-gentoo-r5 x86_64)
System uname: Linux-2.6.32-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9450_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 14 Feb 2010 08:00:01 +0000
app-shells/bash:     4.1_p2
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.1-r1
dev-util/cmake:      2.8.0-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20
sys-devel/gcc:       4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.32
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -march=core2 -ggdb -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -ggdb -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch"
LINGUAS="en en_US"
MAKEOPTS="--jobs=2 --load-average=6"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac aalib acl acpi alsa amd64 apache2 aspell autotrace bash-completion berkdb bidi bonjour bzip2 cairo cdda cdio cdr cli composite cracklib crypt ctype cups curl cxx dbus device-mapper dri dts dvd dvdr encode exif fbcon ffmpeg fftw filter flac fontconfig fortran freetype gcj gd gdbm git glib gmm gnutls gpm graphviz gs hal httpd iconv imagemagick ipp ipv6 ithreads jadetex java jpeg jpeg2k kde kde4 kerberos kvm lame lapack latex lcms ldap live lm_sensors lzma mad matroska mjpeg mkl mmx mng modules mp3 mpeg mudflap multilib mysql mysqli ncurses nls nptl nptlonly ogg oggvorbis openexr opengl openmp openssl pam pcre pdf perl php plasma plotutils png ppds pppd python qemu qt3support qt4 quicktime readline reflection rss ruby samba sasl secure-delete semantic-desktop session smp spl sql sse sse2 sse3 ssl stream subversion svg sysfs tcl tcpd theora threads thumbnail tiff tk truetype unicode utempter vcd vlm vnc vorbis webkit wxwindows x264 xcomposite xml xorg xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" 
Comment 1 Timothy Miller 2010-02-14 23:45:29 UTC
Created attachment 219729 [details]
Screen snapshot
Comment 2 Timothy Miller 2010-02-15 04:49:36 UTC
I noticed that some KDE packages were double-installed.  That is, there was a desktop themes package installed for both KDE 4.3.5 and 4.4.0.  So I did a depclean and then reinstalled all KDE 4.4 packages.  The problem persists.
Comment 3 Timothy Miller 2010-02-16 16:23:39 UTC
This is the upstream bug:
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2010-04-29 22:46:19 UTC
According to upstream bug this is still happening in 4.4.2
Comment 5 Andreas K. Hüttel archtester gentoo-dev 2010-05-28 22:16:27 UTC
Seen here too, in a vmware machine with 4.4.3
Comment 6 Andreas K. Hüttel archtester gentoo-dev 2010-06-05 14:26:24 UTC
Comment by Marco Martin in kde-bug 229721:

"it seems a problem with overlays and i didn't see it in trunk since ages several overlay caching issues were fixed in trunk, so it's very likely this is fixed. harder to test now since the panel doesn't have an overlay image anymore"

So it seems this will be gone in 4.5, but it's unclear which commit exactly fixed it...
Comment 7 Andreas K. Hüttel archtester gentoo-dev 2010-06-10 19:44:59 UTC
*** Bug 312091 has been marked as a duplicate of this bug. ***
Comment 8 Vicente Olivert Riera (RETIRED) gentoo-dev 2010-06-11 15:02:02 UTC
I don't have this problem with kde-4.4.4
Comment 9 dE 2010-06-12 15:51:29 UTC
You mean you had this problem before?
Comment 10 Andreas K. Hüttel archtester gentoo-dev 2010-06-16 18:38:34 UTC
Rereading the upstream bug report comments, I dont think we can actually do anything here (except wait for kde 4.5).

Since this is a fairly minor thing I'll resolve it as UPSTREAM...